Bug 628126 - unable to port Win XP KVM from f13 to f14
unable to port Win XP KVM from f13 to f14
Status: CLOSED DUPLICATE of bug 623957
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-27 23:26 EDT by Tom Horsley
Modified: 2013-01-09 06:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-28 08:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xml file saved from virsh dumpxml on fedora 13 system (1.73 KB, application/xml)
2010-08-27 23:27 EDT, Tom Horsley
no flags Details
The qemu log from the various attempts to run machine (4.38 KB, text/plain)
2010-08-27 23:29 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2010-08-27 23:26:07 EDT
Description of problem:

I have a nice qcow2 image of a Windows XP sp3 machine at a clean install
state. It worked (at least it did the last time I tried it) under fedora 13
qemu. When I do a "virsh define new-winxp.xml" to import the xml definition
I saved from fedora 13, I get the machine defined OK, but when I try to
start it, this happens:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 878, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1321, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error process exited while connecting to monitor: Supported machines are:
pc         Standard PC (alias of pc-0.13)
pc-0.13    Standard PC (default)
pc-0.12    Standard PC
pc-0.11    Standard PC, qemu 0.11
pc-0.10    Standard PC, qemu 0.10
isapc      ISA-only PC



Version-Release number of selected component (if applicable):

Here's all the packages that match qemu and virt:

qemu-kvm-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-common-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-img-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
gpxe-roms-qemu-1.0.1-1.fc14.noarch
qemu-system-x86-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
virt-viewer-0.2.1-1.fc13.x86_64
python-virtinst-0.500.4-1.fc14.noarch
libvirt-0.8.3-2.fc14.x86_64
virt-top-1.0.4-3.fc13.x86_64
redland-virtuoso-1.0.10-6.fc14.x86_64
libvirt-python-0.8.3-2.fc14.x86_64
libvirt-client-0.8.3-2.fc14.x86_64
virtuoso-opensource-6.1.2-1.fc14.x86_64
virt-manager-0.8.5-1.fc14.noarch
python-virtkey-0.50-8.fc14.x86_64


How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
broken stuff

Expected results:
running win XP KVM

Additional info:
Comment 1 Tom Horsley 2010-08-27 23:27:25 EDT
Created attachment 441644 [details]
xml file saved from virsh dumpxml on fedora 13 system
Comment 2 Tom Horsley 2010-08-27 23:29:57 EDT
Created attachment 441645 [details]
The qemu log from the various attempts to run machine
Comment 3 Tom Horsley 2010-08-28 08:25:45 EDT
Didn't find bug 623957 when I searched earlier, but now I see this is the same.

*** This bug has been marked as a duplicate of bug 623957 ***

Note You need to log in before you can comment on or make changes to this bug.