Bug 623957 - Machine type of 'fedora-13' is no longer supported
Machine type of 'fedora-13' is no longer supported
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 623970 628126 643982 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 05:29 EDT by Matthew Booth
Modified: 2013-01-09 06:38 EST (History)
23 users (show)

See Also:
Fixed In Version: spice-0.6.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 02:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2010-08-13 05:29:19 EDT
Description of problem:
I'm running fedora-virt-preview on F13.

None of my guests start without modification after the most recent libvirt update. They all have /domain/os/@machine='fedora-13'. Attempting to start any guest gives a qemu error:

# virsh start rhel6-v2v
error: Failed to start domain rhel6-v2v
error: internal error Process exited while reading console log output: Supported machines are:
pc         Standard PC (alias of pc-0.13)
pc-0.13    Standard PC (default)
pc-0.12    Standard PC
pc-0.11    Standard PC, qemu 0.11
pc-0.10    Standard PC, qemu 0.10
isapc      ISA-only PC

The workaround is obvious, however this interface must be stable across updates.

Version-Release number of selected component (if applicable):
libvirt-0.8.2-3.fc13.x86_64
Comment 1 Daniel Berrange 2010-08-13 07:51:40 EDT
*** Bug 623970 has been marked as a duplicate of this bug. ***
Comment 2 Frank Murphy 2010-08-18 09:50:13 EDT
(In reply to comment #0)
> Description of problem:
> I'm running fedora-virt-preview on F13.
> 
> The workaround is obvious, however this interface must be stable across
> updates.

What's the workaround, I've upped the host to F14rc4+ all updates.
Comment 3 Matthew Booth 2010-08-18 09:57:56 EDT
(In reply to comment #2)
> > The workaround is obvious, however this interface must be stable across
> > updates.
> 
> What's the workaround, I've upped the host to F14rc4+ all updates.

virsh edit <domain>, and change the machine type to 'pc'.
Comment 4 Justin M. Forbes 2010-08-18 10:34:13 EDT
A patch introduced the fedora-13 machine type to ensure support for virtio-net and virtio-serial which were realistically pc-0.13 features.  In hind sight, this patch should not have been applied, but we need to support it now.  I will get new builds out which support the fedora-13 machine type, and we will carry this patch through F15 to ensure that guests are supported through the standard upgrade cycles.
Ideally, if you have already hit this bug, it is ideal that you change your machine type to pc-0.13 to avoid issues should the guests survive past F15.
Comment 5 Tom Horsley 2010-08-28 08:25:45 EDT
*** Bug 628126 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-09-14 17:33:43 EDT
spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.6.rc1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.6.rc1.fc14
Comment 7 Fedora Update System 2010-09-15 02:53:28 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.6.rc1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice spice-protocol qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.6.rc1.fc14
Comment 8 Fedora Update System 2010-09-22 14:42:30 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice spice-protocol qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14
Comment 9 Fedora Update System 2010-09-30 02:10:10 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Chris Lalancette 2010-10-19 18:06:22 EDT
*** Bug 643982 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.