Bug 628345 - [abrt] crash in Miro-3.0.2-1.fc13: player.py:55:skip_forward:TypeError: unsupported operand type(s) for /: 'NoneType' and 'NoneType'
Summary: [abrt] crash in Miro-3.0.2-1.fc13: player.py:55:skip_forward:TypeError: unsup...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1b3967a5
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-29 15:27 UTC by aten
Modified: 2010-09-15 05:53 UTC (History)
3 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 05:38:58 UTC


Attachments (Terms of Use)
File: backtrace (1.63 KB, text/plain)
2010-08-29 15:27 UTC, aten
no flags Details

Description aten 2010-08-29 15:27:50 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/miro.real
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.33.6-147.fc13.x86_64
package: Miro-3.0.2-1.fc13
reason: player.py:55:skip_forward:TypeError: unsupported operand type(s) for /: 'NoneType' and 'NoneType'
release: Fedora release 13 (Goddard)
How to reproduce: just plyed video. Miro continued to work as if nothing happened but abrtd was triggered

backtrace
-----
player.py:55:skip_forward:TypeError: unsupported operand type(s) for /: 'NoneType' and 'NoneType'

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/window.py", line 122, in do_key_press_event
    return WrappedWindow.do_key_press_event(self, event)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/window.py", line 108, in do_key_press_event
    if wrappermap.wrapper(self).emit('key-press', key, modifiers):
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 155, in emit
    if callback.invoke(self, args):
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 89, in invoke
    return callback(obj, *(args + self.extra_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/application.py", line 152, in on_key_press
    return playback.handle_key_press(key, mods)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/playback.py", line 622, in handle_key_press
    app.widgetapp.on_skip_forward()
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/application.py", line 274, in on_skip_forward
    app.playback_manager.skip_forward()
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/playback.py", line 498, in skip_forward
    self.player.skip_forward()
  File "/usr/lib64/python2.6/site-packages/miro/player.py", line 55, in skip_forward
    self.seek_to(pos / duration)
TypeError: unsupported operand type(s) for /: 'NoneType' and 'NoneType'

Local variables in innermost frame:
duration: None
current: 0
self: <miro.frontends.widgets.gtk.video.VideoPlayer object at 0x7f850c336510>
pos: None

Comment 1 aten 2010-08-29 15:27:53 UTC
Created an attachment (id=441804)
File: backtrace

Comment 2 aten 2010-08-29 16:01:01 UTC
Package: Miro-3.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
just plyed video. Miro continued to work as if nothing happened but abrtd was triggered

Comment 3 Alex Lancaster 2010-08-29 16:57:02 UTC
*** Bug 628353 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-08-29 17:21:23 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 5 Fedora Update System 2010-08-29 17:28:21 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 6 Fedora Update System 2010-08-29 17:32:30 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 7 will kahn-greene 2010-08-30 13:08:21 UTC
I can't reproduce this issue, but it looks like the code in Miro 3.0.3 still has the issue.

The code that will eventually be Miro 3.5 checks for None before doing anything, so this should be fixed in Miro 3.5.

Comment 8 Fedora Update System 2010-08-31 06:29:59 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 9 Fedora Update System 2010-09-15 05:36:06 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-09-15 05:51:05 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.