Bug 628424 - Cannot upgrade moodle: error: unpacking of archive failed on file /var/www/moodle/web/auth/cas: cpio: rename
Summary: Cannot upgrade moodle: error: unpacking of archive failed on file /var/www/mo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: moodle
Version: 13
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 631998 (view as bug list)
Depends On:
Blocks: 696806
TreeView+ depends on / blocked
 
Reported: 2010-08-30 02:50 UTC by Basil Mohamed Gohar
Modified: 2011-04-14 21:31 UTC (History)
2 users (show)

Fixed In Version: moodle-1.9.9-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 696806 (view as bug list)
Environment:
Last Closed: 2010-10-22 18:02:33 UTC
Type: ---


Attachments (Terms of Use)

Description Basil Mohamed Gohar 2010-08-30 02:50:00 UTC
Description of problem:

yum upgrade of Moodle fails for version 1.9.9-2

Running Transaction
etckeeper: pre transaction commit
  Updating       : moodle-1.9.9-2.fc13.noarch                                                                                                                                                                                                                              1/2 
Error unpacking rpm package moodle-1.9.9-2.fc13.noarch
error: unpacking of archive failed on file /var/www/moodle/web/auth/cas: cpio: rename

Comment 1 Basil Mohamed Gohar 2010-08-30 02:50:43 UTC
Note, on another system that had this problem, uninstalling and reinstalling Moodle works fine, so it appears to be an upgrade-specific problem.

Comment 2 Todd Zullinger 2010-09-21 00:06:34 UTC
I think this is a nasty problem.  It affects the EPEL packages as well, it would seem:

$ sudo yum update moodle
...
Error unpacking rpm package moodle-1.8.13-2.el5.noarch
error: unpacking of archive failed on file /var/www/moodle/web/auth/cas: cpio: rename

Failed:
  moodle.noarch 0:1.8.13-2.el5

$ rpm -qf /var/www/moodle/web/auth/cas
moodle-1.8.12-1.el5.noarch

$ file /var/www/moodle/web/auth/cas
/var/www/moodle/web/auth/cas: directory

$ rpm -qplv moodle-1.8.13-2.el5.noarch.rpm | grep /var/www/moodle/web/auth/cas
lrwxrwxrwx    1 root    root               16 Aug 20 08:40 /var/www/moodle/web/auth/cas -> /usr/share/pear/

Happy to file a seperate EPEL bug if desired.  But the issue is the same, replacing a directory with a symlink is a painful process with rpm.

Comment 3 Todd Zullinger 2010-09-21 00:14:16 UTC
*** Bug 631998 has been marked as a duplicate of this bug. ***

Comment 4 Gwyn Ciesla 2010-10-04 14:26:20 UTC
Sorry for the delay.  It was a one-character typo.  If the rawhide build works for you, I'll push the fix everywhere.

Comment 5 Fedora Update System 2010-10-12 15:48:52 UTC
moodle-1.9.9-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/moodle-1.9.9-3.fc14

Comment 6 Fedora Update System 2010-10-12 15:48:58 UTC
moodle-1.9.9-3.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/moodle-1.9.9-3.fc12

Comment 7 Fedora Update System 2010-10-12 15:49:04 UTC
moodle-1.8.13-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/moodle-1.8.13-3.el5

Comment 8 Fedora Update System 2010-10-12 15:49:11 UTC
moodle-1.9.9-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/moodle-1.9.9-3.fc13

Comment 9 Fedora Update System 2010-10-13 05:54:54 UTC
moodle-1.8.13-3.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update moodle'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/moodle-1.8.13-3.el5

Comment 10 Fedora Update System 2010-10-22 18:02:28 UTC
moodle-1.9.9-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-10-22 18:06:11 UTC
moodle-1.9.9-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-10-27 19:10:12 UTC
moodle-1.8.13-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-10-28 05:53:02 UTC
moodle-1.9.9-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.