Bug 62845 - default locale causes X errors
default locale causes X errors
Status: CLOSED DUPLICATE of bug 62844
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-06 00:38 EST by Chris Ricker
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-06 00:39:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-04-06 00:38:59 EST
anaconda creates, by default, /etc/sysconfig/i18n with the following contents:

LANG="en_US.iso885915"
SUPPORTED="en_US.iso885915:en_US:en"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

This causes major problems with X.  The window manager I use (fluxbox) would not
start (reporting errors about X not supporting the specified locale),
applications reported failures loading default fonts, etc.  It acted as if the
locale en_US.iso885915 was bogus.  After I edited /etc/sysconfig/i18n and
changed all en_US.iso885915 to just en_US, everything worked correctly.
Comment 1 Jeremy Katz 2002-04-06 12:41:42 EST

*** This bug has been marked as a duplicate of 62844 ***

Note You need to log in before you can comment on or make changes to this bug.