Bug 62844 - LANG setting breaks X when X started manually
LANG setting breaks X when X started manually
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 62782 62845 62863 62877 62913 62918 62931 62957 63129 63486 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-06 00:35 EST by Jay Berkenbilt
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 15:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-04-06 00:35:48 EST
Description of Problem:

I have installed Skipjack beta-2 using US-English as my language environment. 
My /etc/sysconfig/i18n file looks like this;

LANG="en_US.iso885915"
SUPPORTED="en_US.iso885915:en_US:en"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

The file /etc/profile.d/lang.sh sets LANG on the basis of this file.  Some file,
perhaps /etc/X11/xinit/xinitrc.d/xinput, results in LANG being set to en_US
instead of en-US.iso885915 under certain circumstances including booting into
runlevel 5 and logging in via gdm.

If one attempts to start X with LANG (or perhaps other locale-related variables)
set to en-US.iso885915, you receive multiple instances of this warning:

Warning: locale not supported by Xlib, locale set to C

and some things don't work properly, especially in the area of displaying strings.

Version-Release number of selected component (if applicable):

initscripts-6.61-1, xinitrc-3.20-1

How Reproducible:

always

Steps to Reproduce:
1. boot into runlevel 3
2. log in on the console
3. start X with xinit
4. observe on the vc from which X was started the above warning
5. run twm &
6. notice the title is "Untitled"

Actual Results:

The value of LANG is set to something that is not supported under X

Expected Results:

LANG should be adjusted appropriately within X regardless of whether X was
started by gdm or in some other way.

Additional Information:

I hope my attempt at analysis has not obscured the problem.  It seems that the
whole way in which LANG is set in or out of X is fairly involved and is spread
across multiple locations.  The main issue is that LANG is set badly in X not
started from prefdm (or something similar to that).  This problem was introduced
between skipjack beta-1 and beta-2.
Comment 1 Jeremy Katz 2002-04-06 12:40:41 EST
Already fixed in anaconda CVS...  iso15 added to the wrong field in the
lang-table so LANG got set to the bogus value instead of just changing SYSFONTACM.

Fix is to just change LANG in /etc/sysconfig/i18n to en_US.
Comment 2 Jeremy Katz 2002-04-06 12:41:37 EST
*** Bug 62845 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-04-06 12:49:38 EST
*** Bug 62863 has been marked as a duplicate of this bug. ***
Comment 4 Bob Cochran 2002-04-06 23:32:13 EST
This error also occurs using a graphical login to Gnome. Correcting
/etc/sysconfig/i18n to the same values listed in the equivalent RH 7.2 (Enigma)
/etc/sysconfig/i18n file do not correct this problem.
Comment 5 Jeremy Katz 2002-04-07 15:55:58 EDT
*** Bug 62918 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-04-07 15:57:47 EDT
*** Bug 62913 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-04-07 15:58:14 EDT
*** Bug 62877 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-04-07 16:00:07 EDT
*** Bug 62782 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2002-04-07 20:14:52 EDT
*** Bug 62931 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2002-04-08 12:30:06 EDT
*** Bug 62957 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2002-04-09 15:41:46 EDT
*** Bug 62846 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2002-04-09 19:01:30 EDT
Confirmed fix.
Comment 13 Bill Nottingham 2002-04-10 18:14:10 EDT
*** Bug 63129 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2002-04-14 17:33:58 EDT
*** Bug 63486 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.