Bug 62846 - ending ^G in i18n breaks all shell stuff
ending ^G in i18n breaks all shell stuff
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: locale_config (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-06 00:53 EST by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 12:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-04-06 00:53:18 EST
By default, the system created an /etc/sysconfig/i18n that looked like:

LANG="en_US.iso885915"
SUPPORTED="en_US.iso885915:en_US:en"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

Since the .iso885915 stuff broke a lot of things, I used locale_config to switch
to en_US.  The resulting /etc/i18n file ended with a "^G", which subsequently
broke essentially all shell actions.  Removing the ^G fixed the problems.

There's a fairly similar bug filed against rh7.2, though in that one, ^Y was the
trailing character....
Comment 1 Bill Nottingham 2002-04-09 15:41:51 EDT

*** This bug has been marked as a duplicate of 62844 ***
Comment 2 Bill Nottingham 2002-04-09 15:42:21 EDT
Whoops, never mind. Need to read the *whole* bug.
Comment 3 Owen Taylor 2002-04-10 12:41:19 EDT
Fixed in CVS/0.3.4, package still needs to be moved to dist-7.3

Note You need to log in before you can comment on or make changes to this bug.