Bug 628926 - meego spin does not build
meego spin does not build
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-31 08:36 EDT by Daniel Walsh
Modified: 2010-09-22 16:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 16:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2010-08-31 08:36:47 EDT
livecd-creator -c fedora-livecd-meego.ks 
mke2fs 1.41.12 (17-May-2010)
Filesystem label=_fedora-livec-x8
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
262144 inodes, 1048576 blocks
10485 blocks (1.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1073741824
32 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 29 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.41.12 (17-May-2010)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
Retrieving http://download.fedora.devel.redhat.com/pub/fedora/linux/development/rawhide/x86_64/os/repodata/repomd.xml ...OK
Retrieving http://download.fedora.devel.redhat.com/pub/fedora/linux/development/rawhide/x86_64/os/repodata/51f311936b54257bf206d730ac487cb2b11b7e18853273a298001e537d600375-primary.sqlite.bz2 ...OK
Retrieving http://download.fedora.devel.redhat.com/pub/fedora/linux/development/rawhide/x86_64/os/repodata/cc06907ffc41e558e86be1744fd7b68d19505c54c4c82ba7be7a813f7237b0da-comps-rawhide.xml.gz ...OK
No such package unix2dos to remove
Error creating Live CD : Failed to build transaction : moblin-panel-status-0.1.21-5.fc14.x86_64 requires libsocialweb-client.so.1()(64bit)
moblin-panel-myzone-0.1.34-2.fc14.x86_64 requires libsocialweb-client.so.1()(64bit)
firefox conflicts with xulrunner
Comment 1 Daniel Walsh 2010-08-31 08:37:09 EDT
spin-kickstarts-0.14.1-1.fc14.noarch
Comment 2 Bruno Wolff III 2010-08-31 08:55:55 EDT
This looks like a file conflict problem in rawhide. You'd probably get a successful build with F14 development repository as the nightly composes are working.
You can add a repo command to over ride the one from the included fedora-live-mini.ks file. You need to name it the same, but have it refer to F14.
They'll be another kickstart package built before beta (around sept 7) that will default to the current release of the system you build from and that has some other changes.
Typically we do tests pulling from the git repo and with the resulting ISOs at:
http://alt.fedoraproject.org/pub/alt/nightly-composes
Depending on what you are testing that can be a good place to get the last successful build. As this case shows, when there are dependency conflicts in the repo you want to test, you can't do builds. (In some cases you can exclude some broken packages if they aren't key to a spin or at least what you are testing.)
Comment 3 Peter Robinson 2010-08-31 09:13:24 EDT
This is a known problem with F-15 rawhide builds. Its partially Meego 1.0 and partially 1.1 and hence the dependency problems. I'm slowly working through them all but I have very little time at the moment.
Comment 4 Peter Robinson 2010-09-22 16:26:03 EDT
Closing this as the image is now building. There's still issue that related to bug 628921 but I hope to have that fixed soon.

Note You need to log in before you can comment on or make changes to this bug.