Bug 62895 - upgrading ypserv can overwrite user-seetings in /var/yp/Makefile
Summary: upgrading ypserv can overwrite user-seetings in /var/yp/Makefile
Status: CLOSED DUPLICATE of bug 60377
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ypserv (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-07 11:30 UTC by Bernhard Weisshuhn
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-07 11:30:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Weisshuhn 2002-04-07 11:30:54 UTC
Description of problem:
Upgrades of ypserv overwrite /var/yp/Makefile which may contain customized
Infomation (which maps to build, NOPUSH etc)

Version-Release number of selected component (if applicable): ypserv-2.2-7


How reproducible:
Sometimes

Steps to Reproduce:
install yperv-2.2.3, edit /var/yp/Makefile, upgrade to ypserv-2.2.7.

Actual Results:  Changes in /var/yp/Makefile are lost.

Expected Results:  new Makefile should be created as /var/yp/Makefile.rpmnew, or
at least the old version should be preserved as Makefile.rpmold

Additional info:

When I tried to reproduce it, my changes to Makefile were preserved, but no
rpmnew was created. But I know that I lost my changes when I upgraded from 2.2.3
to 2.2.7. Sorry to be so vague on this.

The obvious fix should be to make /var/yp/Makefile %config(noreplace) in the
specfile.

Comment 1 Alexander Larsson 2002-04-07 21:42:16 UTC

*** This bug has been marked as a duplicate of 60377 ***


Note You need to log in before you can comment on or make changes to this bug.