Bug 629437 - lua: please update to version-release >= 8.1.4-2
Summary: lua: please update to version-release >= 8.1.4-2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: lua
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: rob
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: UpdatePackage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-02 01:19 UTC by Jose Pedro Oliveira
Modified: 2010-10-26 18:01 UTC (History)
6 users (show)

Fixed In Version: lua-5.1.4-4.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-26 18:01:29 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 495095 low CLOSED pkg-config reports wrong --libs output for lua-devel in EPEL on 64-bit OS 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 499238 low CLOSED liblua-5.1.so missing -lm dependency, lua.spec fix provided 2020-10-14 00:28:05 UTC

Description Jose Pedro Oliveira 2010-09-02 01:19:39 UTC
Description of problem
The current lua version in EPEL5 (lua-5.1.2-1.el5) has two problems:

 * #495095 - pkg-config reports wrong --libs ...
 * #499238 - liblua-5.1.so missing -lm dependency

And both problems can be eliminated by updating to a more recent lua RPM (fedora lua RPM >= 5.1.4-2).

Version-Release number of selected component (if applicable):
lua-5.1.2-1.el5


Expected results:
To have lua >= lua-5.1.4-2 in the EPEL5 repository

Comment 1 Kevin Fenzi 2010-10-02 04:44:51 UTC
ok. I took a look at fixing this. 

I had to tweak the patch thats available in the master branch for some reason, but I think I have a package that will work. 

Can you please test: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=2507529

I'd love some feedback before pushing this as an update. Thanks.

Comment 2 Jose Pedro Oliveira 2010-10-02 10:49:00 UTC
(In reply to comment #1)
> ok. I took a look at fixing this. 
> 
> I had to tweak the patch thats available in the master branch for some reason,
> but I think I have a package that will work. 
> 
> Can you please test: 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2507529
> 
> I'd love some feedback before pushing this as an update. Thanks.

Kevin,

Where can I download the SRPM or your patch/spefile?

Note: I can't locate the SRPM in koji (I can only locate the binary RPMS).  Did you commit the changes to git? I don't see any recent commits in http://pkgs.fedoraproject.org/gitweb/?p=lua.git;a=summary .


/jpo

BTW: I have rebuilt the F12 lua SRPM for my EPEL5 boxes (lua-5.1.4-4.fc12.src.rpm from http://koji.fedoraproject.org/koji/buildinfo?buildID=119525)

Comment 4 rob 2010-10-02 11:21:20 UTC
Kevin,

Thanks for taking a look at this.  I apologize for not getting around to it; I simply don't have time these days.  lua is open for provenpackagers to commit but if anyone else wants to take ownership of the EPEL branches let me know since it would probably be appropriate for me to release ownership.

Comment 5 Jose Pedro Oliveira 2010-10-02 13:45:31 UTC
(In reply to comment #3)
> http://koji.fedoraproject.org/koji/getfile?taskID=2507530&name=lua-5.1.4-1.el5.src.rpm

Thanks Mark.

Comment 6 Jose Pedro Oliveira 2010-10-02 15:00:56 UTC
Kevin,

Wouldn't it be better to just sync the fc12 branch to el5? The RHEL6 SRPM is basically the same as the Fedora 12 one.  They have the same patch and the  only specfile difference is a build bump. It shouldn't cause suprises (no modified patch and no second patch).

----------
diff -ruN lua-5.1.4-4.fc12.src/lua.spec lua-5.1.4-4.1.el6.src/lua.spec
--- lua-5.1.4-4.fc12.src/lua.spec       2009-07-27 00:59:33.000000000 +0100
+++ lua-5.1.4-4.1.el6.src/lua.spec      2009-12-04 17:06:43.000000000 +0000
@@ -1,6 +1,6 @@
 Name:           lua
 Version:        5.1.4
-Release:        4%{?dist}
+Release:        4.1%{?dist}
 Summary:        Powerful light-weight programming language
 Group:          Development/Languages
 License:        MIT
@@ -94,6 +94,9 @@
 %{_libdir}/*.a
 
 %changelog
+* Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 5.1.4-4.1
+- Rebuilt for RHEL 6
+
 * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.4-4
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
 
----------
$ rpm -qplv lua-5.1.4-4.fc12.src.rpm
-rw-r--r--    1 mockbuilmockbuil      1443398 Sep  3  2008 lua-5.1.4-autotoolize.patch
-rw-rw-r--    1 mockbuilmockbuil       216679 Sep  3  2008 lua-5.1.4.tar.gz
-rw-r--r--    1 mockbuilmockbuil         6784 Jul 27  2009 lua.spec
----------
$ rpm -qplv lua-5.1.4-4.1.el6.src.rpm 
-rw-r--r--    1 mockbuilmockbuil      1443398 May 20  2009 lua-5.1.4-autotoolize.patch
-rw-rw-r--    1 mockbuilmockbuil       216679 May 20  2009 lua-5.1.4.tar.gz
-rw-r--r--    1 mockbuilmockbuil         6877 Dec  4  2009 lua.spec
----------

Links:

Fedora 12 SRPM:
http://koji.fedoraproject.org/koji/buildinfo?buildID=119525

RHEL6 SRPM:
ftp://ftp.redhat.com/pub/redhat/rhel/beta/6Server-beta2/source/SRPMS/lua-5.1.4-4.1.el6.src.rpm


/jpo

Comment 7 Kevin Fenzi 2010-10-02 18:03:32 UTC
>Wouldn't it be better to just sync the fc12 branch to el5? The RHEL6 SRPM is
>basically the same as the Fedora 12 one.  They have the same patch and the 
>only specfile difference is a build bump. It shouldn't cause suprises (no
>modified patch and no second patch).

I tried that first. I have no idea at all how the el6 or f12 packages build. They all fail here trying to patch luaconf.h. 

See for example: http://koji.fedoraproject.org/koji/taskinfo?taskID=2508318

I simply removed the patch part that deals with removing the luaconf.h file and it builds fine.

Comment 8 Jose Pedro Oliveira 2010-10-02 18:46:25 UTC
(In reply to comment #7)
> >Wouldn't it be better to just sync the fc12 branch to el5? The RHEL6 SRPM is
> >basically the same as the Fedora 12 one.  They have the same patch and the 
> >only specfile difference is a build bump. It shouldn't cause suprises (no
> >modified patch and no second patch).
> 
> I tried that first. I have no idea at all how the el6 or f12 packages build.
> They all fail here trying to patch luaconf.h. 
> 
> See for example: http://koji.fedoraproject.org/koji/taskinfo?taskID=2508318
> 
> I simply removed the patch part that deals with removing the luaconf.h file and
> it builds fine.

Strange! I have no problem building it locally in mock for i386 and x86_64 archs
(base system: CentOS 5.5 x86_64 + mock-1.0.7-1.el5):

Prep steps:
 * rpm -i --nomd5 lua-5.1.4-4.fc12.src.rpm
 * rpmbuild -bs --nodeps lua.spec

Build step:
 * mock -r epel-5-x86_64 <...>/SRPMS/lua-5.1.4-4.src.rpm
 * mock -r epel-5-i386 <...>/SRPMS/lua-5.1.4-4.src.rpm

Comment 9 Kevin Fenzi 2010-10-02 18:52:20 UTC
It could be some strange artifact of my using a rawhide machine to make the srpms. ;( 

If you can get it building fine like that, I'd say go ahead and commit and push the update?

Comment 10 Jose Pedro Oliveira 2010-10-03 14:31:36 UTC
The lua-5.1.4-autotoolize.patch file available in the SRPMS differs from the one available in git but the change appears to be safe (different expansions of the $Id$ cvs keyword).


MD5 digests:

Patch from the SRPMs availabe in the mirrors:
4e0c6e69ef33c2a682f8cfcebf208c6c  lua-5.1.4-autotoolize.patch_from.el6.srpm
4e0c6e69ef33c2a682f8cfcebf208c6c  lua-5.1.4-autotoolize.patch_from.fc12.srpm

Patch from git
a5ef2e026f61acc177c9635c7e43214f  lua-5.1.4-autotoolize.patch_from.f12.git.branch
a5ef2e026f61acc177c9635c7e43214f  lua-5.1.4-autotoolize.patch_from.f13.git.branch


Diff
----------
$ diff -u lua-5.1.4-autotoolize.patch_from.fc12.sources.repo lua-5.1.4-autotoolize.patch_from.f12.git.branch
--- lua-5.1.4-autotoolize.patch_from.fc12.sources.repo  2008-09-03 13:27:55.000000000 +0100
+++ lua-5.1.4-autotoolize.patch_from.f12.git.branch     2010-10-03 15:17:24.432627950 +0100
@@ -40946,7 +40946,7 @@
 +++ lua-5.1.4-autotoolize/src/luaconf.h        2008-09-03 13:25:45.000000000 +0200
 @@ -1,763 +0,0 @@
 -/*
--** $Id: luaconf.h,v 1.82.1.7 2008/02/11 16:25:08 roberto Exp $
+-** $Id: lua-5.1.4-autotoolize.patch,v 1.1 2008/09/03 12:27:55 timn Exp $
 -** Configuration file for Lua
 -** See Copyright Notice in lua.h
 -*/
@@ -41713,7 +41713,7 @@
 +++ lua-5.1.4-autotoolize/src/luaconf.h.template.in    2008-09-03 13:18:37.000000000 +0200
 @@ -0,0 +1,754 @@
 +/*
-+** $Id: luaconf.h,v 1.81 2006/02/10 17:44:06 roberto Exp $
++** $Id: lua-5.1.4-autotoolize.patch,v 1.1 2008/09/03 12:27:55 timn Exp $
 +** Configuration file for Lua
 +** See Copyright Notice in lua.h
 +*/
----------

Comment 11 Jose Pedro Oliveira 2010-10-03 14:37:21 UTC
(In reply to comment #9)
> It could be some strange artifact of my using a rawhide machine to make the
> srpms. ;( 

Maybe caused by the gcc breakage? 

> If you can get it building fine like that, I'd say go ahead and commit and push
> the update?


I can build the F12 SRPM without problems in:

 * CentOS (i386 and x86_64): mock and locally
 * Fedora 13 x86_64: mock
 * RHEL 6 Beta 2 refresh x86_64: mock

So +1 for importing its contents (patch + specfile) for the el5 branch and have it build for EPEL5 testing.  But it would be great if someone else could also test it.

/jpo

Comment 12 Kevin Fenzi 2010-10-05 03:16:48 UTC
Just to confirm, this is due to the cvs->git conversion. It slightly modified the patch file so it no longer applies. ;) 

I am going to see about getting it re-converted correctly.

Comment 13 Kevin Fenzi 2010-10-07 04:18:01 UTC
ok. I got it re-converted and the patch fixed, then copied over the f12 changes to el5. ;) 

Update will be along shortly.

Comment 14 Fedora Update System 2010-10-07 04:32:32 UTC
lua-5.1.4-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/lua-5.1.4-4.el5

Comment 15 Jose Pedro Oliveira 2010-10-07 16:07:01 UTC
Kevin,

Thanks for the EPEL5 build
( http://koji.fedoraproject.org/koji/buildinfo?buildID=199439 ) .

For the record: MD5 digest of the EPEL5 and F12 SRPMs

$ rpmdev-md5  lua-5.1.4-4.fc12.src.rpm
8dede2d17f58fd957caa0b6a076af547  lua-5.1.4-4.fc12.src.rpm
4e0c6e69ef33c2a682f8cfcebf208c6c  lua-5.1.4-autotoolize.patch
d0870f2de55d59c1c8419f36e8fac150  lua-5.1.4.tar.gz
a5224e01a1c23319f0b4be1838004e4c  lua.spec

$ rpmdev-md5  lua-5.1.4-4.el5.src.rpm      # downloaded from the koji page above
5044bfdcd07aa50e411779d95c95f752  lua-5.1.4-4.el5.src.rpm
4e0c6e69ef33c2a682f8cfcebf208c6c  lua-5.1.4-autotoolize.patch
d0870f2de55d59c1c8419f36e8fac150  lua-5.1.4.tar.gz
a5224e01a1c23319f0b4be1838004e4c  lua.spec

/jpo

Comment 16 Jose Pedro Oliveira 2010-10-07 16:53:03 UTC
And now for some bad news:

 * the configure.ac file inside the patch file lua-5.1.4-autotoolize.patch
   has the wrong lua version (5.1.3):

   Line 30994
   AC_INIT([Autotoolized Lua], [5.1.3], [], [lua-at])

   This causes at least problem: the wrong expansion of the Lua version
   in the .pc file. The second line of the pkgconfig file will list the
   lua version as 5.1.3 (instead of 5.1.4).

   This affects all lua-devel-5.1.4-* RPMS of Fedora{12,13,..} and EPEL{5,6}.

/jpo

Comment 17 Jose Pedro Oliveira 2010-10-07 17:09:02 UTC
(In reply to comment #16)
> And now for some bad news:
> 
>  * the configure.ac file inside the patch file lua-5.1.4-autotoolize.patch
>    has the wrong lua version (5.1.3):
> 
>    Line 30994
>    AC_INIT([Autotoolized Lua], [5.1.3], [], [lua-at])
> 
>    This causes at least problem: the wrong expansion of the Lua version
>    in the .pc file. The second line of the pkgconfig file will list the
>    lua version as 5.1.3 (instead of 5.1.4).
> 
>    This affects all lua-devel-5.1.4-* RPMS of Fedora{12,13,..} and EPEL{5,6}.

Correction: the lua.pc.in file inside the patch has the lua version hardcoded.

Comment 18 Kevin Fenzi 2010-10-07 17:13:35 UTC
nice. ;( 

Yeah, I see 5.1.3 in the pc file here on rawhide: 

% rpm -q lua-devel 
lua-devel-5.1.4-5.fc14.x86_64
% cat /usr/lib64/pkgconfig/lua.pc
V= 5.1
R= 5.1.3
prefix= /usr
exec_prefix=${prefix}
libdir= /usr/lib64
includedir=${prefix}/include

Name: Lua
Description: An Extensible Extension Language
Version: ${R}
Requires: 
Libs: -llua -lm -ldl
Cflags: -I${includedir}

So, yes, this needs to be fixed in all branches. ;(

Comment 19 Fedora Update System 2010-10-07 19:29:32 UTC
lua-5.1.4-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lua'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lua-5.1.4-4.el5

Comment 20 Jose Pedro Oliveira 2010-10-07 20:52:29 UTC
Created a new ticket (bug #641144) with a new updated patch for the problem mentioned in comment 16 (17 and 18).

Comment 21 Kevin Fenzi 2010-10-10 19:14:09 UTC
The fedora lua maintainer should be back around in the next few days. 

I will wait and let them comment on bug 641144, and then likely will update the epel package to match. 

Thanks for all the testing on this!

Comment 22 Jose Pedro Oliveira 2010-10-26 00:19:20 UTC
Kevin,

Could you change the lua epel5 rpms status from testing to stable?

tia,
jpo

Comment 23 Kevin Fenzi 2010-10-26 03:56:46 UTC
Sure, done. 

We still probibly should push an update with the revised 5.1.4 auto* patch.

Comment 24 Jose Pedro Oliveira 2010-10-26 09:26:25 UTC
(In reply to comment #23)
> Sure, done. 

Thanks.

> We still probibly should push an update with the revised 5.1.4 auto* patch.

We should but the upgrade path in EPEL will be problematic as lua is a RHEL 6 core package (and the RHEL 6 Beta 2 Refresh NVR was lua-5.1.4-4.1.el6).

/jpo

Comment 25 Kevin Fenzi 2010-10-26 16:20:27 UTC
There's no need to care about upgrade path with EPEL. Upgrades from RHEL5 -> RHEL6 are not supported by upstream, they want you to do a clean install for dist upgrades.

Comment 26 Fedora Update System 2010-10-26 18:01:18 UTC
lua-5.1.4-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.