Bug 63002 - Programm crashes right after execution
Summary: Programm crashes right after execution
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: serviceconf (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
high
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
: 63003 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 02:22 UTC by Eric Khanukayev
Modified: 2007-03-27 03:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 19:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Khanukayev 2002-04-09 02:22:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020314
Netscape6/6.2.2

Description of problem:
When I execute serviceconf from command promt i get:
root@eric root # serviceconf
Traceback (innermost last):
  File "/usr/share/serviceconf/serviceconf.py", line 438, in ?
    main()
  File "/usr/share/serviceconf/serviceconf.py", line 429, in main
    Gui()
  File "/usr/share/serviceconf/serviceconf.py", line 139, in __init__
    self.on_clstServices_select_row(None, 0, 0, None)
  File "/usr/share/serviceconf/serviceconf.py", line 213, in
on_clstServices_select_row
    self.checking_service = self.clstServices.get_text(i,1)
  File "/usr/lib/python1.5/site-packages/gtk.py", line 1218, in get_text
    return _gtk.gtk_clist_get_text(self._o, r, c)
ValueError: can't get text value

When I execute the same program by double clicking on icon - 
window comes up then goes away(in a 2 seconds).

Please help

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just type in serviceconf - that's it
2.
3.
	

Additional info:

Comment 1 Bill Nottingham 2002-04-09 05:35:19 UTC
Does this persist with the version in rawhide?

Comment 2 Bill Nottingham 2002-04-09 05:35:31 UTC
*** Bug 63003 has been marked as a duplicate of this bug. ***

Comment 3 Eric Khanukayev 2002-04-12 04:11:28 UTC
What means rawhide?

Comment 4 Bill Nottingham 2002-04-12 15:25:28 UTC
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/

Daily (or pretty close to daily) snapshots of our development tree.

Comment 5 Eric Khanukayev 2002-05-29 19:57:34 UTC
It always happens, I have never been able to execute this programm

Comment 6 David Kaplan 2002-06-18 02:59:43 UTC
I am having the same problem.  This bug also seems to be a duplicate of several
other previous bugs.

I believe the problem is due to a service appearing twice - in init.d and in
xinet.d.  serviceconf has always worked for me and recently failed.  I assume
this is because I recently turned on identd in xinet.d.  It seems to get
confused when the service is off in init.d, but on in xinet.d.



Comment 7 David Kaplan 2002-06-18 03:03:53 UTC
I forgot to mention that I am running serviceconf-0.7.0-3.  I am reluctant to go
to rawhide as that would require my upgrading a large number of packages (or
going to Redhat 7.3 - I am running 7.2).  

Also, I am fairly convinced this problem is due to the service appearing twice.
 I removed the file /etc/xinet.d/identd and serviceconf functions fine.  


Comment 8 Daniel Walsh 2002-06-21 19:44:32 UTC
This bug has been fixed during the porting to python2/gtk2.  It will be in the
next release of RedHat Linux.  Currently the work around is to remove the entry
from /etc/xinet.d or /etc/init.d


Note You need to log in before you can comment on or make changes to this bug.