Bug 630087 - [6.1 FEAT] support for IEEE 802.1Qbg in lldpad
[6.1 FEAT] support for IEEE 802.1Qbg in lldpad
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lldpad (Show other bugs)
6.1
All All
high Severity high
: beta
: 6.1
Assigned To: Petr Šabata
qe-baseos-daemons
: FutureFeature, OtherQA
: 634004 (view as bug list)
Depends On:
Blocks: 538808 554529 580566 634001 635490 672453
  Show dependency treegraph
 
Reported: 2010-09-03 13:00 EDT by IBM Bug Proxy
Modified: 2011-05-19 07:52 EDT (History)
24 users (show)

See Also:
Fixed In Version: lldpad-0.9.38-8.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 07:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 66754 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-03 13:00:54 EDT
1. Feature Overview:
Feature Id: [66754]
a. Name of Feature: [6.1 FEAT] support for IEEE 802.1Qbg in lldpad
b. Feature Description
support for edge virtual bridging (EVB) and VSI discovery protocol (VDP, under standardization in
IEEE 802.1Qbg) in lldpad.

2. Feature Details:
Sponsor: LTC
Architectures:  x86, x86_64, 

Arch Specificity: both
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Direct from Community
Category: system management
Request Type: Toolchain - Enhancement from Upstream
d. Upstream Acceptance: Field does not exist
Sponsor Priority P2
f. Severity: high
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
In datacenter/cloud environments support for IEEE 802.1Qbg is required to register a large number of
guests and allow easier migration of guests with keeping the correct network connectivity.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie A. Glass, sglass@us.ibm.com

Technical contact(s):
Jens Osterkamp, Jens.Osterkamp@de.ibm.com
Comment 2 IBM Bug Proxy 2010-10-04 12:24:35 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:22 EDT-------
Code Upstream Status: Submitted
Comment 3 IBM Bug Proxy 2010-11-24 04:40:40 EST
------- Comment From jens@de.ibm.com 2010-11-24 04:33 EDT-------
The patches necessary to support this feature are:

- implement VDP keepalive
- do not use macv[tap/lan] interfaces as ports
- lldpad support for libvirt netlink message
- use connect instead of bind
- add libnl dependency to configure.ac
- VDP commandline interface
- implementation of IEEE 802.1Qbg in lldpad, part 2
- BUGFIX: check for existence of ifup
- implementation of IEEE 802.1Qbg in lldpad, part 1
- consolidation of MIN and MAX macros in common.h

All patches apply on top of lldpad 0.9.38, available as tarball from http://sourceforge.net/projects/e1000/files/DCB%20Tools/lldpad/0.9.38/.
They have been posted to e1000-eedc@lists.sourceforge.net, virtualization@lists.linux-foundation.org, cc: chrisw@redhat.com and are available from the archives at http://sourceforge.net/mailarchive/forum.php?forum_name=e1000-eedc or https://lists.linux-foundation.org/pipermail/virtualization/.

I am in contact with John Fastabend from Intel who is the maintainer of lldpad. He confirmed that the patches look good to him and he wants to include them into lldpad.
Comment 7 John Jarvis 2010-12-01 11:40:23 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 8 Gerhard Stenzel 2010-12-13 11:48:08 EST
(Adding the primary maintainer for lldpad to the CC list)

John, apologies for communicating via bugzilla, but can you provide a statement that you plan to include the patches from Jens real soon now in the upstream version of lldpad?

Thank you for your help,

Gerhard
Comment 9 john.r.fastabend 2010-12-23 00:18:40 EST
Hi, attached is a link to the lldpad git tree including the EVB patches provided by Jens.

git://open-lldp.org/lldp/open-lldp

The open-lldp.org web page content is out of date I will make a public announcement regarding open-lldp.org going live and upstream git repo after I have had a chance to update the content and our validation team has finished there testing of open-lldp.

I will be doing this after returning from the holidays. Feel free to ping me in the BZ or email me directly.

Thanks,
John.
Comment 10 IBM Bug Proxy 2011-01-06 09:50:47 EST
------- Comment From sglass@us.ibm.com 2011-01-06 09:48 EDT-------
Hi John,
Any update on when this will be upstream?

Thanks
Comment 11 John Jarvis 2011-01-06 12:55:32 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 12 john.r.fastabend 2011-01-10 11:33:43 EST
Patch set supplied by Jens has been applied to upstream open-lldp project and has passed our internal BAT testing. Available at,

git://open-lldp.org/lldp/open-lldp

Thanks,
John.
Comment 13 John Villalovos 2011-01-11 12:11:21 EST
*** Bug 634004 has been marked as a duplicate of this bug. ***
Comment 17 Petr Šabata 2011-02-02 12:01:10 EST
Done in CVS, lldpad-0.9.38-7.el6
Comment 18 Petr Šabata 2011-02-02 12:14:49 EST
CVS lldpad-0.9.38-8.el6: BR cleanup
Comment 19 Petr Pisar 2011-02-03 03:29:40 EST
Just reading the patch, there is lot of sprintf(obuf, "...%s...", ...) (in lldp_evb_cmds.c), I wonder if all such concatenations are verified they do not overflow the obuf. The obuf is pointer inside preallocated buffer of length MAX_CLIF_MSGBUF (ctrl_iface.c:ctrl_iface_receive()) and the appended strings are literals of the protocol with fixed size. I'm just curious.
Comment 20 IBM Bug Proxy 2011-02-03 07:01:15 EST
------- Comment From jens@de.ibm.com 2011-02-03 06:51 EDT-------
(In reply to comment #16)
> Just reading the patch, there is lot of sprintf(obuf, "...%s...", ...) (in
> lldp_evb_cmds.c), I wonder if all such concatenations are verified they do not
> overflow the obuf. The obuf is pointer inside preallocated buffer of length
> MAX_CLIF_MSGBUF (ctrl_iface.c:ctrl_iface_receive()) and the appended strings
> are literals of the protocol with fixed size. I'm just curious.

I don't think this is a problem for lldp_evb_cmds.c. All the get_* commands who write to obuf only use a few very well defined static strings. With 4096 bytes the buffer is much larger than the strings that are ever used.
Comment 23 IBM Bug Proxy 2011-02-24 07:41:18 EST
------- Comment From jens@de.ibm.com 2011-02-24 07:31 EDT-------
I verified that lldpad-0.9.41-1.el6.src.rpm contains the lldpad code from


up to

"commit 2c8344c5d2d8aed8f9f2d40191830571ffc69c63
Author: John Fastabend <john.r.fastabend@intel.com>
Date:   Mon Jan 10 18:35:01 2011 -0800

lldpad: version bump 0.9.40 -> 0.9.41

Addition of EVB and sanitized headers warrants a version bump.

Signed-off-by: John Fastabend <john.r.fastabend@intel.com>"

A separate bugzilla has been opened to include the fixes that have been submitted since.
Comment 25 Martin Cermak 2011-03-11 06:28:40 EST
Comments #14, #15, #24 => Conditions for setting SanityOnly have been met here. Setting Verified SanityOnly.
Comment 26 IBM Bug Proxy 2011-03-22 09:31:05 EDT
------- Comment From jens@de.ibm.com 2011-03-22 09:25 EDT-------
I verified that the IEEE 802.1Qbg is included in lldpad in RHEL6.1.
So from my point of view this request can be closed.
Comment 27 Chris Ward 2011-04-06 07:02:07 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 28 IBM Bug Proxy 2011-04-06 09:31:52 EDT
------- Comment From sglass@us.ibm.com 2011-04-06 09:20 EDT-------
This feature has been verified by IBM
Comment 30 Martin Cermak 2011-04-18 03:41:17 EDT
New patches have been added to the latest build, please test the next snapshot (lldpad-0.9.41-4.el6) and update us here with test results. Thanks.
Comment 31 IBM Bug Proxy 2011-04-27 15:32:16 EDT
------- Comment From jens@de.ibm.com 2011-04-27 15:12 EDT-------
(In reply to comment #23)
> New patches have been added to the latest build, please test the next snapshot
> (lldpad-0.9.41-4.el6) and update us here with test results. Thanks.

We verified that all upstream patches are in lldpad-0.9.41-4.el6. We have successfully tested it with snapshot 4 in our setup. Thanks !
Comment 32 errata-xmlrpc 2011-05-19 07:52:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0520.html

Note You need to log in before you can comment on or make changes to this bug.