Bug 630361 - spicec Warning: failed to parse message channel 2 type 304
spicec Warning: failed to parse message channel 2 type 304
Status: CLOSED DUPLICATE of bug 634535
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-04 20:05 EDT by Tom Horsley
Modified: 2011-04-14 03:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-14 03:44:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
qemu log file (10.82 KB, text/plain)
2010-09-15 20:09 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2010-09-04 20:05:09 EDT
Description of problem:

I'm trying to run a Windows XP KVM under spice. I have conned libvirt into
starting qemu-kvm with the arguments documented in the fedora 14 spice page
by writing a wrapper program that substitutes the -vnc and -vga arguments
with the spice args instead. That gives me a qemu-kvm running this this
command line:

/usr/bin/qemu-kvm -S -M pc-0.13 -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name newxp -uuid 56bf8244-94fc-c33b-5530-1c88082e992f -nodefconfig -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/newxp.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=localtime -boot c -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/zooty/images/new-winxp.img,if=none,id=drive-ide0-0-0,boot=on -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:89:73:85,bus=pci.0,addr=0x5 -net tap,fd=47,vlan=0,name=hostnet0 -usb -device usb-tablet,id=input0 -spice port=5930,disable-ticketing -vga qxl -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3

When I run spicec -h localhost -p 5930, I get a brief window popping up,
then it goes away and this message appears on stderr:

Warning: failed to parse message channel 2 type 304


Version-Release number of selected component (if applicable):
qemu-kvm-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-common-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-img-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
gpxe-roms-qemu-1.0.1-1.fc14.noarch
qemu-system-x86-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
spice-client-0.5.3-1.fc14.x86_64
spice-server-0.5.3-1.fc14.x86_64
libvirt-0.8.3-2.fc14.x86_64
libvirt-python-0.8.3-2.fc14.x86_64
libvirt-client-0.8.3-2.fc14.x86_64


How reproducible:
Seems to be every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
brief flicker, then error message

Expected results:
VGA display of my windows box where I can download and install the spice
drivers to try out high performance spice video.

Additional info:

I find it easy to believe I am missing something, but the available docs
are rather thin, so I figured I'd submit this bug anyway in case this is
a real error.
Comment 1 Tom Horsley 2010-09-15 20:02:16 EDT
OK, I've just updated lots of stuff from updates-testing and tried to
run spice again. This time I do get a window, but it is about the
size of my fingernail, and can't be resized. It is basically nothing
but top title bar and bottom margin window manager decorations. With
a small amount of the left side of the letter "S" showing in the title
bar.

Once again, I am running the virtual machine under libvirt with a wrapper
program to swap out the default libvirt vga and vnc args and swap in the
spice args. The command like that sows up in ps is:

/usr/bin/qemu-kvm -S -M pc-0.13 -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name newxp -uuid 56bf8244-94fc-c33b-5530-1c88082e992f -nodefconfig -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/newxp.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=localtime -boot c -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/zooty/images/new-winxp.img,if=none,id=drive-ide0-0-0,boot=on -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:89:73:85,bus=pci.0,addr=0x5 -net tap,fd=46,vlan=0,name=hostnet0 -usb -device usb-tablet,id=input0 -spice port=5930,disable-ticketing -vga qxl -device AC97,id=sound0,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3

packages currently installed:

qemu-common-0.13.0-0.6.rc1.fc14.x86_64
qemu-kvm-0.13.0-0.6.rc1.fc14.x86_64
gpxe-roms-qemu-1.0.1-1.fc14.noarch
qemu-system-x86-0.13.0-0.6.rc1.fc14.x86_64
qemu-img-0.13.0-0.6.rc1.fc14.x86_64
libvirt-0.8.3-2.fc14.x86_64
libvirt-python-0.8.3-2.fc14.x86_64
libvirt-client-0.8.3-2.fc14.x86_64
spice-client-0.6.0-1.fc14.x86_64
spice-server-0.6.0-1.fc14.x86_64
Comment 2 Tom Horsley 2010-09-15 20:09:54 EDT
Created attachment 447593 [details]
qemu log file

Here's the qemu log with lots of messages at the end that don't mean anything
to me, but might mean something to someone.
Comment 3 Alexander Larsson 2010-09-16 11:10:42 EDT
This is bug 630361, pass in -global qxl.revision=2 to fix it for now.
Comment 4 Alexander Larsson 2010-09-16 11:26:11 EDT
I mean bug 634535
Comment 5 Tom Horsley 2010-09-16 18:40:16 EDT
Hey qxl.revision=2 works, but I'm only getting video, no sound. Do I need
to install more than the qxl driver on the windows KVM to get sound?
Comment 6 Christophe Fergeau 2011-04-13 12:21:15 EDT
Reading bug #635900, I'm under the impression that you managed to get audio to work, is that right? Since the original bug is fixed I'd tend to close this bug as a duplicate of bug #634535 and let you open a new bugs if you are other (different) issues.
Comment 7 Tom Horsley 2011-04-13 13:09:28 EDT
Yep, I got audio to work as well eventually. Now my only worry is how hard it will be to get native support for spice to function correctly instead of using my hacked up wrapper script when I switch to fedora 15 :-).
Comment 8 Christophe Fergeau 2011-04-14 03:44:36 EDT
Ok, I'm closing this bug as a duplicate to bug #634535 then. Are you also saying that bug #635900 is no longer happening to you either?

*** This bug has been marked as a duplicate of bug 634535 ***

Note You need to log in before you can comment on or make changes to this bug.