Bug 634535 - Spice not working in qemu-0.13.0-0.6.rc1.fc14
Spice not working in qemu-0.13.0-0.6.rc1.fc14
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 630361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-16 05:35 EDT by Alexander Larsson
Modified: 2013-01-09 06:40 EST (History)
14 users (show)

See Also:
Fixed In Version: spice-0.6.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 02:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugfix (949 bytes, patch)
2010-09-16 08:12 EDT, Gerd Hoffmann
no flags Details | Diff

  None (edit)
Description Alexander Larsson 2010-09-16 05:35:26 EDT
When launching qemu with -vga qxl and -spice and then connecting to it with the spice client gets me a 9x1 window with black in.

I tried replacing the vgabios-qxl.bin with the one from the spice qemu repo, and this got me working text mode, but when switching from text mode it seems it fails somehow, leaving a black window with a textmode cursor in the top left corner.
Comment 1 Alexander Larsson 2010-09-16 06:20:18 EDT
I built the http://cgit.freedesktop.org/spice/qemu branches spice.v18 and spice.kvm.v18 against the F14 spice packages, and it worked fine.
Comment 2 Alexander Larsson 2010-09-16 07:36:17 EDT
I figured it out, you must start spice with -global qxl.revision=2, because the default is otherwise 3. We need to fix that. The default should be 2.
Comment 3 Gerd Hoffmann 2010-09-16 08:12:49 EDT
Created attachment 447726 [details]
bugfix

Oops, forgot to flip the default pci id from unstable to stable.  Attached patch fixes it.  Fix also pushed to the spice.14 branch @ freedesktop.

For the time being (until new package builds are available) you can add
'-global qxl.revision=2' to the qemu command line.
Comment 4 Fedora Update System 2010-09-21 18:22:37 EDT
spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14
Comment 5 Fedora Update System 2010-09-22 14:42:37 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice spice-protocol qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14
Comment 6 Fedora Update System 2010-09-30 02:10:16 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Christophe Fergeau 2011-04-14 03:44:36 EDT
*** Bug 630361 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.