Bug 630497 - Book fails to build in Brew (but build locally)
Book fails to build in Brew (but build locally)
Status: CLOSED DUPLICATE of bug 612515
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Hideo
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-05 21:33 EDT by Manuel Ospina
Modified: 2015-11-09 19:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-05 22:28:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Ospina 2010-09-05 21:33:09 EDT
Description of problem:

When trying to brew the release notes for JBoss EAP 4.2.9, the process fails. I got this error (from log):

cp: cannot stat `images/icon.svg': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.98130 (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.98130 (%install)
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target noarch --nodeps builddir/build/SPECS/JBoss_Enterprise_Application_Platform-Release_Notes_CP09-4.2-web-ja-JP.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 324, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target noarch --nodeps builddir/build/SPECS/JBoss_Enterprise_Application_Platform-Release_Notes_CP09-4.2-web-ja-JP.spec']
LEAVE do --> EXCEPTION RAISED

The book builds normally in the local machine

Version-Release number of selected component (if applicable):


How reproducible: 
Always


Steps to Reproduce:
1. publican package --brew --lang ja-JP
2.
3.
  
Actual results:
raise and error and fail

Expected results:
It should build


Additional info:
Comment 1 Ruediger Landmann 2010-09-05 22:28:50 EDT

*** This bug has been marked as a duplicate of bug 612515 ***

Note You need to log in before you can comment on or make changes to this bug.