Bug 630935 - shutdown from init 1 starts default during shutdown process
shutdown from init 1 starts default during shutdown process
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 630915 631160 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-07 08:32 EDT by Petr Lautrbach
Modified: 2014-03-16 23:24 EDT (History)
12 users (show)

See Also:
Fixed In Version: initscripts-9.20-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 03:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log from shutdown -h now (23.41 KB, text/plain)
2010-09-08 11:15 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Petr Lautrbach 2010-09-07 08:32:02 EDT
Version-Release number of selected component (if applicable):
systemd-9-3.fc14.x86_64

Steps to Reproduce:
1. boot to runlevel 1
2. shutdown -h now

  
Actual results:
...
init[1]: Got SIGCHLD for process 714 (bash)                                                                              
init[1]: Child 714 died (code=killed, status=9/KILL)                                                                     
init[1]: Child 714 belongs to single.service                                                                             
init[1]: single.service: main process exited, code=killed, status=9                                                      
init[1]: About to execute: /bin/systemctl default                                                                        
init[1]: Forked /bin/systemctl as 775                                                                                    
init[1]: single.service changed start -> start-post                                         
...
init[1]: Added job graphical.target/start to transaction.                                               
init[1]: Added job multi-user.target/start to transaction.                                              
init[1]: Added job basic.target/start to transaction.                                                   
init[1]: Added job sysinit.target/start to transaction.                                                 
init[1]: Added job sysinit.service/start to transaction.                                           
...
Stopping Rescue Shell...                                                                                                 
init[1]: single.service changed start-post -> stop-sigterm                                                               
Starting LSB: Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...                           
init[1]: About to execute: /etc/rc.d/init.d/lvm2-monitor start                                                           
init[1]: Forked /etc/rc.d/init.d/lvm2-monitor as 773                                                                     
init[1]: lvm2-monitor.service changed failed -> start                                                                    
Starting LSB: start and stop iptables firewall...                                                                        
init[1]: About to execute: /etc/rc.d/init.d/iptables start                                                               
init[1]: Forked /etc/rc.d/init.d/iptables as 774                                                                         
init[1]: iptables.service changed dead -> start                                                                          
Starting LSB: start and stop ip6tables firewall...                                                                       
init[1]: About to execute: /etc/rc.d/init.d/ip6tables start                                                              
init[1]: Forked /etc/rc.d/init.d/ip6tables as 777                                                                        
init[1]: ip6tables.service changed dead -> start                                                                         
init[1]: dbus.target changed dead -> active                                                                              
init[1]: Job dbus.target/start finished, success=yes                                                                     
Starting D-Bus System Message Bus...                                                    
Expected results:
...
Comment 1 Bill Nottingham 2010-09-07 13:29:44 EDT
This is a bug in single.service.
Comment 3 Fedora Update System 2010-09-07 16:31:03 EDT
systemd-9-3.fc14,initscripts-9.19-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/systemd-9-3.fc14,initscripts-9.19-1.fc14
Comment 4 Fedora Update System 2010-09-07 23:18:57 EDT
initscripts-9.19-1.fc14, systemd-9-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts systemd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/systemd-9-3.fc14,initscripts-9.19-1.fc14
Comment 5 Petr Lautrbach 2010-09-08 06:13:50 EDT
Conflict with shutdown.target doesn't fixed this for me. There is no added shutdown.target to transaction but I see in logs: 

init[1]: Added job poweroff.target/start to transaction.                                             
init[1]: Added job poweroff.service/start to transaction.             


Conflicts=multi-user.target poweroff.target in single.service works.
Comment 6 Bill Nottingham 2010-09-08 10:24:49 EDT
What are you invoking to shut down/halt? I can't reproduce this here.
Comment 7 Petr Lautrbach 2010-09-08 11:00:42 EDT
# rpm -qf /sbin/halt /sbin/shutdown
systemd-sysvinit-9-3.fc14.x86_64
systemd-sysvinit-9-3.fc14.x86_64

# rpm -q initscripts
initscripts-9.19-1.fc14.x86_64


bash-4.1# halt                           
init[1]: Trying to enqueue job halt.target/start
init[1]: Added job halt.target/start to transaction.
init[1]: Added job halt.service/start to transaction.
...
init[1]: Got SIGCHLD for process 728 (bash)
init[1]: Child 728 died (code=killed, status=9/KILL)
init[1]: Child 728 belongs to single.service
init[1]: single.service: main process exited, code=killed, status=9
init[1]: About to execute: /bin/systemctl default
init[1]: Forked /bin/systemctl as 795
init[1]: single.service changed start -> start-post


bash-4.1# shutdown -h now

init[1]: Trying to enqueue job poweroff.target/start
init[1]: Added job poweroff.target/start to transaction.
init[1]: Added job poweroff.service/start to transaction.
...
init[1]: Got SIGCHLD for process 712 (bash)[  OK  ]                                                                      

init[1]: Child 712 died (code=killed, status=9/KILL)
init[1]: Child 712 belongs to single.service
init[1]: single.service: main process exited, code=killed, status=9
init[1]: About to execute: /bin/systemctl default
init[1]: Forked /bin/systemctl as 774
init[1]: single.service changed start -> start-post



There is no shutdown.target/start in logs in both cases.
Comment 8 Petr Lautrbach 2010-09-08 11:15:54 EDT
Created attachment 446008 [details]
log from shutdown -h now
Comment 10 Bill Nottingham 2010-09-08 12:19:47 EDT
*** Bug 630915 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Becker 2010-09-09 13:06:57 EDT
*** Bug 632198 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2010-09-10 11:14:35 EDT
initscripts-9.20-1.fc14, sysvinit-2.87-5.dsf.fc14, systemd-9-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts sysvinit systemd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/systemd-9-3.fc14,initscripts-9.20-1.fc14,sysvinit-2.87-5.dsf.fc14
Comment 13 Bill Nottingham 2010-09-13 14:21:38 EDT
*** Bug 631160 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2010-09-14 00:29:01 EDT
systemd-10-1.fc14, initscripts-9.20-1.fc14, sysvinit-2.87-5.dsf.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update systemd initscripts sysvinit'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/systemd-10-1.fc14,initscripts-9.20-1.fc14,sysvinit-2.87-5.dsf.fc14
Comment 15 Fedora Update System 2010-09-15 03:12:37 EDT
initscripts-9.20-1.fc14, sysvinit-2.87-5.dsf.fc14, systemd-10-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.