Bug 631160 - kdm is (re)started just before shutdown???
kdm is (re)started just before shutdown???
Status: CLOSED DUPLICATE of bug 630935
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F14Target
  Show dependency treegraph
Reported: 2010-09-07 13:03 EDT by Michal Hlavinka
Modified: 2010-09-13 14:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-09-13 14:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2010-09-07 13:03:33 EDT
Description of problem:
This seems odd, but at the end of shutdown kdm seems restarted. I first thought it's just vga garbage, but there is also "working clock" mouse cursor and if I change username in kdm before shutdown kdm during shutdown has the username prefilled to default value so it's not just a garbage

How reproducible:
happens every time

Steps to Reproduce:
1.boot to kdm, no login
2.menu->shutdown->reboot OR ctrl-alt-f2, log in as root, reboot
3.some text info about system being shut down 

Actual results:
kdm shows again (and working) just before shutdown for about 1-2 seconds

Expected results:
no kdm before shutdown
Comment 1 Bill Nottingham 2010-09-07 15:36:44 EDT
Please try initscripts-9.19-1 when it's available (it *shouldn't* fix this, but it may change it slightly.)
Comment 2 Ira Malinich 2010-09-07 19:41:54 EDT
I'm getting the same behaviour with gdm on the systemd Test Day LiveCD ISO and subsequent hard disk installed system.
Comment 3 Petr Lautrbach 2010-09-08 06:19:27 EDT
Same here. kdm is restarted 3 or 4 times during shutdown process.

Comment 4 Michal Hlavinka 2010-09-08 07:29:28 EDT
(In reply to comment #1)
> Please try initscripts-9.19-1 when it's available (it *shouldn't* fix this, but
> it may change it slightly.)

tried but no (or not big enough) change
Comment 5 Petr Lautrbach 2010-09-08 07:47:53 EDT
I see the problem in stopping target.

graphical.target/stop and multi-user.target/stop is correctly added to transaction but stop on target only stops target but not wanted services/targets which were started on target start.
Comment 6 Lennart Poettering 2010-09-08 19:24:16 EDT
Hmm, by default all units get a Conflicts to shutdown.target and hence should be pulled down as part of that.

I'll have a close look on what is going on here tomorrow.
Comment 7 Bill Nottingham 2010-09-09 12:01:56 EDT
Does https://bugzilla.redhat.com/show_bug.cgi?id=630935#c9 help?
Comment 8 Adam Williamson 2010-09-09 17:51:20 EDT
confirm that I see this too, this seems like a polish issue that should really be fixed at least for final. Marking 'needinfo' for Bill's q.
Comment 9 Ira Malinich 2010-09-10 19:05:55 EDT
After updating to the following package versions, gdm is no longer *visibly* restarting at shutdown for me:


If I'm reading the diff referred to in comment 7 correctly, then adding "Requires=shutdown.target" to the killall.service file seems to have fixed it.
Comment 10 Bill Nottingham 2010-09-13 14:21:38 EDT

*** This bug has been marked as a duplicate of bug 630935 ***

Note You need to log in before you can comment on or make changes to this bug.