This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 631552 - make 3.82 fails on a valid dependency
make 3.82 fails on a valid dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: make (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
: 631193 (view as bug list)
Depends On:
Blocks: 631371
  Show dependency treegraph
 
Reported: 2010-09-07 16:52 EDT by Brian Lane
Modified: 2015-05-04 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: make-3.82-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 08:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-09-07 16:52:02 EDT
isomd5sum hasn't changed since 6/30/2010, and it still builds fine in rawhide which uses make 3.81

In f14, with make 3.82, it fails on a library dependency:

This is from hno on bug 631371 comment #7

Makefile says:

libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o md5.o)

libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o md5.o)

The F14 make for some reason dislikes this constructs like this in
dependencies. If rewritten as follow it works

libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o) \
                    libimplantisomd5.a(md5.o)

libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o) \
                  libcheckisomd5.a(md5.o)

This smells like a F14 make bug. There is nothing wrong with the original rule.
Comment 1 Petr Machata 2010-09-10 09:26:23 EDT
Agreed, that should work.  Reproducer:
x1 x2:; echo "$@" > $@
xxx: xxx(x1 x2)
Comment 2 Jesse Keating 2010-09-10 14:01:27 EDT
Since this has already gone into stable, you'll need to revert to an older one with an epoch build, or get a fix from upstream.  But the e:n-v-r must increase either way.
Comment 3 Fedora Update System 2010-09-13 08:11:29 EDT
make-3.82-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/make-3.82-2.fc14
Comment 4 Fedora Update System 2010-09-13 14:10:54 EDT
make-3.82-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update make'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/make-3.82-2.fc14
Comment 5 Ngo Than 2010-09-20 05:17:25 EDT
*** Bug 631193 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-09-23 08:55:37 EDT
make-3.82-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.