Bug 631575 - .gdb_index NOBITS crash
Summary: .gdb_index NOBITS crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 632247 (view as bug list)
Depends On:
Blocks: 631997
TreeView+ depends on / blocked
 
Reported: 2010-09-07 22:14 UTC by Steve Tyler
Modified: 2010-09-09 14:17 UTC (History)
4 users (show)

Fixed In Version: gdb-7.2-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-09 04:31:31 UTC


Attachments (Terms of Use)
gdb session crashing after loading symbols (10.11 KB, text/plain)
2010-09-07 22:33 UTC, Steve Tyler
no flags Details
coredump1.xz from gnome-panel (680.30 KB, application/x-xz)
2010-09-08 13:37 UTC, Steve Tyler
no flags Details
rpm -qa | sort > rpm-qa.1.log (40.45 KB, text/plain)
2010-09-08 15:20 UTC, Steve Tyler
no flags Details
gdb-7.2-3.fc14.x86_64-session.1.log (14.23 KB, text/plain)
2010-09-08 20:35 UTC, Steve Tyler
no flags Details
gdb-7.2-1 session crashing after loading symbols (9.56 KB, text/plain)
2010-09-09 09:16 UTC, luigi votta
no flags Details
rpms installed (60.44 KB, application/octet-stream)
2010-09-09 09:18 UTC, luigi votta
no flags Details

Description Steve Tyler 2010-09-07 22:14:30 UTC
Description of problem:
This happened while abrt was generating a backtrace. Now abrt is trying to report the gdb crash ...

I'll try to get a backtrace some other way.

Version-Release number of selected component (if applicable):
gdb-7.2-1.fc14

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Package:    	gdb-7.2-1.fc14
Latest Crash:	Tue 07 Sep 2010 02:58:51 PM 
Command:    	gdb -batch -ex 'set debug-file-directory /usr/lib/debug:/var/cache/abrt-di/usr/lib/debug' -ex 'file /usr/bin/gnome-panel' -ex 'core-file /var/spool/abrt/ccpp-1283896623-1924/coredump' -ex 'thread apply all backtrace 2048 full' -ex 'info sharedlib' -ex 'print (char*)__abort_msg' -ex 'print (char*)__glib_assert_msg' -ex 'info registers' -ex disassemble
Reason:     	Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
Comment:    	None
Bug Reports:

Comment 1 Steve Tyler 2010-09-07 22:33:37 UTC
Created attachment 445796 [details]
gdb session crashing after loading symbols

...
warning: .dynamic section for "/usr/lib64/libSM.so.6.0.0" is not at the expected address (wrong library or version mismatch?)

warning: Can't read pathname for load map: Input/output error.
...
warning: Can't read pathname for load map: Input/output error.
Segmentation fault (core dumped)

Comment 2 Jan Kratochvil 2010-09-08 12:28:26 UTC
Could you please provide that file
/var/spool/abrt/ccpp-1283896623-1924/coredump
to have a reproducer?

Comment 3 Steve Tyler 2010-09-08 13:37:24 UTC
Created attachment 445988 [details]
coredump1.xz from gnome-panel

I reproduced the gdb crash in a VM. This core file is from that environment to avoid information leakage.

[root@fir ccpp-1283894781-1410]# rpm -q gdb
gdb-7.2-1.fc14.x86_64
[root@fir ccpp-1283894781-1410]# ls -lF core*
-rw-r--r-- 1 root root 39571456 Sep  7 14:26 coredump
-rw-r--r-- 1 root root   696632 Sep  7 14:26 coredump1.xz
[root@fir ccpp-1283894781-1410]# file coredump
coredump: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style, from 'gnome-panel'

Comment 4 Jan Kratochvil 2010-09-08 15:10:54 UTC
Still not reproducible... could you submit even `rpm -qa'?
Posted why it should not be needed at:
http://lists.fedoraproject.org/pipermail/devel/2010-September/142701.html

Comment 5 Steve Tyler 2010-09-08 15:20:15 UTC
Created attachment 446011 [details]
rpm -qa | sort > rpm-qa.1.log

Comment 6 Jan Kratochvil 2010-09-08 19:12:50 UTC
[patch] .gdb_index: Do not crash on NOBITS
http://sourceware.org/ml/gdb-patches/2010-09/msg00183.html

Comment 7 Fedora Update System 2010-09-08 20:01:44 UTC
gdb-7.2-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gdb-7.2-3.fc14

Comment 8 Steve Tyler 2010-09-08 20:35:35 UTC
Created attachment 446081 [details]
gdb-7.2-3.fc14.x86_64-session.1.log

Thanks, Jan!

Attached session shows gdb-7.2-3 successfully reading the symbols and ready for more. :-)

Very nice work tracking this one down.

Comment 9 Jan Kratochvil 2010-09-08 20:41:31 UTC
Thanks for all the provided info.  It has become urgent since the push of:
glibc-2.12.90-10

Comment 10 Fedora Update System 2010-09-09 04:31:27 UTC
gdb-7.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 luigi votta 2010-09-09 09:16:49 UTC
Created attachment 446183 [details]
gdb-7.2-1 session crashing after loading symbols

Attached coredump file, as the previous requests

Comment 12 luigi votta 2010-09-09 09:18:48 UTC
Created attachment 446186 [details]
rpms installed

Comment 13 luigi votta 2010-09-09 09:24:26 UTC
gdb-7.2.3 available! Oh sorry, drop #c11 and #c12, (how much noise i made). 
Thank You.

Comment 14 Steve Tyler 2010-09-09 13:56:33 UTC
Not sure if this is significant, but gdb-7.2-3.fc14 is not showing up on repos. selinux-policy-3.9.3-1 was pushed about the same time and it is on repos.

[root@fir ~]# repoquery -qf gdb selinux-policy | sort
gdb-0:7.2-1.fc14.x86_64
gdb-0:7.2-1.fc14.x86_64
selinux-policy-0:3.9.0-2.fc14.noarch
selinux-policy-0:3.9.3-1.fc14.noarch
selinux-policy-0:3.9.3-1.fc14.noarch
[root@fir ~]# 
[root@fir ~]# repoquery --location gdb selinux-policy
http://fedora.fastsoft.net/pub/linux/fedora/linux/development/14/x86_64/os/Packages/gdb-7.2-1.fc14.x86_64.rpm
http://mirrors.kernel.org/fedora/updates/testing/14/x86_64/selinux-policy-3.9.3-1.fc14.noarch.rpm

https://admin.fedoraproject.org/updates/gdb-7.2-3.fc14
https://admin.fedoraproject.org/updates/selinux-policy-3.9.3-1.fc14

Comment 15 Jan Kratochvil 2010-09-09 14:14:38 UTC
*** Bug 632247 has been marked as a duplicate of this bug. ***

Comment 16 Jan Kratochvil 2010-09-09 14:17:02 UTC
(In reply to comment #14)
> Not sure if this is significant, but gdb-7.2-3.fc14 is not showing up on repos.
> selinux-policy-3.9.3-1 was pushed about the same time and it is on repos.

selinux-policy was submitted earlier so I would give it next day...
2010-09-08 20:01:34 gdb
2010-09-08 18:37:57 selinux-policy


Note You need to log in before you can comment on or make changes to this bug.