Bug 63184 - apmd cannot be removed because of %triggerpostun
apmd cannot be removed because of %triggerpostun
Status: CLOSED DUPLICATE of bug 62615
Product: Red Hat Public Beta
Classification: Retired
Component: apmd (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-10 17:50 EDT by Chris Adams
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 17:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2002-04-10 17:50:31 EDT
Attempting to "rpm -e apmd" results in:

error reading information on service apmd: No such file or directory
error: execution of %trigger scriptlet from apmd-3.0.2-7 failed, exit status 1

The problem is that the %preun does "chkconfig --del apmd", but there is a
%triggerpostun that tries to "chkconfig --add apmd".

This happens because the %trigger is done if the version is less than
3.0final-6, and the apmd in skijack2 is 3.0.2-7 (which compares as less).
Comment 1 Bill Nottingham 2002-04-10 18:31:19 EDT

*** This bug has been marked as a duplicate of 62615 ***

Note You need to log in before you can comment on or make changes to this bug.