Bug 632123 - [abrt] NetworkManager-gnome-1:0.8.1-6.git20100831.fc14: IA__gtk_tree_model_get_valist: Process /usr/bin/nm-applet was killed by signal 11 (SIGSEGV)
Summary: [abrt] NetworkManager-gnome-1:0.8.1-6.git20100831.fc14: IA__gtk_tree_model_ge...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a5ddcd1dace5a530a2f7602fbd9...
: 613457 628152 633592 635637 648001 648089 648621 649800 651642 653203 656752 663856 680724 746402 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-09 08:44 UTC by Matěj Cepl
Modified: 2018-04-11 09:58 UTC (History)
25 users (show)

Fixed In Version: NetworkManager-0.8.3.996-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 01:50:38 UTC


Attachments (Terms of Use)
File: backtrace (36.19 KB, text/plain)
2010-09-09 08:44 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2010-09-09 08:44:24 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: nm-applet --sm-disable
component: NetworkManager
crash_function: IA__gtk_tree_model_get_valist
executable: /usr/bin/nm-applet
kernel: 2.6.35.4-12.fc14.x86_64
package: NetworkManager-gnome-1:0.8.1-6.git20100831.fc14
rating: 4
reason: Process /usr/bin/nm-applet was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1284021712
uid: 500

How to reproduce
-----
1.created new wifi network to share network connection with my phone using WPA
2.
3.

Comment 1 Matěj Cepl 2010-09-09 08:44:28 UTC
Created an attachment (id=446167)
File: backtrace

Comment 2 Adam Williamson 2010-09-19 21:28:20 UTC
Package: NetworkManager-gnome-1:0.8.1-6.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Tried to share a wired connection via wireless
2. Chose AdamNet as the SSID, WPA as security and 'fedora01' as password
3. At the next step it seemed to want to try and connect to the new wireless network, presented a dialog asking for security settings but with a greyed-out dropdown box, and when I hit OK, crashed

Comment 3 Karel Klíč 2010-11-09 14:44:50 UTC
*** Bug 613457 has been marked as a duplicate of this bug. ***

Comment 4 Karel Klíč 2010-11-09 14:44:54 UTC
*** Bug 628152 has been marked as a duplicate of this bug. ***

Comment 5 Karel Klíč 2010-11-09 14:44:58 UTC
*** Bug 633592 has been marked as a duplicate of this bug. ***

Comment 6 Karel Klíč 2010-11-09 14:45:03 UTC
*** Bug 635637 has been marked as a duplicate of this bug. ***

Comment 7 Karel Klíč 2010-11-09 14:45:07 UTC
*** Bug 648001 has been marked as a duplicate of this bug. ***

Comment 8 Karel Klíč 2010-11-09 14:45:12 UTC
*** Bug 648621 has been marked as a duplicate of this bug. ***

Comment 9 Karel Klíč 2010-11-09 14:45:17 UTC
*** Bug 649800 has been marked as a duplicate of this bug. ***

Comment 10 Chuck Lasher 2010-11-12 16:43:45 UTC
Package: NetworkManager-gnome-1:0.8.1-9.git20100831.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. turned on wifi after returning home
2. Started to create new private WPA/WPA2 Wifi Network in NM applet
3. upon creation, it crashed as it tried to join its own network.... it did not ask for credentials again.




Comment
-----
Suspect potential for crash may be due to Wifi IP address NOT being defined BEFORE attempting
to connect to it during the create & auto-join process.

The windows products will join a create/join a WPA/WPA2 but ask for IP and/or setup
of adapter IP if not assigned when NetworkManager first attempts to join.

This appears to be a simple unhandled "Oooops, we need to go get an IP address manually since no
dhcp is being received (aka.... ad-hoc and not structured network)

Comment 11 EmadAIsmael 2010-11-13 09:33:28 UTC
Package: NetworkManager-gnome-1:0.8.1-9.git20100831.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just browsing thru Google chrome.
2.
3.

Comment 12 Jirka Klimes 2010-12-16 14:57:53 UTC
Fixed upstream:

libnm-util (NM):
b3800183b434bbaf90d627a2e44c631cf04e8b71 (master)
7c2ba8a4a55899e4f4bd5bd243e10ce8a0c0f13a (NM_0_8)

nm-applet:
6d6b3c466a6e400885b4256601fe4e478ca64269 (master)
8934d01acfb68c3add86c44c724dea5d3ea31fe0 (NMA_0_8)

Comment 13 Jirka Klimes 2010-12-16 14:59:10 UTC
*** Bug 651642 has been marked as a duplicate of this bug. ***

Comment 14 Jirka Klimes 2010-12-16 15:00:07 UTC
*** Bug 653203 has been marked as a duplicate of this bug. ***

Comment 15 Jirka Klimes 2010-12-16 15:01:10 UTC
*** Bug 656752 has been marked as a duplicate of this bug. ***

Comment 16 Jirka Klimes 2010-12-16 15:02:02 UTC
*** Bug 648089 has been marked as a duplicate of this bug. ***

Comment 17 Jirka Klimes 2010-12-20 09:21:18 UTC
*** Bug 663856 has been marked as a duplicate of this bug. ***

Comment 18 Pedro Silva 2010-12-21 15:41:19 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Create new Wifi Network
2. Define Authentication Method (WPA/WPA2) and Password for new Wifi Network
3. Crash

Comment 19 James Ettle 2010-12-25 14:35:24 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
This happened shortly after I created a new wireless network to share a connection.

1. Chose "Create New Wireless Network" in nm-applet.
2. Specified WPA/WPA2 PSK security, gave name and passphrase.
3. Was then prompted to connect to network by name, and choose security BUT the drop-down was greyed out. I clicked OK.

At this point nm-applet died. Upon restarting it, this machine seemed to be connected to the network it created.

I haven't been able to reproduce this after 1 subsequent attempt.

Comment 20 Misha Shnurapet 2011-01-02 16:51:16 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. .
2.
3.


Comment
-----
I was trying to configure my wifi.

Comment 21 Misha Shnurapet 2011-01-02 17:27:06 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Create a wifi network
2. Connect to it
3.


Comment
-----
I was trying to configure my wifi.

Comment 22 Misha Shnurapet 2011-01-02 17:35:57 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Create a WPA-protected wifi network
2. Connect to it
3.


Comment
-----
I was trying to configure my wifi.

Comment 23 David 2011-01-10 17:48:21 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I tried to set up an ad-hoc wireless b/g network using my computer as a DHCP server.  On the first try, I believe I created a 802.11a network, so I went into the edit connections GUI to change that.
2.On exiting the edit connections window, nm-applet began displaying the usual animation for when it connects to a network, but the icon disspeared and ABRT notified me of the crash.

Comment 24 Catalin BOIE 2011-01-11 19:49:52 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I cannot really say. Wireless and IPv6 involved.
2.
3.

Comment 25 Eric Baplue 2011-01-15 17:20:21 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Create a new wireless network and then try to connect to it

Comment 26 David Kovalsky 2011-01-16 13:45:24 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Created my own wifi network via NM (left click appet -> Create new wireless network)
2. Set the security to wpa2 
3. Wait for a while -> boom!

Comment 27 Nathanael Noblet 2011-01-24 17:28:57 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. clicked on 'configure wireless network'
2. entered everything needed for a WP2 Personal Network
3. Received a dialog requesting some kind of key
4. Crash

Comment 28 John J. Egan 2011-01-24 18:21:31 UTC
My wireless (laptop) works fine in Fedora 14 - but it was an upgrade from Fedora 13, Fedora 12 in which wireless worked. Indeed, Fedora 14 has even handled the change of the internal wireless hardware.

I _HAVE_ found that when it balks, Network Configuration / Wireless Device Configuration / Wireless Settings / Mode  has gotten changed from "AUTO" to something else - usually "Managed". Then there's some work involved - AFTER changing the setting to Auto. I usually need to delete defined connections, reboot, then re-connect to the (now NEW) connection.

- - - comments added only for additional input; not as a complaint. Hope is info will help troubleshoot.

Comment 29 kicsiedes1 2011-02-20 19:03:49 UTC
Package: NetworkManager-gnome-1:0.8.1-10.git20100831.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
a

Comment 30 Fedora Update System 2011-02-24 06:06:03 UTC
NetworkManager-0.8.3.995-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 31 Fedora Update System 2011-02-24 06:09:33 UTC
NetworkManager-0.8.3.995-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc13

Comment 32 Fedora Update System 2011-02-24 20:57:16 UTC
NetworkManager-0.8.3.995-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 33 Fedora Update System 2011-02-25 23:42:53 UTC
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).

Comment 34 Fedora Update System 2011-02-25 23:45:53 UTC
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).

Comment 35 Jirka Klimes 2011-02-28 11:34:45 UTC
*** Bug 680724 has been marked as a duplicate of this bug. ***

Comment 36 Fedora Update System 2011-03-02 01:49:14 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2011-03-03 09:47:20 UTC
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).

Comment 38 Fedora Update System 2011-03-25 03:30:16 UTC
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13

Comment 39 Fedora Update System 2011-04-12 21:28:04 UTC
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Dan Williams 2011-11-30 17:03:21 UTC
*** Bug 746402 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.