Bug 632208 - preupgrade's defaults to images/install.img: should be upgrade/install.img
preupgrade's defaults to images/install.img: should be upgrade/install.img
Status: CLOSED DUPLICATE of bug 629245
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 08:25 EDT by Jim Meyering
Modified: 2013-03-13 16:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-09 15:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Meyering 2010-09-09 08:25:11 EDT
Description of problem: when I upgraded from F13 using preupgrade,
it failed to find the suggested image name, because it was using images/install.img (perhaps that resolved to /var/cache/yum/preupgrade/images/install.img?  I'm going by memory).  It should have searched for upgrade/install.img.  It would have been nice if it were able to tell me which partition to look in.  I had 7.  Luckily I was able to determine that the desired image was on the separate /boot partition and that that corresponded to /dev/sda2 in the pull-down list.

Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc13.noarch

How reproducible: at least once

Steps to Reproduce:
1. create 7 partitions (separate /boot) on a GPT partition table
Install F13 and bring it up to date.
2. run preupgrade
3.
  
Actual results: preseeded .img file name is incorrect


Expected results: should be the one that preupgrade just wrote.
RFE: make the menu default to the proper partition number so people don't have to guess


Additional info:
Comment 1 James Laska 2010-09-09 11:54:16 EDT
Discussed with Jim on IRC, but will mention it here as well.

I asked Jim to ...
 1. Retest with the latest preupgrade packaged used for the recent test day.  This doesn't appear to be available on F13 yet, but is available at http://people.freedesktop.org/~hughsient/fedora/13/i386/
 2. After running preupgrade, but prior to rebooting, provide the /etc/grub.conf file
 3. Also prior to reboot, can you also list the contents of /boot/upgrade (find /boot/upgrade should do)
 4. After rebooting into the installer, any anaconda log files (/tmp/*log) may also be helpful.  However, I suspect the results from the previous steps should provide enough information.

Thanks!
Comment 2 Jim Meyering 2010-09-09 13:35:56 EDT
(In reply to comment #1)
> Discussed with Jim on IRC, but will mention it here as well.
> 
> I asked Jim to ...
>  1. Retest with the latest preupgrade packaged used for the recent test day. 
> This doesn't appear to be available on F13 yet, but is available at
> http://people.freedesktop.org/~hughsient/fedora/13/i386/
>  2. After running preupgrade, but prior to rebooting, provide the
> /etc/grub.conf file
>  3. Also prior to reboot, can you also list the contents of /boot/upgrade (find
> /boot/upgrade should do)

That directory contained the install.img file.
However, the UI proposed to search for "/images/install.img".
Once I found the proper directory name (upgrade/, not images/) and located the required partition, it worked fine.

>  4. After rebooting into the installer, any anaconda log files (/tmp/*log) may
> also be helpful.  However, I suspect the results from the previous steps should
> provide enough information.

Not sure when I'll be able to retest, though.
Comment 3 Jim Meyering 2010-09-09 15:11:12 EDT
This is a duplicate:

*** This bug has been marked as a duplicate of bug 629245 ***

Note You need to log in before you can comment on or make changes to this bug.