Bug 632296 - Unable to add multiple Brokers to the Messaging Console
Summary: Unable to add multiple Brokers to the Messaging Console
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin
Version: beta
Hardware: x86_64
OS: Linux
high
high
Target Milestone: 1.3
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks: 595746
TreeView+ depends on / blocked
 
Reported: 2010-09-09 15:54 UTC by Douglas Woods
Modified: 2010-10-22 10:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-22 10:35:46 UTC


Attachments (Terms of Use)

Description Douglas Woods 2010-09-09 15:54:57 UTC
Unable to add multiple Brokers to the Messaging Console

Description of problem:

In v.1.2 there was a button on the Brokers tab under Messaging in the Management Console that allowed for a user to register new brokers. These brokers could be grouped within the Broker Groups and allowed for a user to setup a single management console that could connect with and show multiple brokers.

This button, and functionality is not available ( at least not clearly ) in the 1.3 release.

Version-Release number of selected component (if applicable):

1.3 Beta

How reproducible:

100%

Steps to Reproduce:

1. Start MRG Management Console - log in

2. Go to Messaging Tab

3. Go to Brokers Tab

Actual results:

A single broker ( / ) is shown. There is no button to add new brokers

Expected results:

A button to add brokers should be available.

Additional info:
The cumin.conf file does take a brokers list; this, it appears, is a comma seperated list or broker URI's, even with these specified only ONE shows up.

Comment 1 Justin Ross 2010-09-09 17:23:50 UTC
The brokers config parameter is the only mechanism in 1.3 for adding brokers.  The mechanism that existed before was a big source of user confusion and implementation defects, because it conflated the two following concepts:

 * A broker that is just like other managed objects

 * A broker used internally for qmf communication

The latter will always be configured via the brokers config parameter from here on out.  A future version of qmf and broker management may support networks of brokers under management.  In that case, you would not need to add another broker entry to the config parameter, one for one.  Instead, just one would entry in the config parameter would be sufficient to discover all the managed qmf brokers in the network.

In short, "Register broker" in the ui is not coming back.  It was always a flawed idea before.  Note that we don't have an "Add pool", etc., for grid.  That's because those things are already discovered automatically.

As to your last note, there is a bug preventing multiple brokers from working in the config file.  More info to follow.

Comment 2 Justin Ross 2010-09-13 13:36:15 UTC
There's a serious data issue that causes db corruption when multiple brokers are configured.

The problem is that broker agent ids are not unique.  I have a fix that mangles these ids with extra information, but so far it is breaking db object references.

Comment 3 Justin Ross 2010-09-14 20:57:15 UTC
The db corruption is addressed in revision 4288.  The fix does indeed mangle v1 object ids with extra info to avoid collisions.

With this fix, multiple configured brokers should work properly.


Note You need to log in before you can comment on or make changes to this bug.