Bug 632709 - [6.1 FEAT] makedumpfile port to zLinux.
[6.1 FEAT] makedumpfile port to zLinux.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.1
s390x All
high Severity high
: beta
: 6.1
Assigned To: Cong Wang
Han Pingtian
: FutureFeature
Depends On: 659731
Blocks: 633869 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-10 15:11 EDT by IBM Bug Proxy
Modified: 2013-09-29 22:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-156_el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:15:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kexec-tools-2.0.0-makedumpfile-s390-port.patch (backport) (18.05 KB, text/plain)
2010-11-19 07:12 EST, IBM Bug Proxy
no flags Details
kexec-tools.spec.patch (6.20 KB, text/plain)
2010-11-19 07:12 EST, IBM Bug Proxy
no flags Details
Updated patch for spec file (4.50 KB, patch)
2010-11-22 04:35 EST, Cong Wang
no flags Details | Diff
Updated patch for spec file (4.40 KB, patch)
2010-11-22 21:58 EST, Cong Wang
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67116 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-10 15:11:23 EDT
1. Feature Overview:
Feature Id: [67116]
a. Name of Feature: [6.1 FEAT] makedumpfile port to zLinux.
b. Feature Description
makedumpfile port to zLinux.

zLinux kernel crash dumps have traditionally not been in ELF core format. We now have infrastructure
to convert the zLinux dumps to ELF core format. Subsequently, we'll need to compress these dumps.
Work is on to port makedumpfile for compressing these dumps to s390.

We intend to push this infrastructure to upstream makedumpfile too.


2. Feature Details:
Sponsor: LTC RAS
Architectures:  zSeries - 64 native, 

Arch Specificity: both
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Update Version
d. Upstream Acceptance: Field does not exist
Sponsor Priority P3
f. Severity: high
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
With zLinux gaining facility to report dumps in ELF core format, we'd want one tool (makedumpfile)
to take care of filtering it, as it does with other platforms.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael W. Wortman, wortman@us.ibm.com

Technical contact(s):
MAHESH J. SALGAONKAR, mahesh.salgaonkar@in.ibm.com
Comment 2 John Jarvis 2010-09-21 13:45:51 EDT
Is this a request against the dump component or for a new package?
Comment 3 John Jarvis 2010-09-21 13:46:33 EDT
IBM is signed up to test and provide feedback.
Comment 4 IBM Bug Proxy 2010-09-22 07:21:14 EDT
------- Comment From mahesh@linux.vnet.ibm.com 2010-09-22 07:10 EDT-------
(In reply to comment #4)
> Is this a request against the dump component or for a new package?
>

This feature is to enhance makedumpfile tool to support filtering/compressing of ELF kernel crash dumps on s390. We hope to have the zLinux filtering specific patch integrated upstream soon, so RHEL 6.1 will either need to pick up the newer makedumpfile with zLinux support or incorporate a port of it in their package.

Since makedumpfile is shipped as part of kexec-tools rpm, we'll have a challenge for s390 -- kexec is not supported on s390 and hence there is no corresponding kexec-tools package. We would either need to:
1. Have intelligent in the kexec-tools spec file to build only makedumpfile for s390
2. OR have a makedumpfile rpm separately for s390.

Redhat,

What is the preferred approach here?
Comment 5 Adam Tkac 2010-09-23 03:48:20 EDT
Reassigning to proper component, makedumpfile is part of kexec-tools.
Comment 6 IBM Bug Proxy 2010-10-04 12:29:16 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:14 EDT-------
Code Upstream Status: Not Started
Comment 7 IBM Bug Proxy 2010-10-28 04:40:46 EDT
------- Comment From mahesh@linux.vnet.ibm.com 2010-10-28 04:39 EDT-------
(In reply to comment #5)
> (In reply to comment #4)
> > Is this a request against the dump component or for a new package?
> >
>
> This feature is to enhance makedumpfile tool to support filtering/compressing
> of ELF kernel crash dumps on s390. We hope to have the zLinux filtering
> specific patch integrated upstream soon, so RHEL 6.1 will either need to pick
> up the newer makedumpfile with zLinux support or incorporate a port of it in
> their package.
>
> Since makedumpfile is shipped as part of kexec-tools rpm, we'll have a
> challenge for s390 -- kexec is not supported on s390 and hence there is no
> corresponding kexec-tools package. We would either need to:
> 1. Have intelligent in the kexec-tools spec file to build only makedumpfile for
> s390
> 2. OR have a makedumpfile rpm separately for s390.
>
>
> Redhat,
>
> What is the preferred approach here?

Hi Redhat,

We haven't received any response for the above qeury. Can you please let us know what is the preferred approach here?

Thanks,
Comment 8 IBM Bug Proxy 2010-11-16 01:20:57 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-16 01:17 EDT-------
The s390 port patch has been accepted and merged into upstream makedumpfile

============================================
commit 0f7076d6f179f9bbd446c3e21eb63c52369a0f0d
Author: Mahesh Salgaonkar <mahesh@linux.vnet.ibm.com>
Date:   Mon Nov 15 12:39:17 2010 +0900

[PATCH] Add support for s390x crashdump analysis.

This patch adds support for processing s390x kernel crashdumps.

The changes have been tested on s390x system.
The dump compression and filtering (for all dump levels 1,2,4,8,16 and 31)
tests are succussfull.

Signed-off-by: Mahesh Salgaonkar <mahesh@linux.vnet.ibm.com>
Signed-off-by: Michael Holzheu <holzheu@de.ibm.com>
============================================

The latest release of makedumpfile-1.3.7 includes the s390 port patch.
Comment 9 Cong Wang 2010-11-16 02:48:24 EST
IBM, would you mind to backport that patch to makedumpfile-1.3.5 which is the one we used in kexec-tools. Ideally, it would be very nice if you can make a patch against the latest kexec-tools srpm.

Thanks!
Comment 10 IBM Bug Proxy 2010-11-19 07:12:41 EST
Created attachment 461532 [details]
kexec-tools-2.0.0-makedumpfile-s390-port.patch (backport)


------- Comment on attachment From mahesh@linux.vnet.ibm.com 2010-11-19 07:02 EDT-------


Please find the backported patch that cleanly applies on kexec-tools-2.0.0-145.el6.s390x from RHEL6.0. This patch includes following commits from upstream makedumpfile:

1.  commit 1fb344e934f87b9c124e487a21e111c7bdc977ba
     [PATCH] Add ELF note section to the kdump-compressed format.
2.  commit 0178d1fb180fdb7f1185de3d5097563a16ab40b2
     [PATCH] Add the description about version 4.
3.  commit be83d98318561db5c2f474c34880df557b284af0
     [PATCH] Fix right nr_cpus in kdump main header.
4.  commit 8bb3436b1c13f02796d417b2f76af4ed642e51c9
     [PATCH] Fix the size of "log_end" which has been changed since linux-2.6.25
5.  commit 0f7076d6f179f9bbd446c3e21eb63c52369a0f0d
     [PATCH] Add support for s390x crashdump analysis.
Comment 11 IBM Bug Proxy 2010-11-19 07:12:46 EST
Created attachment 461533 [details]
kexec-tools.spec.patch


------- Comment on attachment From mahesh@linux.vnet.ibm.com 2010-11-19 07:09 EDT-------


This patch enables kexec-tools package to deploy makedumpfile tool for s390x architecure. This patch cleanly applies on kexec-tools.spec file of kexec-tools-2.0.0-145.el6.s390x from RHEL6.0.

Redhat ships the makedumpfile tool through kexec-tools package and s390x does not use Kdump functionality, the kexec-tools package was never supported for s390x. Hence this patch enables kexec-tools rpm package to build and install only makedumpfile tool and related files on s390x architecture keeping the existing functionality (unpacking/building kexec-tools, kdump scripts and makedumpfile) intact for other architectures.

With this patch applied on kexec-tools.spec, we should be able to get makedumpfile tool land on s390x system.
Comment 12 Cong Wang 2010-11-22 04:19:03 EST
IBM, thanks very much!

I fixed a couple of issues in the patch from you:

1) We moved makedumpfile to /usr/sbin in 2.0.0-151;

2) s390 patch should be put as Patch401 in spec file.

However, there is still one small issue that I can't fix, it is a compile error:

makedumpfile.c: In function 'is_kvaddr':
makedumpfile.c:1495: error: 'KVBASE' undeclared (first use in this function)
makedumpfile.c:1495: error: (Each undeclared identifier is reported only once
makedumpfile.c:1495: error: for each function it appears in.)

I got this on s390, it is fine on s390x. I think you missed to define KVBASE for s390? So, could you please provide an updated version of kexec-tools-2.0.0-makedumpfile-s390-port.patch?

Thanks again!
Comment 13 Cong Wang 2010-11-22 04:25:35 EST
Hmm, it seems you only make "makedumpfile" support s390x, then why we still define s390 in spec file? :)
Comment 14 Cong Wang 2010-11-22 04:35:22 EST
Created attachment 461953 [details]
Updated patch for spec file

IBM, if you need to change spec file, please use this updated version from me. If not, just ignore it. Thanks.
Comment 16 IBM Bug Proxy 2010-11-22 11:31:34 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-22 11:20 EDT-------
(In reply to comment #14)
> Hmm, it seems you only make "makedumpfile" support s390x, then why we still
> define s390 in spec file? :)

Oops, my mistake. Yes, makedumpfile support is only for s390x and I should not have defined s390 in spec file. I will move s390 under ExcludeArch and post the new patch.

Thanks for your review.
Comment 17 IBM Bug Proxy 2010-11-22 11:41:56 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-22 11:40 EDT-------
(In reply to comment #15)
> BTW, the lastest kexec-tools is here:
>
> https://brewweb.devel.redhat.com/buildinfo?buildID=149753
>
> or
>
> http://download.devel.redhat.com/brewroot/packages/kexec-tools/2.0.0/155.el6/src/
>
> Thanks.

Hi Steve,

I am unable to access above links. Can you please help me to get these files?

Thanks,
-Mahesh.
Comment 18 Cong Wang 2010-11-22 21:58:26 EST
Created attachment 462209 [details]
Updated patch for spec file

IBM, never mind. I simply remove "s390" from all "ifarch" and "ifnarch", and put it back to ExcludeArch. Please review this patch.

Thanks!
Comment 19 Cong Wang 2010-11-22 22:03:45 EST
Oh, I also rename the patch to kexec-tools-2.0.0-makedumpfile-s390x-port.patch. With the patch in comment #18 applied, I can build rpm successfully on s390x.

Steve, if you want to get the rpm's, please use this one:

https://brewweb.devel.redhat.com/taskinfo?taskID=2908654

Thanks.
Comment 20 IBM Bug Proxy 2010-11-24 21:11:09 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-24 21:08 EDT-------
(In reply to comment #19)
> Created an attachment (id=57782) [details]
> Updated patch for spec file
>
>
> ------- Comment on attachment From amwang@redhat.com 2010-11-22 21:58:26
> EDT-------
>
>
> IBM, never mind. I simply remove "s390" from all "ifarch" and "ifnarch", and
> put it back to ExcludeArch. Please review this patch.
>
> Thanks!

Hi Redhat,

Thanks for making change. The patch looks fine. I got the latest kexec-tools source rpm and tested it on s390x system and works fine.

Thanks,
-Mahesh.
Comment 21 IBM Bug Proxy 2010-11-25 22:51:13 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-25 22:46 EDT-------
(In reply to comment #19)
> Created an attachment (id=57782) [details]
> Updated patch for spec file
>
>
> ------- Comment on attachment From amwang@redhat.com 2010-11-22 21:58:26
> EDT-------
>
>
> IBM, never mind. I simply remove "s390" from all "ifarch" and "ifnarch", and
> put it back to ExcludeArch. Please review this patch.
>
> Thanks!

Hi Redhat,

Will this patch go into RHEL6.1 ?
Comment 22 Cong Wang 2010-11-25 23:09:03 EST
(In reply to comment #21)
> Hi Redhat,
> 
> Will this patch go into RHEL6.1 ?

Yes, it is already in kexec-tools-2_0_0-156_el6.
Comment 23 John Jarvis 2010-11-30 15:37:03 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 24 Gonzalo Muelas Serrano 2010-12-03 05:30:12 EST
Hello Red Hat,
in previous releases, without this feature, kexec-tools was not provided with RHEL on System z because System z had no use of it.

Now that we will have a port/supprot of makedumpfile on RHEL 6.1 on System z, will the kexec-tools package automaticaly be build and included for RHEL 6.1 on System z, or do we need a separate bugzilla to track the delivery of kexec-tools in RHEL on System z?

Thank you for your support!
Comment 25 John Jarvis 2010-12-03 09:07:38 EST
Please open a separate Bugzilla to request and track the kexec-tools work item.
Comment 26 Gonzalo Muelas Serrano 2010-12-03 10:21:23 EST
Ok, done: RH Bug 659731 - Build and include kexec-tools on System z
Comment 29 IBM Bug Proxy 2011-02-02 09:42:39 EST
------- Comment From mgrf@de.ibm.com 2011-02-02 09:38 EDT-------
for the record  -  I want to note that  the s390 build of kexec tools will need to contain only the makedumpfile parts.
kexec or ancillary tools are currently not required for s390.

Would you agree to let IBM review the first build?
Comment 31 Cong Wang 2011-02-03 06:47:19 EST
(In reply to comment #29)
Yeah, please. Thanks.
Comment 34 John Jarvis 2011-03-09 13:38:49 EST
IBM is signed up to test and provide feedback.
Comment 35 Han Pingtian 2011-03-09 23:05:28 EST
The patch has been included in -156.el6. Set sanitonly flag.
Comment 36 IBM Bug Proxy 2011-04-06 13:53:10 EDT
------- Comment From tpnoonan@us.ibm.com 2011-04-06 13:46 EDT-------
defect 71114  -  RH692449- [RHEL6.1] makedumpfile fails to generate filtered dumps with -d 16 & 31 option values
is blocking verifcation of this feature
Comment 37 errata-xmlrpc 2011-05-19 10:15:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0736.html

Note You need to log in before you can comment on or make changes to this bug.