Bug 633004 - flash 10.1 and nspluginwrapper hang on right click
Summary: flash 10.1 and nspluginwrapper hang on right click
Keywords:
Status: CLOSED DUPLICATE of bug 662203
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-12 12:33 UTC by Eddie Lania
Modified: 2010-12-16 12:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-16 12:16:48 UTC


Attachments (Terms of Use)

Description Eddie Lania 2010-09-12 12:33:51 UTC
Description of problem: it looks like nspluginwrapper has some incompatibilities with flash 10.1. For example:

1. On any system, install flash 10.1 along with nspluginwrapper
2. Run firefox in a terminal and visit http://www.adobe.com/software/flash/about/
3. Right click on the flash ad at the top of the page.
4. Observe firefox hang, and eventually many errors be spewed on the terminal


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. On any system, install flash 10.1 along with nspluginwrapper
2. Run firefox in a terminal and visit http://www.adobe.com/software/flash/about/
3. Right click on the flash ad at the top of the page.
4. Observe firefox hang, and eventually many errors be spewed on the terminal
  
Actual results: Firefox hangs


Expected results: Firefox not hanging.


Additional info:

Comment 1 Eddie Lania 2010-09-12 12:35:34 UTC
This bug ia also in: https://bugs.launchpad.net/ubuntu/+source/nspluginwrapper/+bug/592492

Comment 2 Martin Stransky 2010-09-22 11:37:30 UTC
Can you check if the same reproduction steps cause firefox/flash hang when nspluginwrapper is not installed?

Comment 3 Eddie Lania 2010-09-22 14:55:41 UTC
I am currently using flash-plugin-10.1.85.3-release.i386 without nspluginwrapper and the problem is gone.

So, my conclusion is that without nspluginwrapper i am not able to reproduce the issue.

Regards,

Eddie.

Comment 4 Eddie Lania 2010-09-25 11:12:38 UTC
Although the lock-up is gone without nspluginwrapper, the following is still outputted in a terminal window when running firefox and following the steps in this bug to reproduce it.

[eddie@t2330fedora ~]$ firefox

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

(<unknown>:3678): Gdk-WARNING **: XID collision, trouble ahead

Comment 5 Martin Stransky 2010-12-16 12:16:48 UTC

*** This bug has been marked as a duplicate of bug 662203 ***


Note You need to log in before you can comment on or make changes to this bug.