Bug 662203 - Firefox/Flash freezes on right button click
Summary: Firefox/Flash freezes on right button click
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: flash-plugin
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
: 236810 622416 633004 (view as bug list)
Depends On:
Blocks: 666865
TreeView+ depends on / blocked
 
Reported: 2010-12-10 21:00 UTC by Alexander Todorov
Modified: 2012-08-03 10:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 666865 (view as bug list)
Environment:
Last Closed: 2012-08-03 10:35:22 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2010-12-10 21:00:53 UTC
Description of problem:
When the user clicks with the right mouse button onto a flash animation the browser will freeze.

Version-Release number of selected component (if applicable):
firefox-3.6.13-2.el6_0.i686
flash-plugin-10.1.102.64-1.el6.i686


How reproducible:
Always

Steps to Reproduce:
1. Sart Firefox and open a page which contains Flash such as http://www.btv.bg/weather/5day
2. Right click on the flash video (the weather report in the above URL).
3.
  
Actual results:
Firefox freezes

Expected results:
Right-click menu will appear.

Additional info:

Comment 1 Alexander Todorov 2010-12-10 21:02:46 UTC
Right-click works with http://www.youtube.com/watch?v=wyR0cBYUxUQ 

It's probably something about the website/video that causes the hang.

Comment 2 Martin Stransky 2010-12-15 10:59:46 UTC
Do you use nspluginwrapper? Can you reproduce it without nspluginwrapper?

Comment 3 Alexander Todorov 2010-12-15 11:18:59 UTC
I had nspluginwrapper-1.3.0-14.el6.i686 installed. Removing it fixed the issue.

Comment 4 Martin Stransky 2010-12-15 12:33:56 UTC
Yes, I can reproduce the crash with npsluginwrapper, flash plug-in is struck somewhere in glib when npsluginwrapper is installed. I wonder why...

Comment 5 Martin Stransky 2010-12-15 12:35:06 UTC
Backtrace of the flash/glib process.

#0  0x0027e430 in __kernel_vsyscall ()
#1  0x010b3df6 in poll () from /lib/libc.so.6
#2  0x007ec64c in g_poll () from /lib/libglib-2.0.so.0
#3  0x007df044 in ?? () from /lib/libglib-2.0.so.0
#4  0x007df7af in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x0155ee2b in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#6  0x01560a55 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#7  0x01560bdf in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#8  0x014ad6f5 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#9  0x011c1306 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#10 0x011c23e2 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#11 0x011b762a in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#12 0x011bd884 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#13 0x0804b4d1 in g_NPP_HandleEvent (connection=0x892baf8) at ../src/npw-viewer.c:4075
#14 handle_NPP_HandleEvent (connection=0x892baf8) at ../src/npw-viewer.c:4102
#15 0x080587b2 in _rpc_dispatch_1 (connection=0x892baf8, message=0xffc438e0) at ../src/rpc.c:1648
#16 0x08058ae0 in _rpc_dispatch (connection=0x892baf8) at ../src/rpc.c:1679
#17 rpc_dispatch (connection=0x892baf8) at ../src/rpc.c:1747
#18 0x0804af62 in rpc_event_dispatch (source=0x892e258, callback=0x8058a40 <rpc_dispatch>, connection=0x892baf8)
    at ../src/npw-viewer.c:4386
#19 0x007db525 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x007df268 in ?? () from /lib/libglib-2.0.so.0
#21 0x007df7af in g_main_loop_run () from /lib/libglib-2.0.so.0
#22 0x00c8a5a9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x0804ebd7 in do_main (argc=<value optimized out>, argv=0xffc45c14) at ../src/npw-viewer.c:4501
#24 main (argc=<value optimized out>, argv=0xffc45c14) at ../src/npw-viewer.c:4675

Comment 6 Martin Stransky 2010-12-16 11:25:40 UTC
Well, it's because the two nested glib loops are waiting for the same content, 
context=0x8582a88 in this case. We need to attach the rpc handler to a different loop.

(gdb) bt
#0  0x006b0424 in __kernel_vsyscall ()
#1  0x01091b16 in poll () from /lib/libc.so.6
#2  0x00ba4dac in g_poll (fds=0x85a8110, nfds=2, timeout=9) at gpoll.c:132
#3  0x00b948b7 in g_main_context_poll (context=0x8582a88, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3093
#4  g_main_context_iterate (context=0x8582a88, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
#5  0x00b9504b in g_main_loop_run (loop=0x8690fc8) at gmain.c:2988
#6  0x04cdfe2b in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#7  0x04ce1a55 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#8  0x04ce1bdf in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#9  0x04c2e6f5 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#10 0x04942306 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#11 0x049433e2 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#12 0x0493862a in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#13 0x0493e884 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#14 0x08052473 in g_NPP_HandleEvent (instance=0x85beff0, event=0xbfd6d7f4) at ../src/npw-viewer.c:4075
#15 0x08052531 in handle_NPP_HandleEvent (connection=0x85a5f50) at ../src/npw-viewer.c:4102
#16 0x080596e7 in _rpc_dispatch_1 (connection=0x85a5f50, message=0xbfd6d8f8) at ../src/rpc.c:1648
#17 0x0805979e in _rpc_dispatch (connection=0x85a5f50, message=0xbfd6d8f8) at ../src/rpc.c:1679
#18 0x080599a1 in rpc_dispatch (connection=0x85a5f50) at ../src/rpc.c:1747
#19 0x08052ce0 in rpc_event_dispatch (source=0x85a80c0, callback=0x8059906 <rpc_dispatch>, connection=0x85a5f50)
    at ../src/npw-viewer.c:4386
#20 0x00b94192 in g_main_dispatch (context=0x8582a88) at gmain.c:2149
#21 g_main_context_dispatch (context=0x8582a88) at gmain.c:2702
#22 0x00b94978 in g_main_context_iterate (context=0x8582a88, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#23 0x00b9504b in g_main_loop_run (loop=0x85a7a80) at gmain.c:2988
#24 0x007f9499 in IA__gtk_main () at gtkmain.c:1237
#25 0x08052f9a in do_main (argc=1, argv=0xbfd6fc44, connection_path=
    0xbfd701b0 "/org/wrapper/NSPlugins/libflashplayer.so/10607-3") at ../src/npw-viewer.c:4501
#26 0x0805365e in main (argc=1, argv=0xbfd6fc44) at ../src/npw-viewer.c:4675

(gdb) f
#4  g_main_context_iterate (context=0x8582a88, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
(gdb) f 20
#20 0x00b94192 in g_main_dispatch (context=0x8582a88) at gmain.c:2149

Comment 7 Martin Stransky 2010-12-16 12:16:48 UTC
*** Bug 633004 has been marked as a duplicate of this bug. ***

Comment 8 Martin Stransky 2010-12-16 12:18:57 UTC
*** Bug 622416 has been marked as a duplicate of this bug. ***

Comment 9 Martin Stransky 2010-12-16 12:45:29 UTC
*** Bug 236810 has been marked as a duplicate of this bug. ***

Comment 10 RHEL Product and Program Management 2011-01-07 15:39:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 11 Martin Stransky 2011-05-04 10:04:35 UTC
It should be fixed by new upstream version 1.3.2.

Comment 12 Martin Stransky 2012-08-03 10:35:22 UTC
Flash is dead and closed source, closing as WONTFIX. You can imagine CANTFIX here as well.


Note You need to log in before you can comment on or make changes to this bug.