Bug 633247 - basic video driver fails in bare metal install (black screen, machine is unresponsive)
basic video driver fails in bare metal install (black screen, machine is unre...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-13 07:50 EDT by Andre Robatino
Modified: 2010-10-14 15:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-14 15:47:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (21.95 KB, text/plain)
2010-09-13 10:02 EDT, Andre Robatino
no flags Details
/var/log/messages (221.34 KB, text/plain)
2010-09-13 10:03 EDT, Andre Robatino
no flags Details
/etc/X11/xorg.conf (622 bytes, text/plain)
2010-09-13 12:18 EDT, Andre Robatino
no flags Details
/var/log/Xorg.0.log (33.49 KB, text/plain)
2010-09-13 12:20 EDT, Andre Robatino
no flags Details
/var/log/messages (318.58 KB, text/plain)
2010-09-13 12:21 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2010-09-13 07:50:44 EDT
Description of problem:
When choosing basic video mode on a 14 Beta TC1 i386 DVD install, when stage2 is supposed to start, there is a black screen and the machine is totally unresponsive. Therefore it's impossible to retrieve any logs, since nothing has been written to the hard drive. The behavior is exactly the same as bug 623956 except it happens on bare metal.

Smolt URL: http://www.smolts.org/client/show/pub_49b32bf0-4174-4537-bd84-37fc4aa1c614

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-2.3.0-1.fc14

How reproducible:
always
Comment 1 Andre Robatino 2010-09-13 08:37:23 EDT
I filed bug 472687 for this same machine, which might be relevant. Due to its crappy video hardware, getting the default video mode to work properly required the default color depth to be reduced from 24 to 16. (The default video mode DOES work, I did a default graphical install of F12 on this box a few months ago.)
Comment 2 Andre Robatino 2010-09-13 10:02:40 EDT
Created attachment 446934 [details]
/var/log/Xorg.0.log

This machine has no xorg.conf file.
Comment 3 Andre Robatino 2010-09-13 10:03:32 EDT
Created attachment 446936 [details]
/var/log/messages
Comment 4 Matěj Cepl 2010-09-13 11:41:03 EDT
Actually, according to Xorg.0.log this is not VESA which is used but Mach64.
Comment 5 Andre Robatino 2010-09-13 12:18:59 EDT
Created attachment 446980 [details]
/etc/X11/xorg.conf

Sorry, the problem is really in vesa. I ran "system-config-display --noui" to generate an xorg.conf file, changed the driver to vesa, then when I reboot, it fails to start X. This is in F12, so the problem is not new. I didn't realize it until now since the default driver works fine.
Comment 6 Andre Robatino 2010-09-13 12:20:27 EDT
Created attachment 446981 [details]
/var/log/Xorg.0.log
Comment 7 Andre Robatino 2010-09-13 12:21:37 EDT
Created attachment 446982 [details]
/var/log/messages
Comment 8 Andre Robatino 2010-10-14 15:47:23 EDT
This works now with F14 Final TC1. I remembered that there were some bug fixes involving reducing the color depth from 24 to 16, and changing the default resolution to 1024x768, and decided to test again. Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.