Bug 633437 - [6.1 FEAT] makedumpfile support - convert Linux on z dumps to ELF - userspace part
[6.1 FEAT] makedumpfile support - convert Linux on z dumps to ELF - userspace...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.1
s390x All
high Severity high
: beta
: 6.1
Assigned To: Dan Horák
qe-baseos-daemons
: FutureFeature, OtherQA
: 633423 (view as bug list)
Depends On:
Blocks: 633869 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-13 15:01 EDT by IBM Bug Proxy
Modified: 2011-05-19 09:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: s390utils-1.8.2-30.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:17:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
s390-tools-rhel6-zgetdump-zipl-mkdump.patch (218.44 KB, text/plain)
2010-12-01 11:41 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67049 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 15:01:59 EDT
1. Feature Overview:
Feature Id: [67049]
a. Name of Feature: [6.1 FEAT] makedumpfile support - convert Linux on z dumps to ELF - userspace part
b. Feature Description
This feature allows to convert s390 format dumps into ELF format dumps. This is needed in order to
be able to use makedumpfile tool.

This feature has different parts needed and tracked in different feature depending on the affected
component (kernel, binutils, crash, s390-tools).

The port of makedumfile to s390 is tracked by a different feature.

This concrete feature provides the s390-tools part:
zgetdump:
Currently zgetdump is used to copy dumps from DASD and tape dump devices using the s390 dump format.
This feature adds two new dump formats, ELF (source/target) and LKCD (target). Therefore the
zgetdump tool can read ELF, s390 and LKCD and write ELF and s390 format dumps and now can also be
used for dump format conversion. The ELF target format can be used to run the "makedumpfile" tool
as a second step to compress the dump.
Also a mount option based on "fuse" will be added to zgetdump so that dumps can be converted in
memory without the need of copying them (see zgetdump man page below for more details).
Three new options are added to zgetdump:
??? fmt: Specify target dump format (elf or s390)
??? mount: Mount the dump instead of copying it to standard output
??? umount: Unmout the dump (wrapper function for "fusermount -u")
The "???all" option of zgetdump will be removed. The rational behind this is that this option is not
very useful, only applicable for multi-volume tape dumps that are very rare and technically with the
required new code structure of zgetdump it is a lot of effort to reimplement this option. The
decission is that it is not worth the effort.

DASD and Tape dump tools (zipl) and vmconvert:
The ELF format contains register information in the dump header. Currently for s390 dumps the
register information is stored in the CPU prefix pages in the dumped memory. The dump analysis tools
find these pages using the global variable "lowcore_ptr". In order to do this the memory address of
this variable must be available. The analysis tools crash and lcrash get that address from the
System.map or vmlinux file. To be independent from those files, with this item the s390 and LKCD
dump format is extended to store this information in the dump header.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Backport
Category: other
Request Type: Package - Feature from IBM
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
The memory footprints of Linux on System z systems grow from year to year and therefore also system
dumps become sometimes so large that it is hard to work with them. For example transferring a 50 GB
dump over the network to a service organization can take a very long time. The "makedumpfile" open
source tool is used to compress system dumps by filtering out memory pages like free, user space or
cache pages that are not necessary for dump analysis.

This feature will improve and remove possible future restrictions in service, by enabling the
infrastructure needed to be able to use makedumfile on Linux on System z. 

4. Primary contact at Red Hat:
John Jarvis jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 IBM Bug Proxy 2010-10-04 11:16:39 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:36 EDT-------
Code Upstream Status: Accepted
Comment 3 John Jarvis 2010-10-04 14:18:49 EDT
IBM is signed up to test and provide feedback, setting OtherQA.
Comment 5 IBM Bug Proxy 2010-12-01 11:41:58 EST
Created attachment 464052 [details]
s390-tools-rhel6-zgetdump-zipl-mkdump.patch


------- Comment on attachment From brueckner@linux.vnet.ibm.com 2010-12-01 11:36 EDT-------


Summary:     zgetdump/zipl: Add ELF dump support (needed for makedumpfile)
Description: The zgetdump tool can be used now for dump format conversion.
             It can read ELF, s390, and LKCD and write ELF and s390 format
             dumps. A mount option based on "fuse" is added to zgetdump that
             allows dumps to be converted in memory on the fly without the
             need of copying them. The following two options are added to
             zgetdump:
             * fmt: Specify output dump format (elf or s390)
             * mount: Mount dump instead of copying it to standard output

             The zipl dump tools now store the prefix registers in the dump
             header.

             With this patch also multi-volume support for tape dump is 
             removed, because today's tape drives have enough capacity to
             store a dump on a single volume.
Comment 8 Ondrej Vasik 2010-12-06 08:00:19 EST
*** Bug 633423 has been marked as a duplicate of this bug. ***
Comment 9 John Jarvis 2011-01-13 14:41:32 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 13 Chris Ward 2011-04-06 07:14:34 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 14 IBM Bug Proxy 2011-04-11 12:02:07 EDT
------- Comment From mgrf@de.ibm.com 2011-04-11 11:57 EDT-------
This is verified on r 6.1 snapshots - set to verified  Thx
Comment 15 IBM Bug Proxy 2011-04-21 05:22:48 EDT
------- Comment From mgrf@de.ibm.com 2011-04-21 05:11 EDT-------
This is verified on R 6.1 snapshots - set to verified  Thx
Comment 16 errata-xmlrpc 2011-05-19 09:17:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0601.html

Note You need to log in before you can comment on or make changes to this bug.