Bug 634126 - Removing fence device instance may lead to retaining "zombie" items in "unfence" section(s) in cluster.conf
Removing fence device instance may lead to retaining "zombie" items in "unfen...
Status: CLOSED DUPLICATE of bug 622562
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Pokorný
Cluster QE
:
Depends On: 622562
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-15 06:14 EDT by Jan Pokorný
Modified: 2010-10-11 11:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 634188 634210 634212 (view as bug list)
Environment:
Last Closed: 2010-10-11 11:59:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2010-09-15 06:14:48 EDT
Description of problem:
This bug appeared with introduction of unfencing generation support which was a solution of bug #622562.
It is assumed that the only symptom of this bug is mentioned problem that when fence device instance is being removed, respective "device" xml-nodes (i.e. those referencing particular fence device instance by name) are not removed from "unfence" section(s). This leads to "zombie" items.

Version-Release number of selected component (if applicable):
Any having fix for bug #622562 applied (no official one for RHEL6 presently). This solution was committed to upstream git as two subsequent commits (ca226dabc8d51073322b44971b14c3ecdc94a686 + 847508ae4483685d3eb59ed47433c02562c6bf0f).

How reproducible:
Always.

Steps to Reproduce:
1. create new fence device instance (Fence Devices tab - Add), it has to be one of the fence devices that support unfencing (see https://bugzilla.redhat.com/show_bug.cgi?id=622562#c1)
2. display details to any node of particular cluster (on Nodes tab), add a fence method, then by this method, click "Add a Fence Instance", from the drop-down menu, select a fence device instance added in step 1, then make sure the "Unfencing" checkbox is checked and confirm (optionally, check the cluster.conf on a cluster's node)
3. go back to Fence Devices tab, select fence device instance added in step 1 and delete it -- if you check cluster.conf now, you can see that respective "device" xml-nodes in "unfence" section has not been removed as expected (in "fence" section, they were removed correctly)
Comment 3 Ryan McCabe 2010-10-11 11:59:23 EDT
Same bug as bug #622562. this fixes a corner case in the fix for that one.

*** This bug has been marked as a duplicate of bug 622562 ***

Note You need to log in before you can comment on or make changes to this bug.