Bug 622562 - Need to add support for unfencing conf. generation for SAN fencing agents and fence_scsi
Need to add support for unfencing conf. generation for SAN fencing agents and...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: Documentation, Rebase, ZStream
: 634126 (view as bug list)
Depends On:
Blocks: 634126 642140
  Show dependency treegraph
 
Reported: 2010-08-09 14:46 EDT by Perry Myers
Modified: 2011-05-19 09:56 EDT (History)
9 users (show)

See Also:
Fixed In Version: luci-0.23.0-10.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
If SAN fence devices (or SCSI fencing) are used, fence configuration must be performed after upgrading to a version of luci containing a fix for this bug. If SAN fencing is configured prior to upgrading luci, the unfence configuration will not be written to the cluster configuration file, which will cause fencing to not operate correctly. If this is the case, after upgrading luci, configuration for SAN fence agents must be removed and redone.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch with all necessary fixes (32.45 KB, patch)
2010-10-11 12:10 EDT, Ryan McCabe
no flags Details | Diff

  None (edit)
Description Perry Myers 2010-08-09 14:46:52 EDT
Description of problem:
Luci presently does not allow the user to configure unfencing which means that the SAN fencing agents and fence_scsi cannot be unfenced on system boot.

Need to add an option that is enabled by default for all of the SAN fence configuration pages to enable unfencing functionality.
Comment 1 Jan Pokorný 2010-08-13 13:14:27 EDT
This should be fixed as of commit http://git.fedorahosted.org/git?p=luci.git;a=commit;h=847508ae4483685d3eb59ed47433c02562c6bf0f

Following (storage) fence devices are affected, listed together with
appropriate action parameter for unfencing:

* brocade - enable
* mcdata  - enable
* scsi    - on
* sanbox2 - enable
Comment 3 Jan Pokorný 2010-09-15 06:18:21 EDT
(In reply to comment #1)
Only giving to know that a new bug in committed solution was found: bug #634126.
Comment 4 Jan Pokorný 2010-09-15 14:23:42 EDT
(In reply to comment #3)
Bug #634126 should be fixed.
Comment 12 Ryan McCabe 2010-10-11 11:59:24 EDT
*** Bug 634126 has been marked as a duplicate of this bug. ***
Comment 14 Ryan McCabe 2010-10-11 12:10:33 EDT
Created attachment 452754 [details]
Patch with all necessary fixes
Comment 17 Ryan McCabe 2010-10-11 13:07:04 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If SAN fence devices (or SCSI fencing) are used, fence configuration must be performed after upgrading to a version of luci containing a fix for this bug. If SAN fencing is configured prior to upgrading luci, the unfence configuration will not be written to the cluster configuration file, which will cause fencing to not operate correctly. If this is the case, after upgrading luci, configuration for SAN fence agents must be removed and redone.
Comment 40 Brian Brock 2011-04-13 14:22:10 EDT
thanks!

fix verified in luci-0.23.0-12.el6
Comment 41 errata-xmlrpc 2011-05-19 09:56:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0655.html

Note You need to log in before you can comment on or make changes to this bug.