Bug 6347 - Always takes 2 calls to ISP before logging in.
Always takes 2 calls to ISP before logging in.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 6461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-25 15:54 EDT by Karl Larsen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-05 22:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Larsen 1999-10-25 15:54:49 EDT
I started with ver 6.1 last week. UserNet did not have this
problem under ver 6.0. Found 3 listings in
/etc/ppp/pap-secrets and corrected to 1. This due to
mis-setting up rp3 early. No way to tell rp3 "use pap
stupid!" and I can't send you the connect-errors file that
might help.
Comment 1 Michael K. Johnson 1999-10-27 12:03:59 EDT
The problem with it taking two calls to log in is known but not
debugged.  This is in part because while I am occasionally able
to reproduce it, I cannot reproduce it with enough reliability
to know whether or not any particular change I make has an effect.
Every bit of information that you or anyone else with this problem
can provide will help.  Please include your modem brand, your ISP
name, the location of the POP that you dial into, whether you use
PAP/CHAP or login/password style authentication, and anything else
you can think of that might be relevant to the problem.  If you
see or hear from anyone else with the same problem, please encourage
them to add that information to this bug report, as the more
people who provide this information, the more likely it is that we
can find the patterns and fix the problem.

Regarding asking rp3 to do PAP authentication, you can ask for
PAP/CHAP (whichever the remote side requests) without doing
login/password authentication by choosing "Edit", clicking on
the "Advanced" tab, and then selecting the "Let PPP do all
authentication" option.  By default, wvdial (the program used
underneath which rp3 sets up) tries to autodetect which to
use, and it is normally successful.
Comment 2 Michael K. Johnson 1999-10-28 14:28:59 EDT
*** Bug 6461 has been marked as a duplicate of this bug. ***

G'day, I've recently installed 6.1, and love the new PPP
Dialer in gnome. However, I found that when I use the
applet, the first time it dials and disconnect, the second
time it connects fine. I thought it was just me, but a check
of deja.com revealed a few other people with the same
problem, and no resolution. Is it me, a bug, a feature?
Thanks a lot!
Comment 3 Michael K. Johnson 1999-10-28 15:52:59 EDT
Please fetch the file
ftp://people.redhat.com/johnsonm/pppd
and then copy it to /usr/sbin with
cp pppd /usr/sbin/pppd
(use cp instead of mv in order to preserve file permissions)

Then dial in, and send the newly-generated parts from
the /var/log/messages file.  Include all the pppd and WvDial
lines from a complete dialin session.

(This binary is identical to the one shipped with Red Hat Linux
6.1, except that it includes debugging information and has one
debugging statement added.)

(William D. Ezell: I've added you to the CC line because you
reported this bug in separate email.  I hope that's OK with
you.)
Comment 4 Michael K. Johnson 1999-10-29 12:50:59 EDT
Thanks, Karl, for running that test.  The instrumented pppd I put
up for ftp shows that we were barking up the wrong tree.

Several traces have shown that when dual-dialing occurs, it at
least usually (maybe always) coincides with PPP modules being
loaded.

Try running
  modprobe ppp_deflate
  modprobe bsd_comp
as root before bringing up the PPP interface and see if that
makes the dual-dial problem go away.

Also, try running
  rmmod ppp_deflace
  rmmod bsd_comp
  rmmod ppp
  rmmod slhc
before dialing and see if that causes the problem to recur.

Thanks!
Comment 5 Michael K. Johnson 1999-10-29 15:10:59 EDT
Karl reports that the modprobe commands cause the problem to go
away.  Thanks, Karl.  If anyone can reproduce this problem with
the ppp_deflate and bsd_comp modules loaded before bringing up
the ppp interface, please post here to let us know.
Comment 6 Michael K. Johnson 1999-10-30 12:37:59 EDT
Fixed William D. Ezell's address in the CC line.  Had copied
it with the spam protection in it before, sorry.

William D. Ezell: I've added you to the CC line because you
reported this bug in separate email.  I hope that's OK with
you.
Comment 7 wdezell 1999-10-31 10:00:59 EST
From wdezell@snowhill.com:  using USR Sportster 56K external,
login/passwd-style authentication.  Have toggeled the "Let PPP do all
authentication" option with no effect.  Can see from modem lights data
exchange occurs prior to disconnect.  Will post follow-up info as
found.
Comment 8 Michael K. Johnson 1999-11-03 14:45:59 EST
*** Bug 6506 has been marked as a duplicate of this bug. ***

After entering all parameters of my isp connection
(prodigy, chap, let ppp do all auth.), the connection
works fine when I press the debug button, i.e. ppp
comes and stays up. However, when starting the
connection using the normal rp3, it dials in and
immediately disconnect.
Reason might be, that rp3 modifies my chap-secrets
from "login * passwd" to "login ppp1 passwd".


------- Additional Comments From johnsonm@redhat.com  10/29/99 14:05 -------
Does it retry and succeed on a second dial attempt, or fail for
good?  What messages are stored in /var/log/messages?

------- Additional Comments From frese01@hotmail.com  11/01/99 09:54 -------
It does fail again on 2nd attempt and I do get a text error
message in the window that I started rp3 in:
"Failed to activate ppp1". As I said, it works in debug mode.
/var/log/messages for 2 failed attempts:

Nov  1 09:36:30 kitty pppd[7003]: pppd 2.3.10 started by root, uid 0
Nov  1 09:36:30 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1 at
115200
Nov  1 09:36:31 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:36:31 kitty WvDial: Initializing modem.
Nov  1 09:36:32 kitty WvDial: Sending: ATZ
Nov  1 09:36:32 kitty WvDial: ATZ
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:36:32 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Sending: ATM1L1
Nov  1 09:36:32 kitty WvDial: ATM1L1
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Modem initialized.
Nov  1 09:36:32 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:36:32 kitty WvDial: Waiting for carrier.
Nov  1 09:36:32 kitty WvDial: ATDT *70,829-9801
Nov  1 09:37:06 kitty WvDial: CONNECT 26400/ARQ/V34/LAPM/V42BIS
Nov  1 09:37:06 kitty WvDial: Carrier detected.  Starting PPP
immediately.
Nov  1 09:37:06 kitty pppd[7003]: Serial connection established.
Nov  1 09:37:06 kitty pppd[7003]: Using interface ppp0
Nov  1 09:37:06 kitty pppd[7003]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:37:14 kitty pppd[7003]: CHAP authentication failed
Nov  1 09:37:14 kitty pppd[7003]: Connection terminated.
Nov  1 09:37:14 kitty pppd[7003]: Hangup (SIGHUP)
Nov  1 09:37:14 kitty pppd[7003]: Exit.
Nov  1 09:37:17 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1 at
115200
Nov  1 09:37:17 kitty modprobe: can't locate module char-major-108
Nov  1 09:37:17 kitty pppd[7017]: pppd 2.3.10 started by root, uid 0
Nov  1 09:37:18 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:37:18 kitty WvDial: Initializing modem.
Nov  1 09:37:18 kitty WvDial: Sending: ATZ
Nov  1 09:37:18 kitty WvDial: ATZ
Nov  1 09:37:18 kitty WvDial: OK
Nov  1 09:37:18 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:37:18 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:37:18 kitty WvDial: OK
Nov  1 09:37:18 kitty WvDial: Sending: ATM1L1
Nov  1 09:37:19 kitty WvDial: ATM1L1
Nov  1 09:37:19 kitty WvDial: OK
Nov  1 09:37:19 kitty WvDial: Modem initialized.
Nov  1 09:37:19 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:37:19 kitty WvDial: Waiting for carrier.
Nov  1 09:37:19 kitty WvDial: ATDT *70,829-9801
Nov  1 09:37:50 kitty WvDial: CONNECT 26400/ARQ/V34/LAPM/V42BIS
Nov  1 09:37:50 kitty WvDial: Carrier detected.  Starting PPP
immediately.
Nov  1 09:37:50 kitty pppd[7017]: Serial connection established.
Nov  1 09:37:50 kitty pppd[7017]: Using interface ppp0
Nov  1 09:37:50 kitty pppd[7017]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:37:57 kitty pppd[7017]: CHAP authentication failed
Nov  1 09:37:58 kitty pppd[7017]: Connection terminated.
Nov  1 09:37:58 kitty pppd[7017]: Hangup (SIGHUP)
Nov  1 09:37:58 kitty pppd[7017]: Exit.


Now here's the log in debug mode:
 Nov  1 09:37:58 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1
at 115200
Nov  1 09:37:58 kitty modprobe: can't locate module char-major-108
Nov  1 09:37:58 kitty pppd[7035]: pppd 2.3.10 started by root, uid 0
Nov  1 09:37:59 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:37:59 kitty WvDial: Initializing modem.
Nov  1 09:37:59 kitty WvDial: Sending: ATZ
Nov  1 09:37:59 kitty WvDial: ATZ
Nov  1 09:37:59 kitty WvDial: OK
Nov  1 09:37:59 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:37:59 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:37:59 kitty WvDial: OK
Nov  1 09:37:59 kitty WvDial: Sending: ATM1L1
Nov  1 09:38:00 kitty WvDial: ATM1L1
Nov  1 09:38:00 kitty WvDial: OK
Nov  1 09:38:00 kitty WvDial: Modem initialized.
Nov  1 09:38:00 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:38:00 kitty WvDial: Waiting for carrier.
Nov  1 09:38:00 kitty WvDial: ATDT *70,829-9801
Nov  1 09:39:20 kitty modprobe: can't locate module char-major-108
Nov  1 09:39:20 kitty pppd[7083]: pppd 2.3.10 started by root, uid 0
Nov  1 09:39:20 kitty pppd[7083]: Using interface ppp0
Nov  1 09:39:20 kitty pppd[7083]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:39:27 kitty pppd[7083]: local  IP address 209.156.182.63
Nov  1 09:39:27 kitty pppd[7083]: remote IP address 209.156.107.160
Nov  1 09:39:27 kitty pppd[7083]: BSD-Compress (15/12) compression
enabled
Nov  1 09:39:27 kitty pppd[7083]: BSD-Compress (15/12) compression
enabled
Nov  1 09:39:40 kitty pppd[7083]: Terminating on signal 15.
Nov  1 09:39:41 kitty pppd[7083]: Connection terminated.
Nov  1 09:39:41 kitty pppd[7083]: Connect time 0.4 minutes.
Nov  1 09:39:41 kitty pppd[7083]: Sent 411 bytes, received 424 bytes.
Nov  1 09:39:41 kitty pppd[7083]: Exit.


In addition, when I tried debug-mode once more and then cancelled
it while dialing, I got another fatal error of 'rp3-config':
Gtk-WARNING **: invalid unclassed pointer in cast to `GtkText'

Gtk-CRITICAL **: file gtktext.c: line 940 (gtk_text_insert): assertion
`GTK_IS_TEXT (text)' failed.

Gtk-WARNING **: invalid unclassed pointer in cast to `GtkText'

(maybe this is because I'm running fvwm?).
In addition, I got an error
'rp3-config-WARNING **: Error reading from child: Bad file descriptor
'
(is this because I manually deleted /etc/wvdial.conf once? now it
is
-rw-------   1 root     root          554 Nov  1 09:39
/etc/wvdial.conf
[Modem0]
Modem = /dev/ttyS1
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L1

[Dialer Defaults]
Modem = /dev/ttyS1
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L1

[Dialer Prodigy]
Username = xxxxx
Password = xxxxx
Modem = /dev/ttyS1
Phone = xxxxx
Dial Prefix = *70
Baud = 115200
Stupid mode = 1
Inherits = Dialer Defaults

[Dialer Prodigy1]
Modem = /dev/ttyS0
Baud = 115200
Stupid mode = 0



------- Additional Comments From johnsonm@redhat.com  11/03/99 14:33 -------
OK, this is an instance of a very difficult-to-track-down bug that
we are currently working on fixing.
Comment 9 Michael K. Johnson 1999-11-03 14:58:59 EST
Oops, bug #6506 was not a duplicate, my bad.
Comment 10 Michael K. Johnson 1999-11-05 18:14:59 EST
Please try
ftp://people.redhat.com/johnsonm/ppp-23.10-2.i386.rpm
and see if it fixes the problem for you.

Thanks!
Comment 11 Michael K. Johnson 1999-11-05 22:46:59 EST
Karl reports via private email that the new pppd package fixes it
for him.  I'm going to look into a couple other bug reports before
making an errata release.  If you upgrade to this new package and
it does not solve the double-dial problem, please reopen this bug
with as much info as you can provide.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.