Bug 6506 - rp3 works in debug mode but not in normal mode
rp3 works in debug mode but not in normal mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-29 12:56 EDT by frese01
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-06 16:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frese01 1999-10-29 12:56:03 EDT
After entering all parameters of my isp connection
(prodigy, chap, let ppp do all auth.), the connection
works fine when I press the debug button, i.e. ppp
comes and stays up. However, when starting the
connection using the normal rp3, it dials in and
immediately disconnect.
Reason might be, that rp3 modifies my chap-secrets
from "login * passwd" to "login ppp1 passwd".
Comment 1 Michael K. Johnson 1999-10-29 14:05:59 EDT
Does it retry and succeed on a second dial attempt, or fail for
good?  What messages are stored in /var/log/messages?
Comment 2 frese01 1999-11-01 09:54:59 EST
It does fail again on 2nd attempt and I do get a text error
message in the window that I started rp3 in:
"Failed to activate ppp1". As I said, it works in debug mode.
/var/log/messages for 2 failed attempts:

Nov  1 09:36:30 kitty pppd[7003]: pppd 2.3.10 started by root, uid 0
Nov  1 09:36:30 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1 at
115200
Nov  1 09:36:31 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:36:31 kitty WvDial: Initializing modem.
Nov  1 09:36:32 kitty WvDial: Sending: ATZ
Nov  1 09:36:32 kitty WvDial: ATZ
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:36:32 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Sending: ATM1L1
Nov  1 09:36:32 kitty WvDial: ATM1L1
Nov  1 09:36:32 kitty WvDial: OK
Nov  1 09:36:32 kitty WvDial: Modem initialized.
Nov  1 09:36:32 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:36:32 kitty WvDial: Waiting for carrier.
Nov  1 09:36:32 kitty WvDial: ATDT *70,829-9801
Nov  1 09:37:06 kitty WvDial: CONNECT 26400/ARQ/V34/LAPM/V42BIS
Nov  1 09:37:06 kitty WvDial: Carrier detected.  Starting PPP
immediately.
Nov  1 09:37:06 kitty pppd[7003]: Serial connection established.
Nov  1 09:37:06 kitty pppd[7003]: Using interface ppp0
Nov  1 09:37:06 kitty pppd[7003]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:37:14 kitty pppd[7003]: CHAP authentication failed
Nov  1 09:37:14 kitty pppd[7003]: Connection terminated.
Nov  1 09:37:14 kitty pppd[7003]: Hangup (SIGHUP)
Nov  1 09:37:14 kitty pppd[7003]: Exit.
Nov  1 09:37:17 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1 at
115200
Nov  1 09:37:17 kitty modprobe: can't locate module char-major-108
Nov  1 09:37:17 kitty pppd[7017]: pppd 2.3.10 started by root, uid 0
Nov  1 09:37:18 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:37:18 kitty WvDial: Initializing modem.
Nov  1 09:37:18 kitty WvDial: Sending: ATZ
Nov  1 09:37:18 kitty WvDial: ATZ
Nov  1 09:37:18 kitty WvDial: OK
Nov  1 09:37:18 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:37:18 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:37:18 kitty WvDial: OK
Nov  1 09:37:18 kitty WvDial: Sending: ATM1L1
Nov  1 09:37:19 kitty WvDial: ATM1L1
Nov  1 09:37:19 kitty WvDial: OK
Nov  1 09:37:19 kitty WvDial: Modem initialized.
Nov  1 09:37:19 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:37:19 kitty WvDial: Waiting for carrier.
Nov  1 09:37:19 kitty WvDial: ATDT *70,829-9801
Nov  1 09:37:50 kitty WvDial: CONNECT 26400/ARQ/V34/LAPM/V42BIS
Nov  1 09:37:50 kitty WvDial: Carrier detected.  Starting PPP
immediately.
Nov  1 09:37:50 kitty pppd[7017]: Serial connection established.
Nov  1 09:37:50 kitty pppd[7017]: Using interface ppp0
Nov  1 09:37:50 kitty pppd[7017]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:37:57 kitty pppd[7017]: CHAP authentication failed
Nov  1 09:37:58 kitty pppd[7017]: Connection terminated.
Nov  1 09:37:58 kitty pppd[7017]: Hangup (SIGHUP)
Nov  1 09:37:58 kitty pppd[7017]: Exit.


Now here's the log in debug mode:
 Nov  1 09:37:58 kitty ifup-ppp: pppd started for ppp1 on /dev/ttyS1
at 115200
Nov  1 09:37:58 kitty modprobe: can't locate module char-major-108
Nov  1 09:37:58 kitty pppd[7035]: pppd 2.3.10 started by root, uid 0
Nov  1 09:37:59 kitty WvDial: WvDial: Internet dialer version 1.40
Nov  1 09:37:59 kitty WvDial: Initializing modem.
Nov  1 09:37:59 kitty WvDial: Sending: ATZ
Nov  1 09:37:59 kitty WvDial: ATZ
Nov  1 09:37:59 kitty WvDial: OK
Nov  1 09:37:59 kitty WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Nov  1 09:37:59 kitty WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Nov  1 09:37:59 kitty WvDial: OK
Nov  1 09:37:59 kitty WvDial: Sending: ATM1L1
Nov  1 09:38:00 kitty WvDial: ATM1L1
Nov  1 09:38:00 kitty WvDial: OK
Nov  1 09:38:00 kitty WvDial: Modem initialized.
Nov  1 09:38:00 kitty WvDial: Sending: ATDT *70,829-9801
Nov  1 09:38:00 kitty WvDial: Waiting for carrier.
Nov  1 09:38:00 kitty WvDial: ATDT *70,829-9801
Nov  1 09:39:20 kitty modprobe: can't locate module char-major-108
Nov  1 09:39:20 kitty pppd[7083]: pppd 2.3.10 started by root, uid 0
Nov  1 09:39:20 kitty pppd[7083]: Using interface ppp0
Nov  1 09:39:20 kitty pppd[7083]: Connect: ppp0 <--> /dev/ttyS1
Nov  1 09:39:27 kitty pppd[7083]: local  IP address 209.156.182.63
Nov  1 09:39:27 kitty pppd[7083]: remote IP address 209.156.107.160
Nov  1 09:39:27 kitty pppd[7083]: BSD-Compress (15/12) compression
enabled
Nov  1 09:39:27 kitty pppd[7083]: BSD-Compress (15/12) compression
enabled
Nov  1 09:39:40 kitty pppd[7083]: Terminating on signal 15.
Nov  1 09:39:41 kitty pppd[7083]: Connection terminated.
Nov  1 09:39:41 kitty pppd[7083]: Connect time 0.4 minutes.
Nov  1 09:39:41 kitty pppd[7083]: Sent 411 bytes, received 424 bytes.
Nov  1 09:39:41 kitty pppd[7083]: Exit.


In addition, when I tried debug-mode once more and then cancelled
it while dialing, I got another fatal error of 'rp3-config':
Gtk-WARNING **: invalid unclassed pointer in cast to `GtkText'

Gtk-CRITICAL **: file gtktext.c: line 940 (gtk_text_insert): assertion
`GTK_IS_TEXT (text)' failed.

Gtk-WARNING **: invalid unclassed pointer in cast to `GtkText'

(maybe this is because I'm running fvwm?).
In addition, I got an error
'rp3-config-WARNING **: Error reading from child: Bad file descriptor
'
(is this because I manually deleted /etc/wvdial.conf once? now it
is
-rw-------   1 root     root          554 Nov  1 09:39
/etc/wvdial.conf
[Modem0]
Modem = /dev/ttyS1
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L1

[Dialer Defaults]
Modem = /dev/ttyS1
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L1

[Dialer Prodigy]
Username = xxxxx
Password = xxxxx
Modem = /dev/ttyS1
Phone = xxxxx
Dial Prefix = *70
Baud = 115200
Stupid mode = 1
Inherits = Dialer Defaults

[Dialer Prodigy1]
Modem = /dev/ttyS0
Baud = 115200
Stupid mode = 0
Comment 3 Michael K. Johnson 1999-11-03 14:33:59 EST
OK, this is an instance of a very difficult-to-track-down bug that
we are currently working on fixing.
Comment 4 Michael K. Johnson 1999-11-03 14:45:59 EST
Try again to mark as a duplicate of bug #6347...

*** This bug has been marked as a duplicate of 6347 ***
Comment 5 Michael K. Johnson 1999-11-03 14:55:59 EST
Ack, no it's not a duplicate.  I read that wrong, sorry.

The "login ppp1 passwd" is correct -- putting a * in there is
not really good practice, and, in face, I don't particularily
like the fact that we put it there in debug mode, and will
probably change it in the future.  It's correct because we
set the remotename for pppd to "ppp1" which should tell it
what to look for.

Can you turn on pppd debugging by running
  echo "DEBUG=yes" >> /etc/sysconfig/network-scripts/ifcfg-ppp1
and then see if pppd is a bit more verbose about how and why
CHAP is failing?

Thanks,
Comment 6 frese01 1999-11-04 09:33:59 EST
I've put DEBUG=yes in /etc/sysconfig/network-scripts/ifcfg-ppp1
but it doesn't result in any more output in /var/log/messages.
At the command prompt, it again says 'Failed to activate ppp1'
and /var/log/messages says

Nov  4 00:01:33 kitty WvDial: Carrier detected.  Starting PPP
immediately.
Nov  4 00:01:33 kitty pppd[2466]: Serial connection established.
Nov  4 00:01:33 kitty pppd[2466]: Using interface ppp0
Nov  4 00:01:33 kitty pppd[2466]: Connect: ppp0 <--> /dev/ttyS1
Nov  4 00:01:39 kitty pppd[2466]: CHAP authentication failed
Nov  4 00:01:39 kitty pppd[2466]: Connection terminated.
Nov  4 00:01:39 kitty pppd[2466]: Hangup (SIGHUP)
Nov  4 00:01:39 kitty pppd[2466]: Exit.

I'm not sure if it makes a difference, but I have the ppp
compiled into my kernel, i.e. is not running as a module.
Comment 7 Michael K. Johnson 1999-11-08 11:30:59 EST
Aha!  I think I've seen the light here.  Could you try
echo 'PPPOPTIONS=noarch' >> /etc/sysconfig/network-scripts/ifcfg-ppp1
and see if that fixes the problem?
Comment 8 Michael K. Johnson 1999-11-08 14:21:59 EST
Ack, that was wrong!  I meant
echo 'PPPOPTIONS=noauth' >> /etc/sysconfig/network-scripts/ifcfg-ppp1
and mis-wrote.

We're going to be releasing a new initscripts with an equivalent
change shortly.
Comment 9 frese01 1999-11-10 10:05:59 EST
Nope, same problem: CHAP fails (no matter how often I let it dial).
Same error message 'Failed to activate ppp1'.
Report in /var/log/messages is 'pppd[901]: CHAP authentication
failed'.
Still works in debug mode. I'm using the current rp3:

kitty[~]15:rpm -qa | grep rp3
rp3-1.0.1-1

kitty[~]16:cat /etc/sysconfig/network-scripts/ifcfg-ppp1
DEVICE=ppp1
NAME=Prodigy
WVDIALSECT=Prodigy
MODEMPORT=/dev/ttyS1
LINESPEED=115200
PAPNAME=xxxxx
USERCTL=true
ONBOOT=no
DNS1=198.83.19.241
DNS2=198.83.19.244
DEBUG=yes
PPPOPTIONS=noauth
Comment 10 Michael K. Johnson 1999-11-19 15:24:59 EST
Does running "wvdial Prodigy" work from the command line?
Comment 11 frese01 1999-11-30 21:48:59 EST
Yes, 'wvdial Prodigy' works fine.

Just to give some details: My old chap-secrets file
contains a line w/ 'login * passwd'.
Just leaving that as it is, wvdial Prodigy worked.
Then I started rp3 and let it fail once. Now the
chap-secrets file contains both the line above and
the same with the star replaced by ppp1.
Calling wvdial Prodigy after that worked fine as well.
Comment 12 Nalin Dahyabhai 2000-02-05 00:25:59 EST
rp3 incorporated parts of the wvdial sources for its debug function, and called
wvdial for other things, which caused unusual things like this to happen.  Try
upgrading to rp3-1.0.7 and wvdial-1.4.1-2 from Raw Hide, which synchronizes both
trees.

You might also try unchecking the box in rp3's configuration screen that reads
"Let PPPD do all authentication" and let rp3 try to handle the CHAP
authentication instead.
Comment 13 Nalin Dahyabhai 2000-04-06 16:49:59 EDT
The wvdial dialer will only propagate changes from its configuration file to the
pap-secrets and chap-secrets file once it has verified that they are good, so
this is expected.  I'm going to mark this bug as resolved in 6.2 and in Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/).

Note You need to log in before you can comment on or make changes to this bug.