Bug 63511 - Custom fonts are not used if LANG=it_IT@euro
Custom fonts are not used if LANG=it_IT@euro
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: control-center (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 63459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-15 06:24 EDT by Marco Pratesi
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 11:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Pratesi 2002-04-15 06:24:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I select the following custom font:
helvetica (adobe), iso8859-15 bold, 14
The font is not used if LANG=it_IT@euro


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Havoc Pennington 2002-04-15 09:33:15 EDT
Can you "echo $LANG" and "cat /etc/sysconfig/i18n"

It's likely that you have an older version of Xlib that doesn't recognize
iso885915, this was fixed recently.
Comment 2 Marco Pratesi 2002-04-15 11:09:12 EDT
+Can you "echo $LANG" and "cat /etc/sysconfig/i18n"

echo $LANG
it_IT@euro

cat /etc/sysconfig/i18n
LANG="it_IT@euro"
SUPPORTED="en_US.iso885915:en_US:en:it_IT@euro:it_IT:it"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

+It's likely that you have an older version of Xlib that doesn't recognize
+iso885915, this was fixed recently.

My XFree packages are just the ones shipped with skipjack2.
Which package(s) should I upgrade?
XFree86-libs ?
Or I need to upgrade all XFree packages?
Comment 3 Owen Taylor 2002-04-15 11:23:29 EDT
Could you try the control-center-1.4.0.1-30 package in RawHide? I believe
that the theme selector in this package should fix your problem.
(It's not related to X, the problem is that the old theme selector
wrote font= lines into ~/.gtkrc, but to work with non-iso-8859-1 locales,
it needed to write fontset= lines.)
Comment 4 Marco Pratesi 2002-04-15 11:40:09 EDT
The control-center-1.4.0.1-30 package in RawHide fixes the bug.
Thank you.
Comment 5 Havoc Pennington 2002-04-15 12:44:27 EDT
*** Bug 63459 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.