This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 635244 - bluetooth/udev: Disable hid2hci by default
bluetooth/udev: Disable hid2hci by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
16
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-18 06:54 EDT by Alexander Holler
Modified: 2011-09-30 15:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: bluez-4.96-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:47:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Holler 2010-09-18 06:54:54 EDT
Description of problem:

By default hid2hci is enabled (see /lib/udev/rules.d/70-hid2hci.rules).
This is a very bad idea.
At least in F11 it was disabled by default and one had to use the HID2HCI_ENABLE in /etc/sysconfig/bluetooth to enable it which was the correct way to handle that.

If it is enabled by default, bluez needs to have a linkkey for bluetooth keyboards and mice, otherwise those aren't functioning. So currently all people who are using bluetooth keyboards and mice with a dongle which offers HID and HCI (e.g. all Logitech BT-keyboards) are unable to use them after Fedora got installed. The same happens with the Live-CDs (I just had that experience trying to restore a backup using a Fedora-Live-CD).

Currently the only workaround is to attach an USB-keyboard (and maybe mice), and to either disable the above udev-rule or pair with the device.
The correct way would be to leave the BT-dongle in HID mode until the user changes it.
Comment 1 Alexander Holler 2010-09-29 06:49:51 EDT
Because I'm just booted the graphics-testday-iso with kernel 2.6.35.4-28.fc14.x86_64 and udev-161-2.fc14.x86_64 and wondered why my keyboard and mouse are working:

My dongle has the IDs 046d:c70b and 046d:c70c and needs hiddev with kernel 2.6.35 in 70-hid2hci-rules. So the line

KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[35e]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

should be

KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[35bce]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

but this would disable the keyboard/mouse by default (even if it would be correct).
Comment 2 Alexander Holler 2010-09-29 06:53:52 EDT
My suggestion is to enter all IDs used in the line with hidraw in the line with hiddev too and to implement a switch to enable hid2hci only after it is enabled explicit by the user.
Comment 3 Hans de Goede 2011-09-05 13:44:03 EDT
Hi,

hid2hci has moved to bluez -> updating component.
After some discussion we've come to the conclusion to put hid2hci in its own optional (so not installed by default) package. Which should fix the issue
you are experiencing. People who actually want to operate the dongle in Bluetooth mode can install bluez-hid2hci to get the old behavior back.

Note this change will be in F-16 and later, we cannot change the behavior halfway through a release.

Regards,

Hans
Comment 4 Fedora Update System 2011-09-05 13:46:41 EDT
bluez-4.96-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bluez-4.96-3.fc16
Comment 5 Fedora Update System 2011-09-06 14:07:06 EDT
Package bluez-4.96-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluez-4.96-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/bluez-4.96-3.fc16
then log in and leave karma (feedback).
Comment 6 Alexander Holler 2011-09-27 17:00:10 EDT
Thanks.

Moving hidhci to it's own package which isn't installed by default seems to be a good solution for that problem.

I've just filed bug #741247 which is somewhat related and might be a reason why currently not that many people are affected by the problem described here.
Comment 7 Alexander Holler 2011-09-27 17:03:13 EDT
Oh, I just see that I've described the problem in bug #741247 here too. Haven't seen that at first, so bug #741247 is a dupe.

Sorry.
Comment 8 Fedora Update System 2011-09-30 15:46:59 EDT
bluez-4.96-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.