This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 741247 - wrong hid2hci (bluetooth) rules for Logitech devices
wrong hid2hci (bluetooth) rules for Logitech devices
Status: CLOSED DUPLICATE of bug 653244
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 07:36 EDT by Alexander Holler
Modified: 2011-09-27 17:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 17:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Holler 2011-09-26 07:36:51 EDT
I don't know why there are two rules for Logitech bluetooth devices, but the first rule for them in/lib/udev/rules.d/70-hid2hci.rules misses at least IDs 046d:c70b and 046d:c70c.

Kernel 2.6.40.4-5.fc15.x86_64 shows up a hiddev-device for such an adapter if the dongle is in HID-mode (after booted). So if it should be possible to put such an device into HCI-(bluetooth-)mode (which I assume is reason for that rule), the rule has to be expanded to use

ATTRS{idProduct}=="c70[35bce]"

instead of

ATTRS{idProduct}=="c70[35e]"

The problem is related to bug #635244. Because the rule is currently not working for (some) Logitech devices, they are only used in HID mode (no bluetooth), so users of those devices aren't affected by bug #635244, but it means too they can't use the bluetooth functionality.
Comment 1 Hans de Goede 2011-09-27 17:33:52 EDT
This is already fixed in the bluez-4.96-3.fc16 update which will be pushed to F-16 as soon as the beta freeze is lifted.

*** This bug has been marked as a duplicate of bug 653244 ***

Note You need to log in before you can comment on or make changes to this bug.