This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 635395 - ConsoleKit session not properly opened
ConsoleKit session not properly opened
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: LiveCD - Xfce (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-19 08:20 EDT by Christoph Wickert
Modified: 2010-09-20 20:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 635396 (view as bug list)
Environment:
Last Closed: 2010-09-20 20:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6685 None None None Never

  None (edit)
Description Christoph Wickert 2010-09-19 08:20:18 EDT
Description of problem:
ConsoleKit session is not properly opened on the F14 Beta RC2 image. Everything that uses dbus is basically broken.

Version-Release number of selected component (if applicable):
Fedora 14 Beta RC2 Xfce

How reproducible:
always

Steps to Reproduce:
1. Download the image from http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC2/Live/Fedora-14-Beta-i686-Live-XFCE/
1. Boot it
2. Try to connect wifi with nm-applet
  
Actual results:
Nothing happens

Expected results:
NM should connect to the wifi

Additional info:
Start nm-applet from the commandline, it will tell you that dbus gets blocked. This is an issue with ConsoleKit, see the thread on xfce4-dev:
http://foo-projects.org/pipermail/xfce4-dev/2010-September/028230.html
Comment 1 Kevin Fenzi 2010-09-20 17:47:10 EDT
I can't duplicate this with a live Xfce kvm guest from a nightly image. Seems
to connect fine and show everything... 

Perhaps you tested with a machine with lxdm enabled? 
Could this be an lxdm/consokekit interaction issue?

With
http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC2/Live/Fedora-14-Beta-i686-Live-XFCE/Fedora-14-Beta-i686-Live-XFCE.iso
everything also works fine here. 

Could it be hardware specific somehow or otherwise work in a kvm guest for some reason?
Comment 2 Adam Williamson 2010-09-20 17:52:00 EDT
I can't reproduce either. I can reproduce the LXDE bug, but not this one. With RC2 image (same exact one I wrote for you in fact :>) ck-list-sessions shows an active session with Seat1, wifi connect works to the same AP that fails with LXDE, automount of a USB stick works. Are you sure this actually affects XFCE?
Comment 3 Christoph Wickert 2010-09-20 18:08:34 EDT
I was pretty sure it was Xfce because IIRC you gave me the Xfce image during our QA session. Feel free to close this bug if you think it was LXDE and you are sure it doesn't happen in Xfce. I'm traveling ATM and therefor I cannot do any testing or debugging. I will continue once I'm home (tomorrow morning).
Comment 4 Adam Williamson 2010-09-20 18:22:07 EDT
I think I only gave you one image, I really don't recall which it was :/ in my testing I can reproduce this in LXDE, but not in XFCE. I'll leave it open for now, though, I'd like if you could just confirm when you get home.

BTW, I've had a pretty long conversation with jesse about the whole question of blocker bugs on XFCE/LXDE. we've identified a bunch of issues we'll need to escalate to many groups to resolve, but for the Beta, we're probably going to temporarily take the approach of treating LXDE/XFCE validation failure bugs as 'nice to haves' - so we'll take fixes through the freeze, but we won't actually delay the beta release for these bugs. We'd release the beta without the spin that failed validation, and possibly add it later when the failures are fixed.

The deadline for RC3 compose is likely to be early tomorrow US time, so probably about your afternoon (that's my best guess). So we'd really need the LXDE fix to be in by then to make Beta. Just to keep you in the loop :)
Comment 5 Christoph Wickert 2010-09-20 20:00:10 EDT
I have verified the Xfce image works, so I guess I was testing LXDE when I saw this. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.