Bug 635396 - ConsoleKit session not properly opened through LXDM
ConsoleKit session not properly opened through LXDM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: LXDE F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-19 08:24 EDT by Christoph Wickert
Modified: 2010-09-22 00:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 635395
Environment:
Last Closed: 2010-09-22 00:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2010-09-19 08:24:05 EDT
+++ This bug was initially created as a clone of Bug #635395 +++

Description of problem:
ConsoleKit session is not properly opened on the F14 Beta RC2 image. Everything that uses dbus is basically broken.

Version-Release number of selected component (if applicable):
Fedora 14 Beta RC2 LXDE

How reproducible:
always

Steps to Reproduce:
1. Download the image from http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC2/Live/Fedora-14-Beta-i686-Live-LXDE/
1. Boot it
2. Try to connect wifi with nm-applet
  
Actual results:
Nothing happens

Expected results:
NM should connect to the wifi

Additional info:
Start nm-applet from the commandline, it will tell you that dbus gets blocked. This is an issue with ConsoleKit, see the thread on xfce4-dev:
http://foo-projects.org/pipermail/xfce4-dev/2010-September/028230.html
Comment 1 Kevin Fenzi 2010-09-20 11:54:39 EDT
I can't duplicate this with a live Xfce kvm guest from a nightly image. Seems to connect fine and show everything... 

Perhaps you tested with a machine with lxdm enabled? 
Could this be an lxdm/consokekit interaction issue?

I'll test the exact rc2 xfce image now. 
Should this bug be really against lxde-common?
Comment 2 Kevin Fenzi 2010-09-20 12:05:11 EDT
With http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC2/Live/Fedora-14-Beta-i686-Live-XFCE/Fedora-14-Beta-i686-Live-XFCE.iso everything also works fine here. 

Could it be hardware specific somehow?

Other testing welcome.
Comment 3 John Watzke 2010-09-20 12:09:02 EDT
I'll download an image and give it a shot tonight.... My hardware seems to be breaking everything in RC2 right now :-P.
Comment 4 Adam Williamson 2010-09-20 16:48:14 EDT
I can reproduce this. NM can't connect to a wireless network. ck-list-sessions reports active = FALSE and is-local = FALSE. It also reports seat = 'Seat2', which is odd. My working GNOME installed system reports seat = 'Seat1'.

Running nm-applet at a terminal reports 'activate_connection_cb(): Connection activation failed: No user settings service available'.
Comment 5 Kevin Fenzi 2010-09-20 17:18:26 EDT
Adam: This is with an Xfce image? logging in via gdm?
Comment 6 Adam Williamson 2010-09-20 17:32:29 EDT
No. This bug is for LXDE. 635395 is the XFCE bug.
Comment 7 Kevin Fenzi 2010-09-20 17:47:16 EDT
Argh. Wrong bug. ;( 

I'll move my comments over there.
Comment 8 Adam Williamson 2010-09-20 17:58:56 EDT
Kevin and I think this may be a bug in LXDM.
Comment 9 Christoph Wickert 2010-09-20 18:24:44 EDT
Looks like it can be fixed with an update to LXDM git version, stay tuned.
Comment 10 Fedora Update System 2010-09-20 19:26:41 EDT
lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14
Comment 11 Adam Williamson 2010-09-20 19:56:24 EDT
So, the good news: this fix works (couldn't test automount right now, but I was able to connect to the wireless network connection that failed before, and ck-list-sessions output now matches other spins).

The bad news: this fix causes / exposes two SELinux issues:

https://bugzilla.redhat.com/show_bug.cgi?id=635895
https://bugzilla.redhat.com/show_bug.cgi?id=635897

nevertheless, marking 'verified'. Will track Dan down to look at the SELinux stuff.
Comment 12 Fedora Update System 2010-09-20 23:51:18 EDT
lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lxdm'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14
Comment 13 Fedora Update System 2010-09-22 00:08:31 EDT
lxdm-0.3.0-0.1.20100921gitcf9b2cbb.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.