Bug 63603 - Partion utility dumps when modifying partion sizes
Partion utility dumps when modifying partion sizes
Status: CLOSED DUPLICATE of bug 57864
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-04-16 01:10 EDT by Mike
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-16 01:11:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda Dump file (29.71 KB, text/plain)
2002-04-16 01:11 EDT, Mike
no flags Details

  None (edit)
Description Mike 2002-04-16 01:10:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 

Description of problem:
The Automatic Partition handler dumps when I try to modify certain settings for 
disk sizes when trying to install redhat.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Was able to reproduce bug on a PII p233 Partitioning a 15 Gig Drive

Using Graphical Installer 
1: Custom Install
2: Have Installer automatically do the work: First Option
3: Remove All Partions

/* This is what I have at this point */
free         s:1    e:1     < 1 free space
/dev/hda1    s:1    e:6     47 ext3 /boot    
/dev/hda2    s:7    e:1838  14371   /
/dev/hda3    s:1839 e:1870  251     swap
free         s:1871 e:1871  < 1 free space

4: Selected /dev/hda2
Menu listed
First Size Option = 700MB
Radio Button  Fill to max allowable size is checked

5: Edit the First Size Option to 14104 
6: Check the Radio Button  Fill all space up to,
7: Enter in that field 14104
8: Click the Ok Button

Actual Results:  CRASH
As it reports the issue and created an anacdump.txt dump file.

Expected Results:  Should have taken the command and created a disk partion 
with that size or reported a user error and requested the user to modify 
informaiton if it was out side the allowable scope for the disk size.

Additional info:
Comment 1 Mike 2002-04-16 01:11:40 EDT
Created attachment 53966 [details]
Anaconda Dump file
Comment 2 Jeremy Katz 2002-04-16 02:10:29 EDT

*** This bug has been marked as a duplicate of 57864 ***

Note You need to log in before you can comment on or make changes to this bug.