Bug 57864 - Anaconda crashed on attempt to modify auto-created partitions via Disk Druid
Anaconda crashed on attempt to modify auto-created partitions via Disk Druid
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 56645 58015 58802 58924 59364 59736 59874 62420 63603 63885 65750 66488 74397 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-28 18:09 EST by Subhendu Ghosh
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 12:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2001-12-28 18:09:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Selected auto-partitioning via Disk Druid with Preview during install
Attempting to edit partition size caused anaconda to crash.

Could not re-create.  Second install attempt with the above steps went
smoothly.
Attached traceback.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 350, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 778, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1323, in editCb
    self.editPartitionRequest(request)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1231, in
editPartitionRequest
    if self.refresh():
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1278, in refresh
    doPartitioning(self.diskset, self.partitions)
  File "/usr/lib/anaconda/autopart.py", line 743, in doPartitioning
    ret = growParts(diskset, requests, newParts)
  File "/usr/lib/anaconda/autopart.py", line 582, in growParts
    if ret == PARTITION_FAIL:
NameError: ret

Local variables in innermost frame:
lastFreeSize: None
freeSize: {'hda': 5205060L}
maxsect: 14329980L
maxUserSize: 14329980L
requests: <partitioning.Partitions instance at 84e6e10>
tmpint: 267349L
free: {'hda': [<PedPartition object at 8590228>]}
tmp: mountpoint: /home   type: ext3   uniqueID:25
  size: 7000M   requestSize: 7000M  grow: 1   max: 7000
  start: None   end: None   partnum: None
  drive: None   primary: None  
  format: 1, options: None  device: hda2, currentDrive: hda
  raidlevel: None  raidspares: None  raidmembers: []
n: 2

drive: hda
percent: 0.931842385517
newRequest: <partitioning.Partitions instance at 84b93a0>
newParts: 	hda1 <fsset.ext3FileSystem instance at 82d77c8> 47.0346679688
	hda2 <fsset.ext3FileSystem instance at 82d77c8> 6997.06054688
	hda3 <fsset.ext3FileSystem instance at 82d77c8> 6000.84228516
	hda4 None 6047.90771484
	hda5 <fsset.ext3FileSystem instance at 82d77c8> 2996.46826172
	hda6 <fsset.swapFileSystem instance at 831f148> 509.844726562

growList: [<partitioning.PartitionSpec instance at 85ae800>,
<partitioning.PartitionSpec instance at 83f7d38>]
min: 14329980L
max: 14329980L
cur: 14329980L
donegrowing: 0
growSize: {'hda': 7512}
sector_size: 512
cylsectors: 16065
inner_iter: 0
thisFreeSize: {'hda': 5205060L}
outer_iter: 1
request: mountpoint: /home   type: ext3   uniqueID:25
  size: 7000M   requestSize: 7000M  grow: 1   max: 7000
  start: None   end: None   partnum: None
  drive: None   primary: None  
  format: 1, options: None  device: hda2, currentDrive: hda
  raidlevel: None  raidspares: None  raidmembers: []
diskset: <partitioning.DiskSet instance at 8697918>
diff: 0L
imposedMax: 1
part: <PedPartition object at 8590350>
index: 0
startSize: 14329980L
grownList: []
maxFSSize: 4294961685L
origSize: {18: 512, 25: 7000}
lastDiff: 0
growable: {'hda': [<partitioning.PartitionSpec instance at 85ae800>,
<partitioning.PartitionSpec instance at 83f7d38>]}
growby: 4850295L
getFreeSpace: <function getFreeSpace at 8536468>

Dispatcher instance, containing members:
skipSteps: {'reconfigwelcome': 1, 'addswap': 1, 'indivpackage': 1,
'upgrademigratefs': 1, 'findpackages': 1, 'reconfigkeyboard': 1,
'makebootdisk': 1, 'authentication': 1, 'upgrademount': 1,
'confirmupgrade': 1, 'fdisk': 1, 'upgradeswapsuggestion': 1,
'upgrademigfind': 1, 'findinstall': 1, 'findrootparts': 1,
'reconfigcomplete': 1, 'upgradecontinue': 1}
dir: 1
id: InstallData instance, containing members:
  configFileData: {'Splashscreen': pixmaps/first.png, 'WelcomeScreen':
pixmaps/splash.png, 'TitleBar': pixmaps/anaconda_header.png, 'Title': Red
Hat Linux Beta}
  upgradeSwapInfo: None
  langSupport: Language instance, containing members:
    langList: None
    allSupportedLangs: None
    supported: []
    langNicks: None
    default: None

<snip>
Comment 1 Jeremy Katz 2002-01-02 17:49:37 EST
Fixed in CVS and the fix is available in the update disk located at
http://people.redhat.com/katzj/7.2-updates.img
Comment 2 Jeremy Katz 2002-01-07 00:50:45 EST
*** Bug 58015 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-01-07 00:51:06 EST
*** Bug 56645 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-01-24 17:24:47 EST
*** Bug 58802 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2002-01-28 12:02:01 EST
*** Bug 58924 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2002-01-28 12:05:01 EST
Fixed by

http://www.redhat.com/support/errata/RHBA-2002-016.html
Comment 7 Brent Fox 2002-02-06 22:13:56 EST
*** Bug 59364 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-02-14 15:32:03 EST
*** Bug 59874 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2002-02-19 02:32:54 EST
*** Bug 59736 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2002-03-31 13:16:17 EST
*** Bug 62420 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2002-04-16 02:10:24 EDT
*** Bug 63603 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2002-04-24 12:29:52 EDT
*** Bug 63885 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2002-06-04 11:29:09 EDT
*** Bug 65750 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2002-06-11 11:07:17 EDT
*** Bug 66488 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2002-09-23 16:40:30 EDT
*** Bug 74397 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.