Bug 63608 - Application reports an error when pressing Apply or OK
Application reports an error when pressing Apply or OK
Status: CLOSED DUPLICATE of bug 59017
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 03:39 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 10:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-16 03:39:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After starting the redhat-network-config tool and pressing the Apply
or OK button an unhandled exception is reported. This happens also
when no changes are made within the configuration.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start redhat-network-configuration tool
2. Press Apply

	

Actual Results:  Application chrashes.

Expected Results:  Application should not crash.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981, 
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 936, 
in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 833f938>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [	 ]*alias[	 ]+eth1[	 ]+
Comment 1 Harald Hoyer 2002-04-16 05:40:06 EDT
should be already fixed. Please retry with the version from CVS, rawhide or  
http://people.redhat.com/teg/neat/
Comment 2 Harald Hoyer 2002-06-26 10:17:27 EDT

*** This bug has been marked as a duplicate of 59017 ***

Note You need to log in before you can comment on or make changes to this bug.