Bug 6362 - hp 722c problems
hp 722c problems
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-25 22:55 EDT by spw5
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 14:54:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spw5 1999-10-25 22:55:57 EDT
I have an HP 722c and I just noticed that the new
printfilters have native support for my printer, however,
nothing seems to be working.  I open up printtool and select
add a printer, and it does not auto-detect my printer.  If I
manually select when I attempt to print any type of test
page it does not do anything, no matter what port I set the
printer to, so I do not know what is wrong with it or what I
am doing wrong.  I would appreciate any help.  Thank you
	Sean Waters
	spw5@cec.wustl.edu
Comment 1 Bill Nottingham 1999-10-26 11:03:59 EDT
Add

alias parport_lowlevel parport_pc

to your /etc/conf.modules.

*** This bug has been marked as a duplicate of 5680 ***
Comment 2 spw5 1999-10-26 16:40:59 EDT
I wish that the problem were that easy, however, I checked my
conf.modules and it already has that line, and I rebooted completely
just in case it had just appeared and tried again and printtool was
still not detecting any devices on any ports, and none of the print
tests work.  So I dunno if there is anything further you can do to
help, but I am open to suggestions.
Also I know the printer is plugged properly, because windows has no
problems with it
Comment 3 Bill Nottingham 1999-10-26 17:49:59 EDT
What do the contents of /proc/parport/0/autoprobe say if you do:

modprobe lp
modprobe parport_probe

?
Comment 4 spw5 1999-10-26 18:04:59 EDT
my /proc/parport directory is empty, so there is no /o/autoprobe file,
before or after I run those commands... I don't know what this means
unless I forgot to install something.
Comment 5 Bill Nottingham 1999-10-26 18:08:59 EDT
If you do 'modprobe lp', what does lsmod say?
Comment 6 spw5 1999-10-26 18:22:59 EDT
I will type what seems to be relevant form the lsmod:
Module		Size		Used by
parport_probe	3588		0(autoclean)(unused)
lp		4764		0(autoclean)(unused)
parport		8348		0(autoclean)[parport_probe lp]
Comment 7 Bill Nottingham 1999-10-26 18:31:59 EDT
Hmm... that seems to imply that the alias isn't getting propagated.

What do you have in /etc/conf.modules?
Comment 8 spw5 1999-10-26 18:43:59 EDT
This is my /etc/conf.modules:

alias eth0 3c59x
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start
alias sound es1371
Comment 9 Bill Nottingham 1999-10-26 18:48:59 EDT
OK, do the following:

rmmod lp
rmmod parport
insmod parport
insmod parport_pc
insmod lp

What does /proc/parport/0/autoprobe say, if it exists?

Do you have your parallel ports set to non-standard
I/O ports/IRQs?
Comment 10 spw5 1999-10-26 19:23:59 EDT
okay, I still don't have any /proc/parport/0 or anything in parport
for that matter, but the commands gave the following outputs:

rmmod lp
rmmod: module lp not loaded

rmmod parport
rmmod: module parport not loaded

insmod parport - just returned to next line nothing happened

insmod parport_pc
/lib/modules/2.2.13-7/misc/parport_pc.o: init_module: Device or
Resource Busy

insmod lp - just returned to next line didn't print anything out

I checked my bios and the settings for my parallel port are set to
auto and bi-directional, so that should be okay, unless I should set
it to enabled instead of auto?
Comment 11 spw5 1999-10-26 19:40:59 EDT
okay, I still don't have any /proc/parport/0 or anything in parport
for that matter, but the commands gave the following outputs:

rmmod lp
rmmod: module lp not loaded

rmmod parport
rmmod: module parport not loaded

insmod parport - just returned to next line nothing happened

insmod parport_pc
/lib/modules/2.2.13-7/misc/parport_pc.o: init_module: Device or
Resource Busy

insmod lp - just returned to next line didn't print anything out

I checked my bios and the settings for my parallel port are set to
auto and bi-directional, so that should be okay, unless I should set
it to enabled instead of auto?
Comment 12 spw5 1999-10-26 19:53:59 EDT
okay, I still don't have any /proc/parport/0 or anything in parport
for that matter, but the commands gave the following outputs:

rmmod lp
rmmod: module lp not loaded

rmmod parport
rmmod: module parport not loaded

insmod parport - just returned to next line nothing happened

insmod parport_pc
/lib/modules/2.2.13-7/misc/parport_pc.o: init_module: Device or
Resource Busy

insmod lp - just returned to next line didn't print anything out

I checked my bios and the settings for my parallel port are set to
auto and bi-directional, so that should be okay, unless I should set
it to enabled instead of auto?
Comment 13 spw5 1999-10-26 19:54:59 EDT
okay, I still don't have any /proc/parport/0 or anything in parport
for that matter, but the commands gave the following outputs:

rmmod lp
rmmod: module lp not loaded

rmmod parport
rmmod: module parport not loaded

insmod parport - just returned to next line nothing happened

insmod parport_pc
/lib/modules/2.2.13-7/misc/parport_pc.o: init_module: Device or
Resource Busy

insmod lp - just returned to next line didn't print anything out

I checked my bios and the settings for my parallel port are set to
auto and bi-directional, so that should be okay, unless I should set
it to enabled instead of auto?
Comment 14 spw5 1999-10-26 19:55:59 EDT
oops, sorry about the multiple posts, browser messed up =)
Comment 15 Bill Nottingham 1999-10-27 12:00:59 EDT
What does /proc/ioports say?
Comment 16 spw5 1999-10-27 12:58:59 EDT
this is /proc/ioports

0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
1000-1007 : ide0
1008-100f : ide1
1040-107f : es1371
1080-10ff : eth0
Comment 17 Bill Nottingham 1999-10-27 15:15:59 EDT
Hmm... I suppose the one IDE port could be causing a problem.

Could you see if you could specify the resources the
parallel port uses in the BIOS?
Comment 18 spw5 1999-10-27 15:57:59 EDT
I can change the base address and the irq, currently it is set to IRQ
7 and base address 378
Comment 19 Bill Nottingham 1999-10-27 15:58:59 EDT
Hmm... and doing 'modprobe parport_pc io=0x378 irq=7'
gives you 'device or resource busy'?
Comment 20 spw5 1999-10-27 16:04:59 EDT
doing modprobe parport_pc io=0x378 irq=7 doent give anything it just
returns to the next line
Comment 21 Bill Nottingham 1999-10-27 16:13:59 EDT
OK, once that's loaded, if you do 'modprobe lp', does the printer
then work?

If so, you'll probably want to add something like:
'options parport_pc io=0x378 irq=7' to your /etc/conf.modules.
Comment 22 spw5 1999-10-27 16:44:59 EDT
I did what you said and nothing happened still, I noticed in the KDE
print queue program that it gives a warning saying no daemen present?
Comment 23 spw5 1999-10-28 15:36:59 EDT
Okay, somehow or another now I can get my printer to be detected on
lp0 and it seems to be detecting it correctly, however, it still won't
print any of the test pages from printtool
Comment 24 Bill Nottingham 1999-10-29 11:16:59 EDT
What is in /var/spool/lpd/<printername>?
Comment 25 spw5 1999-11-01 13:54:59 EST
in /var/spool/lpd/lp there are the following files:
filter
general.cfg
lock
postscript.cfg
status
textonly.cfg
Comment 26 spw5 1999-11-04 04:10:59 EST
I was just wondering if you had figured anything out because you had
been very prompt with responses before now.  Thanks
Comment 27 Bill Nottingham 1999-11-04 11:46:59 EST
Hmm... it looks sane there.

Is lpd running?
Comment 28 spw5 1999-11-08 02:52:59 EST
yep, lpd gets started every time I boot
Comment 29 Bill Nottingham 1999-11-08 13:44:59 EST
OK, what are the contents of:
/etc/printcap
/var/spool/lpd/<name>/postscript.cfg?
Comment 30 Bill Nottingham 1999-11-08 13:54:59 EST
Really stupid question - which driver are you using?
Comment 31 spw5 1999-11-08 14:23:59 EST
/etc/printcap:
##PRINTTOOL3## LOCAL hp720 600x600 letter {} DeskJet720 Default {}
lp:\
	:sd=/var/spool/lpd/lp:\
	:mx#0:\
	:sh:\
	:lp=/dev/lp0:\
	:if=/var/spool/lpd/lp/filter:

/var/spool/lpd/lp/postscript.cfg:
GSDEVICE=hp720
RESOLUTION=600x600
COLOR=
PAPERSIZE=letter
EXTRA_GS_OPTIONS=""
REVERSE_ORDER=
PS_SEND_EOF=NO

#
# following is related to printing multiple pages per output page
#
NUP=1
RTLFTMAR=18
TOPBOTMAR=18

I am using the HP 710C/720C/722C driver
Comment 32 Bill Nottingham 1999-11-08 14:29:59 EST
Um... we don't ship that driver. That would definitely
cause a problem. Did you compile your own ghostscript/
patch printerdb?

If it's the ppm2ppa stuff, you'll need to either grab
rhs-printfilters-1.58 from the next Raw Hide, or use
the 6.0 rhs-printfilters, and copy
/usr/lib/rhs/rhs-printfilters/master-filter to
/var/spool/lpd/<name>/filter.

Note You need to log in before you can comment on or make changes to this bug.