Bug 636621 - Anaconda netinstall fails with missing 'storage' module
Anaconda netinstall fails with missing 'storage' module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept F14AnacondaBlocker
  Show dependency treegraph
 
Reported: 2010-09-22 13:55 EDT by Carl Roth
Modified: 2013-01-10 01:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 11:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2010-09-22 13:55:30 EDT
Description of problem:

Anaconda fails in setupLoggingFromOpts; it has not imported the 'storage' module in time to configure its 'anaconda_log'.

The error looks something like this:

  Traceback (most recent call last):
    File "/usr/bin/anaconda", line 555, in <module>
      setupLoggingFromOpts(opts)
    File "/usr/bin/anaconda", line 273, in setupLoggingFromOpts
      anaconda_log.setHandlersLevel(storage.storage_log.logger, level)
  NameError: global name 'storage' is not defined

Version-Release number of selected component (if applicable):

Anaconda 14.17.4, as included in the 14-RC3 installer bits.

How reproducible:

Always

Steps to Reproduce:
1. PXE-boot a system using the RC3 'install.img' stage2 image.  There may be other avenues to exercise this bug too.
2.
3.
  
Actual results:


Expected results:


Additional info:

See /usr/bin/anaconda:273 (I'm looking at it in git).  It tries to configure logging w.r.t. the storage module before that module has been imported.

It looks like this bug exists in git too.  For the time being I'll fix it by monkey-patching the imports in updates_disk_hook.py.
Comment 1 Adam Williamson 2010-10-01 12:38:32 EDT
This was discussed at the 2010-10-01 blocker review meeting. We agreed that this does not meet the criteria to be a release blocker (setting 'loglevel' is not covered in them), but should be accepted as a nice-to-have bug.
Comment 2 Chris Lumens 2010-10-01 13:18:26 EDT
Easy fix, committed to F14 branch.  dlehman can decide if he wants to take it for whatever branch he's doings builds from.
Comment 3 Fedora Update System 2010-10-06 18:02:15 EDT
anaconda-14.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14
Comment 4 Fedora Update System 2010-10-07 15:50:25 EDT
anaconda-14.18-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14
Comment 5 Adam Williamson 2010-10-18 21:02:51 EDT
Carl, are you able to test with F14 final TC1 - http://alt.fedoraproject.org/pub/alt/stage/14.TC1.1/ - to confirm that this is fixed? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2010-10-18 21:03:02 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Kamil Páral 2010-10-19 10:00:56 EDT
Tested with F14 Final TC1.1, anaconda works ok with option loglevel=debug.
Comment 8 Jesse Keating 2010-10-21 11:56:43 EDT
anaconda 14.22 is in stable.

Note You need to log in before you can comment on or make changes to this bug.