Bug 636825 - Fix instances of #!/usr/bin/env python in mailman
Fix instances of #!/usr/bin/env python in mailman
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: Patch
Depends On: 521888 605171
Blocks: 502912 1232737 521940 595715
  Show dependency treegraph
 
Reported: 2010-09-23 08:12 EDT by Jan Kaluža
Modified: 2016-07-12 09:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: mailman-2.1.12-17.el6
Doc Type: Bug Fix
Doc Text:
Because of a bug in the brp-python-compile script file, unnecessary /etc/mailman/mm_cfg.pyc and /etc/mailman/mm_cfg.pyo files were generated under certain circumstances. As a result, the Mailman build process could have failed. This update fixes the aforementioned bug by compiling Python script files manually so that the build process no longer fails.
Story Points: ---
Clone Of: 605171
: 1232737 (view as bug list)
Environment:
Last Closed: 2011-09-07 09:06:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Suzanne Yeghiayan 2011-02-15 16:43:11 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 6 Petr Kovar 2011-06-28 09:36:53 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Because of a bug in the brp-python-compile script file, unnecessary /etc/mailman/mm_cfg.pyc and /etc/mailman/mm_cfg.pyo files were generated under certain circumstances. As a result, the Mailman build process could have failed. This update fixes the aforementioned bug by compiling Python script files manually so that the build process no longer fails.
Comment 9 errata-xmlrpc 2011-09-07 09:06:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1275.html

Note You need to log in before you can comment on or make changes to this bug.