Bug 636887 - Mouse does not move in one (Ubuntu) guest, works in other guests
Mouse does not move in one (Ubuntu) guest, works in other guests
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 641980 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-23 11:26 EDT by Richard W.M. Jones
Modified: 2013-01-09 06:40 EST (History)
15 users (show)

See Also:
Fixed In Version: qemu-0.13.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 02:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Libvirt XML from MOUSE NOT WORKING guest (Ubuntu 10.04) (2.35 KB, text/plain)
2010-09-23 11:27 EDT, Richard W.M. Jones
no flags Details
Libvirt XML from MOUSE WORKING guest (CentOS 5.5) (2.12 KB, text/plain)
2010-09-23 11:28 EDT, Richard W.M. Jones
no flags Details
Xorg logfile from inside the NOT WORKING guest. (24.14 KB, text/plain)
2010-09-23 11:45 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2010-09-23 11:26:07 EDT
Description of problem:

The mouse does not move in one of my guests when
viewed using virt-viewer or the virt-manager console.
However the mouse works fine in other guests.

Version-Release number of selected component (if applicable):

virt-viewer-0.2.1-1.fc13.x86_64
virt-manager-0.8.5-1.fc14.noarch
gtk-vnc-0.4.1-6.fc14.x86_64

How reproducible:

This used to work ok in Fedora 13.

Steps to Reproduce:
1. Start guest.
2. Open console.
3. Click, move mouse etc.
  
Actual results:

No response in one guest.

Expected results:

Should work.

Additional info:

The pointer is being captured by virt-viewer, and using
Ctrl+Alt releases the pointer in the usual way.

I will attach dumpxml output from a non-working and a
working guest.
Comment 1 Richard W.M. Jones 2010-09-23 11:27:28 EDT
Created attachment 449248 [details]
Libvirt XML from MOUSE NOT WORKING guest (Ubuntu 10.04)
Comment 2 Richard W.M. Jones 2010-09-23 11:28:06 EDT
Created attachment 449249 [details]
Libvirt XML from MOUSE WORKING guest (CentOS 5.5)
Comment 3 Richard W.M. Jones 2010-09-23 11:29:19 EDT
Also in the not-working guest, mouse clicks are not
being "heard" by the guest.
Comment 4 Richard W.M. Jones 2010-09-23 11:45:34 EDT
Created attachment 449250 [details]
Xorg logfile from inside the NOT WORKING guest.
Comment 5 Daniel Berrange 2010-10-08 07:23:29 EDT
Could be caused by this QEMU problem.

http://patchwork.ozlabs.org/patch/67168/
Comment 6 Daniel Berrange 2010-10-08 07:25:34 EDT
Yep the Xorg log shows the vmmouse was activated, so re-assigning to QEMU

(II) VMWARE(0): VMMOUSE module was loaded
(II) VMWARE(0): vmmouse is available
(II) VMWARE(0): VMMOUSE DEVICE_INIT
(II) VMWARE(0): VMMOUSE DEVICE_ON
(II) VMWARE(0): vmmouse enabled
Comment 7 Richard W.M. Jones 2010-10-08 08:58:15 EDT
OK, is there a version of qemu I can test?
Comment 8 Fedora Update System 2010-10-19 02:00:49 EDT
qemu-0.13.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc14
Comment 9 Fedora Update System 2010-10-19 05:08:46 EDT
qemu-0.13.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc14
Comment 10 Justin M. Forbes 2010-10-19 15:25:37 EDT
*** Bug 641980 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-10-28 02:11:10 EDT
qemu-0.13.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.