Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
For bugs related to Red Hat Enterprise Linux 5 product line. The current stable release is 5.10. For Red Hat Enterprise Linux 6 and above, please visit Red Hat JIRA https://issues.redhat.com/secure/CreateIssue!default.jspa?pid=12332745 to report new issues.

Bug 636893

Summary: certmonger fails to start on new install
Product: Red Hat Enterprise Linux 5 Reporter: Dmitri Pal <dpal>
Component: certmongerAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED ERRATA QA Contact: Jenny Severance <jgalipea>
Severity: medium Docs Contact:
Priority: low    
Version: 5.5CC: jgalipea, nalin, rcritten
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: certmonger-0.30-4.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 636876
: 636894 (view as bug list) Environment:
Last Closed: 2011-01-13 22:48:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 636876    
Bug Blocks: 636894    

Description Dmitri Pal 2010-09-23 15:44:29 UTC
+++ This bug was initially created as a clone of Bug #636876 +++

Description of problem:

certmonger does not start when initially installed:

# /sbin/service start certmonger
Starting certmonger: Error connecting to D-Bus. [FAILED]

Restarting the messagebus service will let certmonger start.

# /sbin/service restart messagebus
# /sbin/service start certmonger

Comment 3 Jenny Severance 2010-11-12 20:49:26 UTC
verified:

[root@ibm-x3950m2-01 ~]# /sbin/service certmonger start
Starting certmonger: [  OK  ]

[root@ibm-x3950m2-01 ~]# ps -ef | grep certmonger
root     23194     1  0 15:46 ?        00:00:00 /usr/sbin/certmonger -S -p /var/run/certmonger.pid

[root@ibm-x3950m2-01 ~]# /sbin/service certmonger stop
Stopping certmonger: [  OK  ]

[root@ibm-x3950m2-01 ~]# ps -ef | grep certmonger
root     23210  7290  0 15:47 pts/0    00:00:00 grep certmonger

[root@ibm-x3950m2-01 ~]# /sbin/service certmonger start
Starting certmonger: [  OK  ]

[root@ibm-x3950m2-01 ~]# ps -ef | grep certmonger
root     23225     1  0 15:47 ?        00:00:00 /usr/sbin/certmonger -S -p /var/run/certmonger.pid

version:

[root@ibm-x3950m2-01 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.6 Beta (Tikanga)

certmonger-0.30-4.el5

Comment 5 errata-xmlrpc 2011-01-13 22:48:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0056.html