Bug 636894 - certmonger fails to start on new install
certmonger fails to start on new install
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: certmonger (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Nalin Dahyabhai
Jenny Galipeau
:
Depends On: 636876 636893
Blocks: 642407
  Show dependency treegraph
 
Reported: 2010-09-23 11:52 EDT by Dmitri Pal
Modified: 2011-05-19 09:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: certmonger-0.30-2
Doc Type: Bug Fix
Doc Text:
Previously, after installing the certmonger utility, the certmonger service failed to start. This occurred because the package installation did not signal the system bus daemon that it needed to re-read its configuration as to allow the certmonger daemon to connect to the bus. This update fixes the bug and the certmonger service can be started right after the installation.
Story Points: ---
Clone Of: 636893
Environment:
Last Closed: 2011-05-19 09:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Dmitri Pal 2010-09-23 11:53:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
After installing certmonger the system needs to be rebooted for the certmonger to start properly.
Comment 2 Nalin Dahyabhai 2010-10-19 16:47:56 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-After installing certmonger the system needs to be rebooted for the certmonger to start properly.+After installing certmonger, the system message bus daemon needs to be signalled to reload its configuration in order for it to allow the certmonger service to start properly.  This can be done by sending the dbus-daemon process a SIGHUP signal or by rebooting the system.  This will be handled automatically in subsequent releases of the certmonger package.
Comment 4 Ryan Lerch 2010-10-20 03:36:58 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-After installing certmonger, the system message bus daemon needs to be signalled to reload its configuration in order for it to allow the certmonger service to start properly.  This can be done by sending the dbus-daemon process a SIGHUP signal or by rebooting the system.  This will be handled automatically in subsequent releases of the certmonger package.+After installing certmonger, the system message bus daemon needs to be signalled to reload its configuration to allow the certmonger service to start properly.  To work around this issue, send the dbus-daemon process a SIGHUP signal, or, alterntively, reboot the system.
Comment 6 Kaleem 2011-03-11 04:20:51 EST
Verified

RHEL version:

[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 Beta (Santiago)

Certmonger version:

[root@localhost ~]# rpm -qi certmonger | head
Name        : certmonger                   Relocations: (not relocatable)
Version     : 0.34                              Vendor: Red Hat, Inc.
Release     : 1.el6                         Build Date: Fri 14 Jan 2011 08:30:16 PM IST
Install Date: Wed 09 Mar 2011 05:25:48 PM IST      Build Host: x86-004.build.bos.redhat.com
Group       : System Environment/Daemons    Source RPM: certmonger-0.34-1.el6.src.rpm
Size        : 683642                           License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://certmonger.fedorahosted.org
Summary     : Certificate status monitor and PKI enrollment client

Steps used to verify:

(1)install certmonger
 
   [root@localhost ~]# rpm -Uvh certmonger-0.34-1.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:certmonger             ########################################### [100%]

(2)start certmonger service

[root@localhost ~]# service certmonger start
Starting certmonger:                                       [  OK  ]

 
Results:
certmonger service started successfully after installation without sending SIGHUP signal to dbus-daemon or reboot of system.
Comment 7 Eva Kopalova 2011-05-02 13:02:08 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-After installing certmonger, the system message bus daemon needs to be signalled to reload its configuration to allow the certmonger service to start properly.  To work around this issue, send the dbus-daemon process a SIGHUP signal, or, alterntively, reboot the system.+Previously, after installing the certmonger utility, the certmonger service failed to start. This occurred because the package installation did not signal the system bus daemon that it needed to re-read its configuration as to allow the certmonger daemon to connect to the bus. This update fixes the bug and the certmonger service can be started right after the installation.
Comment 8 errata-xmlrpc 2011-05-19 09:07:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0570.html

Note You need to log in before you can comment on or make changes to this bug.