Bug 63699 - xmms file selector browser is broken
xmms file selector browser is broken
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: xmms (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 11:48 EDT by Michael Schwendt
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 14:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-04-17 11:48:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
With fully updated Skipjack-beta2, in XMMS I see the file selector not
displaying all directories and files in current directory. Most of the time it
hides every dir/file except "." and "..", but without reason, and it looks as if
either it has problems reading directories or displaying the results. I remember
this has not been the case with unmodified Skipjack-beta2.


Version-Release number of selected component (if applicable):
$ rpm -q xmms glibc
xmms-1.2.7-1
glibc-2.2.5-32


How reproducible:
Always

Steps to Reproduce:
[with KDE]
1. cd $HOME
2. rm -rf .xmms
3. xmms
4. press "L"
5. double-click ".." (parent dir)
6. repeat step 5 arbitrary times

Just browse a bit through sub-dirs forth and back. For me it is 100% reproducible.


Actual Results:  The "Directories" and/or the "Files" column does not show any
files/directories at all or only a few files (like current dir and parent dir).
You may need to click ".." more than once for that to happen.

Once you've reached the root dir, there's no way back, since only current dir
and parent dir are visible and clickable.

Interestingly, re-selecting a directory from the combo box helps and turns up
all hidden files and directories.


Expected Results:  All files and directories should have been displayed.

Additional info:

$ rpm -V xmms

Exiting XMMS gives the following with almost 99%:

Segmentation fault

You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report.
Comment 1 Nathan G. Grennan 2002-04-18 13:44:23 EDT
This bug is a duplicate of 63726.
Comment 2 Michael Schwendt 2002-04-18 14:23:02 EDT
63699 < 63726, so bug #63726 was later and is a duplicate of this one.

Note You need to log in before you can comment on or make changes to this bug.