Bug 63726 - File selection dialog window doesn't reliablely list contents when changing directories
File selection dialog window doesn't reliablely list contents when changing d...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gtk+ (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 17:59 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 20:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-04-17 17:59:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
If I select Play file in xmms it opens a new dialog window to list the avaiable
files to be opened. On the intitial open it opens and lists all the files and
directories in my home directory, but if I then double click on .. in the
directory list to go up a directory to /home I get a empty list except for . and
..    If I then double click on .  I get the directories and files that I should
have seen in the first place. This isn't a permissions problem, I have full
rights to see /home. I can navigate through the directory tree and it will do
this on again off again thing consistantly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start X Windows
2. start xmms
3. Right click on the window
4. Select Play file
5. Double click on ..
	

Actual Results:  Empty list of directories and files

Expected Results:  Full List of directories and files

Additional info:

I actually first noticed this in evolution with the file attachment selection.
This should affect any application based on gtk+ that uses the standard file
selection dialog.
Comment 1 petrosyan 2002-04-17 19:06:16 EDT
i have exactly the same bug in many different gnome applications ( GIMP, xmms ...)

it is really annoying
Comment 2 Owen Taylor 2002-04-17 20:09:18 EDT
Is this new in the last few days? There were some GtkFileSel changes
recently that shouldn't have broken anything, but...
Comment 3 Owen Taylor 2002-04-17 21:00:30 EDT
Fixed in gtk+-1.2.10-14
Comment 4 Owen Taylor 2002-04-17 21:10:52 EDT
Actually, missed an intermediate build. 1.2.10-14 was already done.
Building a 1.2.10-15 now with the patch.
Comment 5 Michael Schwendt 2002-04-18 14:23:52 EDT
Duplicate of bug #63699.

Note You need to log in before you can comment on or make changes to this bug.