Bug 637197 - [6.1 FEAT] Crash Utility support to read compressed/filtered dumpfile generated by makedumpfile for s390x
[6.1 FEAT] Crash Utility support to read compressed/filtered dumpfile generat...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash (Show other bugs)
6.1
s390x All
high Severity high
: beta
: 6.1
Assigned To: Dave Anderson
Han Pingtian
: FutureFeature, OtherQA
Depends On: 649070
Blocks: 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-24 11:01 EDT by IBM Bug Proxy
Modified: 2011-05-19 09:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: crash-5.1.1-1.el6
Doc Type: Enhancement
Doc Text:
The crash utility now supports compressed and/or filtered dump files generated by the makedumpfile utility on IBM System z.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:04:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash-5.0.0-23-s390_elf_and_diskdump_support.patch (backport) (24.65 KB, text/plain)
2010-11-15 21:31 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67491 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-24 11:01:16 EDT
1. Feature Overview:
Feature Id: [67491]
a. Name of Feature: [6.1 FEAT] Crash Utility support to read compressed/filtered dumpfile generated
by makedumpfile for s390x
b. Feature Description
Crash Utility support to read compressed/filtered s390 dumpfile.

This feature allows Crash Utility to read and analyze compressed and filtered dumpfile generated by
makedumpfile tool for s390.

We intend to push this change to upstream Crash Utility too.

This feature is dependent on makedumpfile port to zLinux feature.
The port of makedumfile to s390 is tracked by a different feature.


2. Feature Details:
Sponsor: LTC RAS
Architectures:  zSeries - 64 native, 

Arch Specificity: both
Affects Kernel Modules: No
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Update Version
d. Upstream Acceptance: Not Started
Sponsor Priority P3
f. Severity: high
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target: ---

3. Business Case
With zLinux gaining facility to report dumps in ELF core format and subsequently
compressing/filtering using makedumpfile tool, we'd want crash tool to be enhanced with the ability
to read/analyze these compressed/filtered dumps, as it does with other platforms.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael W. Wortman, wortman@us.ibm.com

Technical contact(s):
MAHESH J. SALGAONKAR, mahesh.salgaonkar@in.ibm.com
Comment 2 Dave Anderson 2010-09-24 11:18:25 EDT
> We intend to push this change to upstream Crash Utility too.

As is the case with BZ #633449 (Z dumps on ELF), I'll make this dependent
upon upstream acceptance as well.
Comment 3 IBM Bug Proxy 2010-10-04 12:25:31 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:14 EDT-------
Code Upstream Status: Not Started
Comment 4 John Jarvis 2010-10-04 14:41:16 EDT
IBM is signed up to test and provide feedback, setting OtherQA.
Comment 5 IBM Bug Proxy 2010-11-15 21:31:00 EST
Created attachment 460712 [details]
crash-5.0.0-23-s390_elf_and_diskdump_support.patch (backport)


------- Comment on attachment From mahesh@linux.vnet.ibm.com 2010-11-15 21:27 EDT-------


Please find the attached backport-ed patch that enables s390x elf as well as diskdump support. This patch cleanly applies on crash version (crash-5.0.0-23) shipped through RHEL6.0.

The patch has been tested on RHEL6.0 and works fine.
Comment 6 Dave Anderson 2010-11-16 09:46:51 EST
Patch posted upstream by mahesh@linux.vnet.ibm.com for review:

  https://www.redhat.com/archives/crash-utility/2010-November/msg00020.html

> The patch has been tested on RHEL6.0 and works fine.

Since there is no RHEL6 kernel support for this yet, and since the RHEL6
version of makedumpfile does not have this support, I need two sets
of files to test/verify this patch-set with:

  (1) vmlinux / vmcore  (ELF format)
  (2) vmlinux / vmcore  (makedumpfile-generated)

Obviously the vmlinux files can be the same, and for that matter it
would be helpful if the "makedumpfile-generated" vmcore was created
from the "ELF format" vmcore.

mahesh@linux.vnet.ibm.com does not have a Red Hat bugzilla account,
so can you pass this request on to IBM?
Comment 7 IBM Bug Proxy 2010-11-17 11:10:50 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-17 11:03 EDT-------
The s390 vmlinux and vmcore (in ELF format) is available at:

http://kernel.beaverton.ibm.com/~msalgaon/crash/s390_vmcore/

The dumpfiles generated by makedumpfile are available at:

http://kernel.beaverton.ibm.com/~msalgaon/crash/s390_vmcore/makedumpfile_generated/

Redhat may not have access to above urls. Can someone help me to make these files available to Redhat ?

Thanks,
-Mahesh.
Comment 8 Dave Anderson 2010-11-17 13:42:01 EST
We do not have access to http://kernel.beaverton.ibm.com.

Perhaps Steve Best can access them and transfer them inside Red Hat?
Comment 9 Steve Best 2010-11-17 14:09:49 EST
Dave,

just tried to access the files and I don't have access to them. once I get access to them I'll bring them over for you.

-Steve
Comment 10 Steve Best 2010-11-18 13:28:28 EST
Dave,

I placed the files on one of my systems. standard beaker password


 root@ibm-js12-06.rhts.eng.bos.redhat.com:/home/sbest/s390_vmcore/

 ls -all
total 1539048
drwxr-xr-x  2 root  root        4096 Nov 18 13:24 .
drwx------ 22 sbest sbest       4096 Nov 18 12:48 ..
-rw-r--r--  1 root  root    22799287 Nov 18 13:20 dumpfile_c_d_31
-rw-r--r--  1 root  root   298670834 Nov 18 13:21 dumpfile_compressed
-rw-r--r--  1 root  root   105503416 Nov 18 13:20 dumpfile_d_31
-rw-r--r--  1 root  root  1073744448 Nov 18 13:23 vmcore_elf
-rw-r--r--  1 root  root    73651456 Nov 18 13:24 vmlinux-2.6.32-71.el6.s390x

-Steve
Comment 11 Dave Anderson 2010-11-18 13:53:57 EST
(In reply to comment #10)
> Dave,
> 
> I placed the files on one of my systems. standard beaker password
> 
> 
>  root@ibm-js12-06.rhts.eng.bos.redhat.com:/home/sbest/s390_vmcore/
> 
>  ls -all
> total 1539048
> drwxr-xr-x  2 root  root        4096 Nov 18 13:24 .
> drwx------ 22 sbest sbest       4096 Nov 18 12:48 ..
> -rw-r--r--  1 root  root    22799287 Nov 18 13:20 dumpfile_c_d_31
> -rw-r--r--  1 root  root   298670834 Nov 18 13:21 dumpfile_compressed
> -rw-r--r--  1 root  root   105503416 Nov 18 13:20 dumpfile_d_31
> -rw-r--r--  1 root  root  1073744448 Nov 18 13:23 vmcore_elf
> -rw-r--r--  1 root  root    73651456 Nov 18 13:24 vmlinux-2.6.32-71.el6.s390x
> 
> -Steve

Got 'em...

Thanks for your help!
Comment 12 IBM Bug Proxy 2010-11-25 23:00:58 EST
------- Comment From mahesh@linux.vnet.ibm.com 2010-11-25 22:51 EDT-------
Hi Dave,

Will this backport patch go into RHEL6.1?
Comment 13 Dave Anderson 2010-11-27 07:53:59 EST
(In reply to comment #12)
> ------- Comment From mahesh@linux.vnet.ibm.com 2010-11-25 22:51 EDT-------
> Hi Dave,
> 
> Will this backport patch go into RHEL6.1?

That's the plan, yes...
Comment 18 Dave Anderson 2010-12-01 09:42:48 EST
Patch applied in upstream version 5.1.0:

  http://people.redhat.com/anderson/crash.changelog.html

     - Implemented support for s390x compressed kdump dumpfiles created
       by the makedumpfile facility.
       (mahesh@linux.vnet.ibm.com)
Comment 19 John Jarvis 2010-12-03 09:10:04 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 25 Jaromir Hradilek 2011-04-27 15:21:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The crash utility now supports compressed and/or filtered dump files generated by the makedumpfile utility on IBM System z.
Comment 26 errata-xmlrpc 2011-05-19 09:04:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0561.html

Note You need to log in before you can comment on or make changes to this bug.