Bug 649070 - Rebase request for crash utility RHEL6.1 errata
Rebase request for crash utility RHEL6.1 errata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash (Show other bugs)
6.1
All Linux
high Severity high
: rc
: 6.1
Assigned To: Dave Anderson
Kernel Dump QE
: Rebase
Depends On:
Blocks: 633449 637197 637735 649050 649051 649053
  Show dependency treegraph
 
Reported: 2010-11-02 17:01 EDT by Dave Anderson
Modified: 2011-05-19 09:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: crash-5.1.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump and virsh dump facilities. With this update, Crash has been rebased to upstream version 5.1.1. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2010-11-02 17:01:34 EDT
Description of problem:

The RHEL6.1 errata version of crash should be rebased to the current
upstream version of the crash utility.

It is far more efficient, and far safer, to rebase to the upstream 
version than to attempt to selectively backport the patches required for
the current set of bugzillas requested for RHEL6.1.  Furthermore, the new
features and other fixes that have been applied to the upstream version 
make the tool significantly more useful than the current RHEL6 version.

I can confidently state the above primarily because I am the original
author, the upstream maintainer, and the Red Hat maintainer of the crash
utility.

As the upstream maintainer, one of my primary goals is, and always has
been, to maintain backwards-compatibility whenever new fixes or features
are applied.  Therefore the risk of regression is less with a rebase than
it would be with selective backports because the RHEL6.1 bugzilla-requested
fixes are based upon the state of the upstream version. 

It should be noted that nothing goes into the upstream version without
my approval, and my testing.  I perform all my testing on RHEL6 systems,
and test changes against a sample set of RHEL3, RHEL4, RHEL5, upstream
and Fedora kernel crash dumps.

And lastly, there have been several new debugging features added to the
upstream version that can only serve to aid our support and development
personnel in dealing with customer crashes more efficiently.  Details
regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html

Version-Release number of selected component (if applicable):

crash-5.0.0-23.el6

The current upstream version is 5.0.9, and typically gets updated
monthly.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Dave Anderson 2010-11-03 09:04:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
he crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
and virsh dump facilities.

With this update, Crash has been rebased to upstream version 5.x.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 6 Dave Anderson 2011-01-10 16:25:09 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
 he crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
 and virsh dump facilities.
 
-With this update, Crash has been rebased to upstream version 5.x.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html+With this update, Crash has been rebased to upstream version 5.1.1. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 8 Han Pingtian 2011-01-10 22:11:01 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
-he crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
+The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
 and virsh dump facilities.
 
 With this update, Crash has been rebased to upstream version 5.1.1. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 11 errata-xmlrpc 2011-05-19 09:04:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0561.html

Note You need to log in before you can comment on or make changes to this bug.